Please merge in changes tro allow partman-uboot to be used with ubiquity

Bug #455713 reported by Michael Casadevall on 2009-10-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
partman-auto (Ubuntu)
Undecided
Michael Casadevall
Karmic
Undecided
Michael Casadevall
ubiquity (Ubuntu)
Undecided
Michael Casadevall
Karmic
Undecided
Michael Casadevall

Bug Description

Binary package hint: ubiquity

The attached branches adds support for ubiquity to use partman-uboot on armel+dove. partman-uboot adds checks to confirm the partitioning layout is acceptable for boards using uboot to properly startup during manual partitioning and also properly passes options to mkfs.ext2 so that u-boot will be able to read the resulting filesystem in all cases. In addition, changes to partman-auto are desired to have it use uboot filesystem over pure ext2.

Changed in partman-auto (Ubuntu):
milestone: none → ubuntu-9.10
Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-9.10
Loïc Minier (lool) on 2009-10-19
Changed in partman-auto (Ubuntu Karmic):
status: New → In Progress
assignee: nobody → Michael Casadevall (mcasadevall)
Changed in ubiquity (Ubuntu Karmic):
assignee: nobody → Michael Casadevall (mcasadevall)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.0.1

---------------
ubiquity (2.0.1) karmic; urgency=low

  [ Evan Dandrea ]
  * Check to see whether X crashed or ubiquity crashed before attempting
    to bail into the noninteractive frontend from only-ubiquity mode
    (LP: #444901).
  * Wrap the format warning label while working around GTK+ label layout
    problems (LP: #364617).

  [ Colin Watson ]
  * Rewrite X_LOADTEMPLATEFILE commands in case they refer to template files
    in the /target chroot (LP: #452118).
  * Install -generic-pae kernels if necessary; this requires some custom
    hacks since -generic-pae isn't in the live filesystem (LP: #413135).
  * Don't do kernel installation/removal in oem-config.
  * Skip partition_too_small check during Wubi installs, as Wubi does some
    of its own checks and the delay imposed by this check looks particularly
    weird in Wubi. This may or may not be the cause of apparent hangs
    towards the end of partitioning, but I suspect that it will at least get
    rid of some conflated reports and make testing quicker.
  * Update translations from Launchpad.
  * Automatic update of included source packages: clock-setup 0.98ubuntu3,
    flash-kernel 2.13ubuntu13, grub-installer 1.43ubuntu6, partman-auto
    89ubuntu2, partman-target 64ubuntu4.

  [ Mario Limonciello ]
  * Mythbuntu: Don't allow "removing" LIRC as it's not supported with install.

  [ Roman Shtylman ]
  * Fixed India timezone map (LP: #453009)

  [ Michael Casadevall ]
  * Added support for partman-uboot in ubiquity (LP: #455713)

 -- Colin Watson <email address hidden> Tue, 20 Oct 2009 01:20:06 +0100

Changed in ubiquity (Ubuntu Karmic):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 89ubuntu2

---------------
partman-auto (89ubuntu2) karmic; urgency=low

  * Change armel+dove automatic partitioning to use the uboot pseudo-filesystem
    instead of ext2. (LP: #455713)

 -- Michael Casadevall <email address hidden> Tue, 20 Oct 2009 00:05:50 +0100

Changed in partman-auto (Ubuntu Karmic):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers