install on dmraid: GrubInstaller failed with code 10

Bug #452118 reported by Tormod Volden on 2009-10-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub-installer (Ubuntu)
Undecided
Colin Watson
ubiquity (Ubuntu)
Undecided
Colin Watson

Bug Description

Binary package hint: ubiquity

Testing Desktop installation from 20091015 (i386), on a fakeraid. Everything goes fine until grub is going to be installed, then ubiquity just dies (silently).

At this point /target/boot/grub is empty.

ProblemType: Bug
Architecture: i386
Date: Thu Oct 15 14:34:06 2009
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha i386 (20091015)
Package: ubiquity 2.0.0
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.46-generic
SourcePackage: ubiquity
Uname: Linux 2.6.31-14-generic i686

Tormod Volden (tormodvolden) wrote :
Tormod Volden (tormodvolden) wrote :
Tormod Volden (tormodvolden) wrote :
Tormod Volden (tormodvolden) wrote :
Colin Watson (cjwatson) on 2009-10-15
Changed in grub-installer (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: New → Fix Committed
Changed in ubiquity (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package grub-installer - 1.43ubuntu6

---------------
grub-installer (1.43ubuntu6) karmic; urgency=low

  * Always use GRUB Legacy when /boot is on a multipath device.
  * If /boot is on SATA RAID or multipath, don't ask a question to which
    there's only one acceptable answer and the other causes grub-installer
    to fall over (LP: #452118).

 -- Colin Watson <email address hidden> Thu, 15 Oct 2009 15:14:54 +0100

Changed in grub-installer (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.0.1

---------------
ubiquity (2.0.1) karmic; urgency=low

  [ Evan Dandrea ]
  * Check to see whether X crashed or ubiquity crashed before attempting
    to bail into the noninteractive frontend from only-ubiquity mode
    (LP: #444901).
  * Wrap the format warning label while working around GTK+ label layout
    problems (LP: #364617).

  [ Colin Watson ]
  * Rewrite X_LOADTEMPLATEFILE commands in case they refer to template files
    in the /target chroot (LP: #452118).
  * Install -generic-pae kernels if necessary; this requires some custom
    hacks since -generic-pae isn't in the live filesystem (LP: #413135).
  * Don't do kernel installation/removal in oem-config.
  * Skip partition_too_small check during Wubi installs, as Wubi does some
    of its own checks and the delay imposed by this check looks particularly
    weird in Wubi. This may or may not be the cause of apparent hangs
    towards the end of partitioning, but I suspect that it will at least get
    rid of some conflated reports and make testing quicker.
  * Update translations from Launchpad.
  * Automatic update of included source packages: clock-setup 0.98ubuntu3,
    flash-kernel 2.13ubuntu13, grub-installer 1.43ubuntu6, partman-auto
    89ubuntu2, partman-target 64ubuntu4.

  [ Mario Limonciello ]
  * Mythbuntu: Don't allow "removing" LIRC as it's not supported with install.

  [ Roman Shtylman ]
  * Fixed India timezone map (LP: #453009)

  [ Michael Casadevall ]
  * Added support for partman-uboot in ubiquity (LP: #455713)

 -- Colin Watson <email address hidden> Tue, 20 Oct 2009 01:20:06 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Sven Müller (svenho) wrote :

While installing Ubuntu 9.10 RC on my Nvidia Fakeraid (Raid 1), grub installation failed with an error without any reason (s.th. like "grub installation failed"). Afterwards the Live Desktop was booted.. /#rootdisk#/boot/grub was empty and thus booting from harddisk fails with "Error 15".

I hope this can be fixed until release - do you need more debugging information?

Tormod Volden (tormodvolden) wrote :

Sven, please file a new bug for your issue. This bug has been closed because the issue in this report has been fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers