When the installation becomes the 80% and it's creating the new user it simple crashes.

Bug #442998 reported by elfio on 2009-10-05
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
partman-target (Ubuntu)
High
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

The PC is a XPS M1330, processor T8100, 1 Gb Ram and a Intel X3100 video card.
I tried to install the beta version (i386 and amd64, the both have the same bug) and the installation go ok until it creates the new user. Then is when it crashes and close the window without more information.

I attached some logs.

Thanks.

ProblemType: Bug
Architecture: i386
Date: Mon Oct 5 12:09:30 2009
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Beta i386 (20090929.2)
Package: ubiquity 1.99.28
ProcEnviron:
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
SourcePackage: ubiquity
Uname: Linux 2.6.31-11-generic i686

elfio (helfio) wrote :
Evan (ev) wrote :

It appears as though finish.d/clear_partitions is setting the uid and gid of the to-be-created user to 0.

Changed in partman-target (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-target - 64ubuntu2

---------------
partman-target (64ubuntu2) karmic; urgency=low

  * Do not ever set the UID and GID for the to-be-created user to 0 in
    clear_partitions (LP: #442998).

 -- Evan Dandrea <email address hidden> Mon, 05 Oct 2009 13:17:08 +0100

Changed in partman-target (Ubuntu):
status: Confirmed → Fix Released
tags: added: ubiquity-1.99.28
tags: added: karmic
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete

This issue has sat incomplete for more than 60 days now. I'm going to close it as invalid. Please feel free re-open if this is still an issue for you. Thank you.

Changed in ubiquity (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers