Ubuntu

[BackTrack 4] cannot create /target/etc/default/locale: Directory nonexistent

Reported by Rejeesh on 2009-09-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

i have tried installing BT4 in my laptop...
But i am getting the following error
Traceback (most recent call last):
  File "/usr/lib/ubiquity/bin/ubiquity", line 229, in <module>
    main()
  File "/usr/lib/ubiquity/bin/ubiquity", line 226, in main
    install()
  File "/usr/lib/ubiquity/bin/ubiquity", line 68, in install
    ret = wizard.run()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 437, in run
    self.progress_loop()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 825, in progress_loop
    (ret, realtb))
RuntimeError: Install failed with exit code 1
Traceback (most recent call last):
  File "/usr/share/ubiquity/install.py", line 2112, in <module>
    install.run()
  File "/usr/share/ubiquity/install.py", line 368, in run
    self.configure_locales()
  File "/usr/share/ubiquity/install.py", line 1041, in configure_locales
    raise InstallStepError("LanguageApply failed with code %d" % ret)
InstallStepError: LanguageApply failed with code 2

Can somebody help me.......

Rejeesh (rejeesh076) wrote :
Evan Dandrea (ev) wrote :

Please run the installer in debug mode (`ubiquity -d` from a terminal window), and attach /var/log/syslog and /var/log/installer/debug when it crashes. Further instructions can be found at https://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs

Thanks!

Changed in ubiquity (Ubuntu):
status: New → Incomplete
  • debug Edit (1.9 MiB, application/octet-stream; name=debug)
  • syslog Edit (127.6 KiB, application/octet-stream; name=syslog)

Hi,

Please find the requested logs attached.

Regards,
Rejeesh

On Sat, Sep 19, 2009 at 12:46 PM, Evan Dandrea <email address hidden> wrote:
> Please run the installer in debug mode (`ubiquity -d` from a terminal
> window), and attach /var/log/syslog and /var/log/installer/debug when it
> crashes.  Further instructions can be found at
> https://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs
>
> Thanks!
>
> ** Changed in: ubiquity (Ubuntu)
>       Status: New => Incomplete
>
> --
> BT4 installer crashed
> https://bugs.launchpad.net/bugs/433132
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “ubiquity” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: ubiquity
>
> i have tried installing BT4 in my laptop...
> But i am getting the following error
> Traceback (most recent call last):
>  File "/usr/lib/ubiquity/bin/ubiquity", line 229, in <module>
>    main()
>  File "/usr/lib/ubiquity/bin/ubiquity", line 226, in main
>    install()
>  File "/usr/lib/ubiquity/bin/ubiquity", line 68, in install
>    ret = wizard.run()
>  File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 437, in run
>    self.progress_loop()
>  File "/usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py", line 825, in progress_loop
>    (ret, realtb))
> RuntimeError: Install failed with exit code 1
> Traceback (most recent call last):
>  File "/usr/share/ubiquity/install.py", line 2112, in <module>
>    install.run()
>  File "/usr/share/ubiquity/install.py", line 368, in run
>    self.configure_locales()
>  File "/usr/share/ubiquity/install.py", line 1041, in configure_locales
>    raise InstallStepError("LanguageApply failed with code %d" % ret)
> InstallStepError: LanguageApply failed with code 2
>
>
> Can somebody help me.......
>

Evan Dandrea (ev) on 2009-10-19
summary: - BT4 installer crashed
+ [BackTrack 4] cannot create /target/etc/default/locale: Directory
+ nonexistent
Evan Dandrea (ev) wrote :

Rejeesh,

What was the exact image you downloaded of BT4 (a link to the file would be fantastic) and what steps did you take upon booting to get into ubiquity and start an install. I believe you're seeing this bug due to a misconfiguration of the live environment used in that CD, but I cannot know for sure until I know exactly which CD you used.

Thanks!

Evan Dandrea (ev) wrote :

The relevant portion of the syslog that led me to the aforementioned conclusion:

Sep 20 12:29:51 bt python: mkdir /var/lib/ubiquity/source
Sep 20 12:29:51 bt python: log-output -t ubiquity mount --bind /mnt/live/lib/modules/2.6.28.1/kernel/drivers /var/lib/ubiquity/source
Sep 20 12:29:51 bt ubiquity: Sep 20 12:29:51 ubiquity: Starting up '['log-output', '-t', 'ubiquity', '--pass-stdout', 'sh', '-c', '/usr/lib/ubiquity/localechooser/post-base-installer && /usr/lib/ubiquity/localechooser/finish-install']' for ubiquity.components.language_apply.LanguageApply
Sep 20 12:29:51 bt ubiquity:
Sep 20 12:29:51 bt ubiquity: /usr/lib/ubiquity/localechooser/post-base-installer: 49: cannot create /target/etc/default/locale: Directory nonexistent

Colin Watson (cjwatson) wrote :

This is also bug 491198, which I just fixed in Ubuntu Lucid. As for getting that into BackTrack, I'm afraid that's their problem and not something we can help with further.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers