side-by-side install resize separator is difficult to notice on large hard-drives

Bug #426739 reported by Philip Morrell on 2009-09-09
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux Mint
Fix Released
High
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

For installs on disks with an existing OS taking up the whole drive (very common), the default partitioning setup is side-by-side, with the linux partition only just large enough to contain the system files (c. 100MB free space). The resizing widget on the visual indicator is not immediately obvious on large (tested with 256GB) drives, since it's only the width of the separator itself. This leads to newbie (i.e. not familiar with partitioning) confusion when they just select next, and they run out of space quickly on the fresh install. This is further compounded when they try again and end up with two tiny linux installs, until they either give up or approach the forums for help.

Suggestion: somehow make it more obvious that you can change the amount of disk space available to linux at the partitioning stage, possibly explaining that the default is just enough for the system and that expanding it will enable you to both store more user data as well as install more programs (though this could be left in a tooltip or something)

reported on Linux Mint 7 Gloria, based off Ubuntu Jaunty, causing new user confusion:
http://forums.linuxmint.com/viewtopic.php?f=90&t=32451

Henry H (henry-harte) wrote :

Given the large number of distributions which are effected by this bug and the audience which is most effected (New users who may be put-off the Linux experience by something which "Just does not work") I would suggest that this bug be elevated in importance.

A further suggestion is that it could be simply mitigated through providing some prominent text (in the installer GUI) to alert the user that if they continue without changing things, they will have an unusable installation! Yes! I know that no one actually reads that stuff ;-) but it would be a step in the right direction until a 'real' solution was put in place.

THanks.

Philip Morrell (emorrp1) on 2009-10-09
Changed in linuxmint:
importance: Low → High
Changed in linuxmint:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Colin Watson (cjwatson) on 2012-10-16
affects: ubiquity → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Dimitri John Ledkov (xnox) wrote :

The side-by-side resize & the manual partinioning has changed a lot since 2009, is this bug still relevant?

Changed in ubiquity (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers