Installer allows invalid usernames

Bug #413147 reported by Ryan Kavanagh on 2009-08-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

 affects ubuntu/ubiquity

ubiquity-frontend-kde version 1.99.6

The installer allows the user to enter an invalid username if the two passwords
match but are too short.

I provided:
Name: Ryan
username: ryan ao
Password1: asdfg
Password2: asdfg
Hostname: ryan

If this does not work for you, try entering a valid username, but keep the
passwords to short. It will ask you if you want to provide a longer password.
Say yes. Then switch to an invalid username, leave the passwords as they are and
hit continue. The same question will appear. Hit continue and proceed with the
invalid username.

See the attached screenshots for more details.

Ryan Kavanagh (ryanakca) wrote :
Evan (ev) on 2009-08-17
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
arky (arky) wrote :
Colin Watson (cjwatson) wrote :

No, the problem is incorrect error handling logic somewhere - just hammering the username into shape isn't the right way to fix it.

Evan (ev) wrote :
Evan (ev) wrote :
Evan (ev) wrote :

When the user responds to the weak password question with true (allow a weak password), ubiquity preseeds the answers to the username, full name, and hostname questions as part of ok_handler in user-setup.py. However, user-setup-ask does not recheck these values at STATE=7, after it gets a response to the weak password question, because there isn't a way to go back to the questions in debian-installer and change their values without reducing the value of STATE.

tags: added: iso-testing
Evan (ev) wrote :

This is fixed indirectly by the removal of the weak password dialog, which has been replaced with a password strength meter.

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers