OEM install: black screen with cursor on login

Bug #403021 reported by Colin Ian King on 2009-07-22
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned
Karmic
High
Unassigned

Bug Description

Testing today's ISO:

ISO: http://cdimage.ubuntu.com/daily-live/20090722/karmic-desktop-amd64.iso
Test: http://testcases.qa.ubuntu.com/Install/DesktopOem

After test case uoi-002 (Desktop Ready For End User) has completed and I had rebooted the machine, X failed to start and all I get is a black screen and a flashing cursor on the top left of the screen. I cannot change to any VT's. I can force a reboot with Ctrl-Alt-Delete.

H/W: Dell Inspiron 6400 laptop

Attached are logs from /var/log

Colin Ian King (colin-king) wrote :
Dave Morley (davmor2) on 2009-08-13
Changed in ubuntu:
status: New → Confirmed
Colin Watson (cjwatson) wrote :

It's odd that /var/log/installer/debug doesn't exist; that suggests that it may not even have got as far as oem-config-firstboot. Reassigning to ubiquity (which builds oem-config nowadays) for the meantime, though.

affects: Ubuntu Karmic → ubiquity (Ubuntu Karmic)
Michael Terry (mterry) wrote :

This is consistent with '/usr/sbin/oem-config -q' failing horribly. This is called early in oem-config-firstboot.

Wharf Rat (sendit2billp) wrote :

Also occurs on 32 bit system - Dell Dimension 8100. Appears to be partly related to the Nvidia driver.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Also, reverting to 2.6.28-15-generic does not enable VT's.

Changing video driver from 'nvidia' to 'vesa' will boot 2.6.31-6-generic, but no VT's with either 2.6.28-15 or 2.6.31-6

Changed in ubiquity (Ubuntu Karmic):
assignee: nobody → Evan Dandrea (evand)
Wharf Rat (sendit2billp) wrote :

This might help with debugging - loaded latest Nvidia driver for the graphics card nVidia Corporation NV11 [GeForce2 MX/MX 400] (NVIDIA-Linux-x86-96.43.13-pkg1.run).

Restarted in 2.6.31-6 recovery mode, issued telinit 3, then ran the Nvidia installation package. Upon completion /etc/init.d/gdm start started the desktop. Then did a restart from System/Shutdown and the system restarted normally with a successful boot to version 2.6.31-6. Also now have tty which was previously disabled.

Evan (ev) wrote :

Colin,

Can you still reproduce this with the latest daily-live CDs? I just tried with 20090822, and aside from a usplash issue (I had to remove "quiet splash" from the kernel command line, otherwise it would hang) and the oem user remaining in the gdm configuration for autologin, it worked fine.

starslights (starslights) wrote :

hello,

I run kubuntu karmic alpha, i have updated yesterday my sytstem.. was the last kernel inclus .

Well now after have restarted , it load the logo kubuntu and after i have a black windows and if i wait 30 min , i see a strange cursor on sreen. A4re no possibility t stop and restart except cut power again.

The test at start don't find errors and if i start with the old kernel, i see no difference.

I hope to have a answer soon while i see alpha5 are only tomorow and i will not reinstall the alpha4 if it crash right after the first update..

Thanks in advance for help

my best

starslights (starslights) wrote :

oups sorry, i have Intel 4 cores x86 64 , kernel 2.6.31.9

Colin Watson (cjwatson) wrote :

This seems to be an X bug (failing to fall back to nv when the nvidia module isn't available, or something?), although I can't say I'm familiar with the details - at any rate it appears not to be an oem-config bug. Reassigning.

affects: ubiquity (Ubuntu Karmic) → xorg-server (Ubuntu Karmic)
Changed in xorg-server (Ubuntu Karmic):
assignee: Evan Dandrea (evand) → nobody
Dave Morley (davmor2) wrote :

Not falling back. It doesn't work with nv or nvidia drivers. I installed the nvidia driver in oem mode to see if it was just and issue with nv, but it effects both the nv and nvidia drivers.

It works on intel though.

starslights (starslights) wrote :

i have install the new version, kubuntu alpha 5 and for the moment seem work. it can loging so far.

Changed in xorg-server (Ubuntu Karmic):
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

Mario figured out that this can be avoided in oem-config, in fact. Weirdness!

affects: xorg-server (Ubuntu Karmic) → ubiquity (Ubuntu Karmic)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.99.17

---------------
ubiquity (1.99.17) karmic; urgency=low

  [ Colin Watson ]
  * Add support for the biosgrub partman method, to be added in
    partman-partitioning 71.

  [ Mario Limonciello ]
  * Use the usplash init script to stop usplash in the oem-config init script
    It seems to do a better job, and prevents a black screen on boot with some
    drivers that aren't as usplash friendly. (LP: #403021)

  [ Evan Dandrea ]
  * Merged Michael Terry's plugins branch (LP: #419989). See
    http://wiki.ubuntu.com/Ubiquity/Plugins for instructions on writing
    new plugins.
  * Automatic update of included source packages: clock-setup
    0.98ubuntu2.

 -- Evan Dandrea <email address hidden> Mon, 07 Sep 2009 09:44:29 +0100

Changed in ubiquity (Ubuntu Karmic):
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments