Change 'select your timezone' to 'select you city' or a variation on a theme

Bug #380171 reported by Endolith on 2009-05-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

The information from the location selector is used to set the time zone, but (apparently) also used to set the country, for localization settings.

Currently it says "Select your time zone from the map, or by region and city", but selecting the time zone is not enough. The wording should be "Select your location from the map" and it should specify what this is used for, so the user knows they should be specific.

I think this location information should also be fed to the "About Me" app, and to the Weather app in the panel clock. That might need a separate bug, though.

komputes (komputes) wrote :

You are correct Endolith, the separate bug you speak of is Bug #291853 affecting libgweather. It works but it is a little sloppy; I think both of these bugs should be worked on at the same time.

--

>information should also be fed to the ...
>Weather app in the panel clock. That might need a separate bug, though.

Changed in hundredpapercuts:
status: New → Confirmed
Evan (ev) wrote :

The user currently has two options. They can either select a time zone location from the map, or alternatively they can select a region and time zone location from the drop down boxes that sit below the map. "Select your location from the map" does not explain the latter option to the user.

Endolith (endolith) wrote :

Why would they select only a region and not a location?

Changed in hundredpapercuts:
milestone: none → round-6
Endolith (endolith) wrote :

Specifically,

    Select your time zone from the map, or by region and city.

should be changed to something like this:

    Select your location from the map, or from the Region and City drop-down
    boxes. This is used to provide localized information, like weather
    forecasts, daylight saving time, and currency formatting.

(Also, the map could stand to be a bit larger...)

Evan (ev) wrote :

I'm concerned that your suggested string is too verbose. Keep in mind that any space used by text is taken away from the timezone map, which increases in usability as it gets larger.

The fact that it's not scaling to fit the window is a separate bug, which has already been filed.

Evan (ev) wrote :

"Why would they select only a region and not a location?"

They wouldn't, and the installer will not let them. We chose to split the data into two drop down boxes because there are a large number of time zone cities and users have often complained when these are put in a single drop down box.

The boxes exist as a concession to disabled users (the map does not support accessibility or keyboard control yet, and those who find the map difficult to use, which was a common problem with previous iterations of the map.

Mark McCoy (mcking) wrote :

The timezone selector has been a papercut for me for a while. Out of the cities listed on the map, none of the cities listed in my timezone are within a thousand miles from my location, and I live in one of the 10 largest cities in the US (San Antonio). I usually choose Chicago, but a novice user wouldn't know which city to choose if there aren't really any near them, or what time zone cities in Mexico are in (Monterrey is closer than Chicago), or why some of the cities listed are on the border of time zones that don't honor daylight savings time.

The region/timezone selector makes sense, the pretty map doesn't....

Evan (ev) wrote :

Mark,
The problem you're experiencing sounds to be a duplicate of bug 371509, which we plan to address by teaching the map about the Southern US border, as outlined here:
https://wiki.ubuntu.com/FoundationsTeam/Specs/KarmicOEMConfigImprovements

Note that oem-config and ubiquity are now one in the same.

Evan, can you change the string to:

    "Select your location from the map, or by region and city below."

Changing "time zone" to "location" will encourage users to make a more precise selection, and adding "below" makes it more clear that the "region and city" selection is separate from the map. Users who see the map but do not see the Region and City controls might be confused by "select your time zone... or... region and city."

Michael Terry (mterry) wrote :

I'll note that the timezone map has changed very recently (not yet even released) to use not quite cities, but 'zone names' -- i.e. translated cities.

Where before you'd see Berlin or New York in the City dropdown, now you see Germany or Eastern (translated for the language chosen). In the case where a country has more than one timezone-city, you'd see 'Russia (City 1)' and 'Russia (City 2)'. In the case where a country has zones with non-city names (like the US, Mexico, and Canada), those names are shown.

The label for the dropdown has been changed from 'City:' to 'Zone:' and the help text at the top is now:

 "Select your location, so that the system can use appropriate display
  conventions for your country, fetch updates from sites close to you,
  and set the clock to the correct local time."

So suggestions on top of these changes are definitely welcome, but just wanted to give a heads up on the new look.

Endolith (endolith) wrote :

I hope it doesn't literally say "City 2". :)

Michael Terry (mterry) wrote :

Yar, of course not. It uses the translated name of the city in question.

komputes (komputes) wrote :

Another comment on Step 2 in ubiquity (Where are you? Select your time zone from the map, or by region and city.) I don't personally find clicking on the map as accurate or useful as using the menus.

For users who wish to use the region and city menus instead of clicking their city on the map, ubiquity should also allow "searching/skipping" the menus using the keyboard.

This way if I click on the City menu and I type in "tor" it will select Toronto as the city. This saves time and is common in other applications.

Tim Tilberg (ttilberg) wrote :

I haven't done a totally fresh install in a while, but I had a situation simiar to comment 7 from Mark McCoy.

I live in Duluth, MN, USA and the closest city to me that is in the same time zone is actually in Canada. While I understood at the time I was selecting based on time zone, I didn't expect it to default all of my weather settings to metric... That was something I got over easily as it was easy to change.

It took me forever to realize however why my dates were always displayed in a non-US format in OO Calc. It caused a certain amount of problems with some spreadsheets I had to do for work even, as I would type a date such as July 4, as 7/4/09, and it would interpret the date was April 7.

I hope the region thing Michael Terry wrote about helps remedy this. What a nightmare!

Endolith (endolith) wrote :

Verbosity is good.

Alejandro Vidal (mancvso) wrote :

@Endolith: in this case: indeed!

Changed in hundredpapercuts:
milestone: round-6 → none
Chris Wilson (notgary) wrote :

There hasn't been any activity on this bug for a while now. There was a suggestion made in comment #9 to change 'time zone' to 'city'. This to me would be an adequate solution to this problem. Is there any disagreement?

Changed in hundredpapercuts:
importance: Undecided → Low
Chris Wilson (notgary) on 2011-01-28
Changed in hundredpapercuts:
status: Confirmed → Triaged
Changed in ubiquity (Ubuntu):
status: New → Confirmed
summary: - "Select your time zone from the map" is misleading
+ Change 'select your timezone' to 'select you city> or a variation on a
+ theme
summary: - Change 'select your timezone' to 'select you city> or a variation on a
+ Change 'select your timezone' to 'select you city' or a variation on a
theme
Chris Wilson (notgary) on 2011-01-28
Changed in hundredpapercuts:
milestone: none → nt7-potpourri
Chris Wilson (notgary) on 2011-01-29
Changed in hundredpapercuts:
assignee: nobody → Chris Wilson (notgary)
Chris Wilson (notgary) on 2011-01-30
Changed in hundredpapercuts:
status: Triaged → In Progress
Chris Wilson (notgary) wrote :

The attached branch will ask the user to 'enter their town/city, or the closest to their location'.

tags: added: patch
Chris Wilson (notgary) wrote :

Unassigning myself. I don't have time to work on this.

Changed in hundredpapercuts:
assignee: Chris Wilson (notgary) → nobody
status: In Progress → Triaged
Ken VanDine (ken-vandine) wrote :

un-subscribing ubuntu-sponsors, I don't think there is enough consensus here to sponsor the branch.

Robert Roth (evfool) on 2011-03-19
tags: removed: patch
Robert Roth (evfool) wrote :

The current timezone selector screen asks the question "Where are you?", nothing more. I guess this should be marked as Invalid or Fix released. See the screenshot attached of the current timezone selector.

Vish (vish) wrote :

Robert, yup, thats a Fix ;-)

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers