Installing next to Windows places Linux beyond 137GB and makes system unbootable (grub error 18).

Bug #379348 reported by Martin Ling on 2009-05-22
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

I tried to install Ubuntu 9.04 (Jaunty) on my laptop, a Dell Precision M20.

I was using a new 250GB drive, with Windows XP already installed.

The installer detected the Windows install and offered to set up alongside Windows and even import the user settings - very nice touch there.

Everything looked good until rebooting. Then, grub error 18. Not only can I not boot Linux, my previous Windows install is now also inaccessible. Indeed, as far as any non-expert knows, it is completely destroyed.

This is *not* acceptable. The installer *must not ever* do this. The stories that circulate, after it happens to someone trying Linux out for the first time, do irreparable damage to the reputation of Ubuntu and of Linux in general. Bugs like this stop bug #1 from ever being fixed. They will not get reported, because the user now has no bootable system. Sure, they can run the live CD they just tried to install off. Are they likely to, now that it has just apparently nuked their machine?

Now, I know and you know what the issue is. The kernel and grub data has been put beyond 137GB. If I go back and reinstall the whole thing, putting a /boot partition at the start of the disk, it'll work. I looked around: this bug gets reported all over the place, and always this workaround has been suggested in response and the matter then considered closed.

If Ubuntu needs a /boot partition at the start of the disk then the installer should make one itself. If it can't do that because existing partitions are in the way, then it should explain the problem and must stop the installation.

affects: ubuntu → ubiquity (Ubuntu)
Endolith (endolith) wrote :

This happened to me too. An unbootable machine is unacceptable. At the very least it should warn the user about common problems like this.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
delance (olivier-delance) wrote :

The answer is at https://answers.launchpad.net/ubuntu/+question/59059.

It is not a Linux Bug. You should have same problem if you try to install two Windows OS on same disk (e.g. XP and Vista).

The bug lies in your BIOS which recognize only 137GB, and do not allow installation of ANY operating system after 137GB.

Worse, I don't know if an installed operating system (or a live CD-ROM) can detect this problem.

OS installer, at my opinion, can only warn you to check if your BIOS see disk after 137GB.

Endolith (endolith) wrote :

Making a computer unbootable is, indeed, a (major) bug.

Does Windows still have picky requirements about where it sits on the drive? Can the partitioner slide it forward a bit and create a separate boot partition near the beginning of the drive? This is what I had to do to make my computer bootable again.

delance (olivier-delance) wrote :

Sorry, but Windows has more picky requirements than Ubuntu. Try to do a multi-boot with many Windows OS and you will understand.

Ubuntu does not need a /boot partition, because it is not yet launched. It is the multi-boot software, GRUB, which will launch Windows or Linux, who is located in this partition.

Your solution will work only with people who have a legal XP CD-ROM, perhaps 1% today. 99% have windows pre-installed with a recovery partition and can not install windows from CD-ROM. So the easiest solution for a laptop is to remains recovery partition and windows partition untouched, and to put GRUB and Ubuntu after.

In French Ubuntu documentation, there is half-dozen web page how to make a Windows/Linux multi-boot. It is not an easy issue.

One solution would be to propose to make a recovery CD-R/Usb key to save the MBR and restore it when a problem arise.

Phillip Susi (psusi) wrote :

This should no longer be an issue since grub2 handles booting beyond 137 GB.

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers