Ubuntu 9.04 installer's width increases too much in partitioning step if computer has other OS installed

Bug #364617 reported by arm-c on 2009-04-21
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
ubiquity (Ubuntu)
High
Ubuntu Installer Team

Bug Description

Ubuntu 9.04 installer's window width increases too much in partitioning step if computer has other operating system(s) installed. This is because of text "This will delete ${SYSTEMS} and install ${RELEASE}." (debconf template ubiquity/text/part_format_warning). ${SYSTEMS} often is very long text, especially in notebook computers with "recovery partition", where is one more "Microsoft Windows XP Home Edition" or "Windows Vista (loader)" installed.

This problem is especially visible when LiveCD starts in 800x600 screen resolution (this often happens with NVIDIA graphic cards or Asus EeePC netbooks) and has other operating systems installed. Ubuntu installer's window expands over twice the width of my screen when in the partitioning step.
For simple user it's impossible to continue the installation, because button "Forward" is not visible :(
It's a serious bug for those that are NEW to Ubuntu.

For the majority of real situation this bug can be fixed by simply adding line break after installed operating system list ({SYSTEMS}) - I've fixed partitioning step window's width problem by applying this patch against debconf templates:

 Name: ubiquity/text/part_format_warning
-Description: This will delete ${SYSTEMS} and install ${RELEASE}.
+Description: This will delete ${SYSTEMS} \n and install ${RELEASE}.

Colin Watson (cjwatson) on 2009-04-22
affects: ubuntu → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: New → Triaged
description: updated
summary: - Ubuntu 9.04rc installer exceeds size of low resolution screen once the
- partitioner is started
+ Ubuntu 9.04 installer's width increases too much in partitioning step if
+ computer has other OS installed
Mantas Kriaučiūnas (mantas) wrote :

I'm attaching a patch for Baltix 9.04 for distribution, which fixes window width of ubiquity's partitioning step and default NTFS/FAT mount-point (see bug #231284). Patch should be applied against /var/cache/debconf/templates.dat and /var/lib/dpkg/info/ubiquity.templates

Tobin Davis (gruemaster) wrote :

Still see it when running Karmic UNR OEM installation.

Evan (ev) wrote :

Fairly trivial to fix, but it runs headfirst into GTK+'s poor layout management (no height for width).

=== modified file 'ubiquity/frontend/gtk_ui.py'
--- ubiquity/frontend/gtk_ui.py 2009-09-21 11:52:53 +0000
+++ ubiquity/frontend/gtk_ui.py 2009-09-30 20:45:06 +0000
@@ -1505,6 +1505,7 @@
                     self.format_warning_align = a
                     label = gtk.Label()
                     self.format_warning = label
+ self.format_warning.set_line_wrap(True)
                     hbox = gtk.HBox(spacing=6)
                     img = gtk.Image()
                     img.set_from_icon_name('gtk-dialog-warning', gtk.ICON_SIZE_BUTTON)

nick parlante (nick-parlante) wrote :

Still seeing this with Karmic beta 1 on a eepc with the standard netbook screen size: 1024 x 600

Tobin Davis (gruemaster) on 2009-10-15
Changed in ubiquity (Ubuntu):
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
Tobin Davis (gruemaster) wrote :

This is what I see during installation. This only happens when running install from the boot menu. Installing from the live image netbook-launcher icon works perfectly.

Evan (ev) wrote :

I've dug into this a bit more and I have a slightly better solution, though with one big caveat. The attached patch will make the format warning wrap, and wrap to the correct width; however, it will prevent the window from ever being resized smaller.

The solution comes from <http://blog.16software.com/dynamic-label-wrapping-in-gtk>, and is meant to work around the ancient height-for-width wrapping problem in GTK+ <https://bugzilla.gnome.org/show_bug.cgi?id=101968>.

I am not convinced the bug warrants this kind of regression, especially considering that the "(development version)" text will go away as soon as we release. Any thoughts?

Evan (ev) wrote :

Of course the non-wrapped label that we have now will cause the window to grow quite large, so perhaps this really is the better solution.

Evan (ev) on 2009-10-19
Changed in ubiquity (Ubuntu):
status: Triaged → Fix Committed
Tobin Davis (gruemaster) wrote :

There needs to be a fix, because the issue occurs even when Windows owns the only two partitions on the system. Granted, my screen shot was from a previously installed UNR and I was installing over the top, I first saw it when I first got this netbook that came preloaded with Windows XP and a recovery partition. Maybe the solution is to frame the installer in a window, like it is done in Kubuntu? I installed Kubuntu Netbook over the weekend on the same system after installing UNR and Moblin Remix making 6 different partitions, and only UNR and Moblin Remix had this problem.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.0.1

---------------
ubiquity (2.0.1) karmic; urgency=low

  [ Evan Dandrea ]
  * Check to see whether X crashed or ubiquity crashed before attempting
    to bail into the noninteractive frontend from only-ubiquity mode
    (LP: #444901).
  * Wrap the format warning label while working around GTK+ label layout
    problems (LP: #364617).

  [ Colin Watson ]
  * Rewrite X_LOADTEMPLATEFILE commands in case they refer to template files
    in the /target chroot (LP: #452118).
  * Install -generic-pae kernels if necessary; this requires some custom
    hacks since -generic-pae isn't in the live filesystem (LP: #413135).
  * Don't do kernel installation/removal in oem-config.
  * Skip partition_too_small check during Wubi installs, as Wubi does some
    of its own checks and the delay imposed by this check looks particularly
    weird in Wubi. This may or may not be the cause of apparent hangs
    towards the end of partitioning, but I suspect that it will at least get
    rid of some conflated reports and make testing quicker.
  * Update translations from Launchpad.
  * Automatic update of included source packages: clock-setup 0.98ubuntu3,
    flash-kernel 2.13ubuntu13, grub-installer 1.43ubuntu6, partman-auto
    89ubuntu2, partman-target 64ubuntu4.

  [ Mario Limonciello ]
  * Mythbuntu: Don't allow "removing" LIRC as it's not supported with install.

  [ Roman Shtylman ]
  * Fixed India timezone map (LP: #453009)

  [ Michael Casadevall ]
  * Added support for partman-uboot in ubiquity (LP: #455713)

 -- Colin Watson <email address hidden> Tue, 20 Oct 2009 01:20:06 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
tags: added: iso-testing
Tobin Davis (gruemaster) on 2012-03-09
Changed in baltix:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.