ubiquity keyboard layout right window blank when going Back from Step 4 to Step 3

Bug #364539 reported by jtholmes on 2009-04-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Colin Watson

Bug Description

Binary package hint: ubiquity

Ubuntu desktop RC 4.20.9

ubiquity:
  Installed: 1.12.12
  Candidate: 1.12.12
  Version table:
 *** 1.12.12 0

Steps to reproduce

Start installer
get to partitioning step, Step4
Select Back button
Keyboard layout displays
Right side window is not populated like it is when
   coming from Step 2 to Step 3.
To get the Right Side window you have to do the following
Select Choose your own:
Slider down to your Country
Select Your country
The right side window is populated properly

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
MediaBuild: Ubuntu 9.04 "Jaunty Jackalope" - Release i386 (20090420.1)
Package: ubiquity 1.12.12
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
Uname: Linux 2.6.28-11-generic i686

Related branches

jtholmes (jtholmes) wrote :
Evan (ev) on 2009-04-21
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Colin Watson (cjwatson) wrote :

Fix committed for Karmic.

Changed in ubiquity (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Medium → Undecided
status: Confirmed → Fix Committed
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.13.0

---------------
ubiquity (1.13.0) karmic; urgency=low

  [ Mario Limonciello ]
  * Mythbuntu Frontend:
    - Explicitly allow the user to progress when the graphics driver is
      selected. For Wubi installs that contain an NVIDIA or AMD graphics
      card, the installer would be stuck on this page because of being in
      automatic mode. This page is not shown on Non-NVIDIA or AMD systems.
    - Be more specific about packages that are removed in role selection.
      Unfortunately prior to this fix, choosing a Frontend role for example
      was not cleaning up mysql, apache, or mythtv-backend (completely
      defeating the purpose of a frontend role).

  [ Evan Dandrea ]
  * Initially set the extra autopartition options to an insensitive
    state (LP: #362914).
  * Properly reset the 'after' partition bar when switching between 'use
    the largest continuous free space' and 'install them side by side'
    (LP: #364181).
  * Add translation support for the "Free Space" string in the GTK frontend
    partition bars (LP: #365490).
  * Re-enable the alpha intro message.
  * Provide better labels for the partition buttons (LP: #336764).
  * Move the ubiquity icon into the ubiquity-ubuntu-artwork package
    (LP: #322174).

  [ Colin Watson ]
  * Strip whitespace from username (LP: #358656).
  * GTK frontend:
    - Fix return value from get_keyboard/get_keyboard_variant if the stored
      default layout/variant is None (LP: #364539).
    - Make create/edit partition mount combo box activate the window default
      (LP: #364564).
    - Widen password entry boxes a bit (LP: #364499).
  * Update imported translations from gtk+2.0 2.16.1-0ubuntu3.
  * Automatic update of included source packages: apt-setup 1:0.40ubuntu1,
    base-installer 1.99ubuntu1, choose-mirror 2.28ubuntu2, console-setup
    1.34ubuntu1, debian-installer-utils 1.67ubuntu1, grub-installer
    1.37ubuntu1, localechooser 2.11ubuntu1, partman-auto 85ubuntu1,
    partman-newworld 21, partman-target 59ubuntu1.
  * Adjust for changes in console-setup 1.34ubuntu1.

 -- Colin Watson <email address hidden> Mon, 11 May 2009 11:22:35 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers