[jaunty] "Use entire disk" options are not disabled when "Install side by side" is selected.

Bug #362914 reported by Ioannis Ramfos on 2009-04-17
2
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: ubiquity

When installing Ubuntu and reaching step 4 of the installer, the three install options are offered, with "Install them side by side" selected by default.

However, the disk selection button of "Use entire disk" option is not deactivated. When selecting the "Specify partitions manually" option, the button is not deactivated either.

But when selecting the "Use entire disk" option once and then return to one of the other options, the button and the text below it are grayed-out properly.

Perhaps this is similar to Bug #94105.

Ioannis Ramfos (isr81) wrote :
Ioannis Ramfos (isr81) wrote :
Evan (ev) on 2009-04-19
Changed in ubiquity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Evan (ev) on 2009-04-20
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.13.0

---------------
ubiquity (1.13.0) karmic; urgency=low

  [ Mario Limonciello ]
  * Mythbuntu Frontend:
    - Explicitly allow the user to progress when the graphics driver is
      selected. For Wubi installs that contain an NVIDIA or AMD graphics
      card, the installer would be stuck on this page because of being in
      automatic mode. This page is not shown on Non-NVIDIA or AMD systems.
    - Be more specific about packages that are removed in role selection.
      Unfortunately prior to this fix, choosing a Frontend role for example
      was not cleaning up mysql, apache, or mythtv-backend (completely
      defeating the purpose of a frontend role).

  [ Evan Dandrea ]
  * Initially set the extra autopartition options to an insensitive
    state (LP: #362914).
  * Properly reset the 'after' partition bar when switching between 'use
    the largest continuous free space' and 'install them side by side'
    (LP: #364181).
  * Add translation support for the "Free Space" string in the GTK frontend
    partition bars (LP: #365490).
  * Re-enable the alpha intro message.
  * Provide better labels for the partition buttons (LP: #336764).
  * Move the ubiquity icon into the ubiquity-ubuntu-artwork package
    (LP: #322174).

  [ Colin Watson ]
  * Strip whitespace from username (LP: #358656).
  * GTK frontend:
    - Fix return value from get_keyboard/get_keyboard_variant if the stored
      default layout/variant is None (LP: #364539).
    - Make create/edit partition mount combo box activate the window default
      (LP: #364564).
    - Widen password entry boxes a bit (LP: #364499).
  * Update imported translations from gtk+2.0 2.16.1-0ubuntu3.
  * Automatic update of included source packages: apt-setup 1:0.40ubuntu1,
    base-installer 1.99ubuntu1, choose-mirror 2.28ubuntu2, console-setup
    1.34ubuntu1, debian-installer-utils 1.67ubuntu1, grub-installer
    1.37ubuntu1, localechooser 2.11ubuntu1, partman-auto 85ubuntu1,
    partman-newworld 21, partman-target 59ubuntu1.
  * Adjust for changes in console-setup 1.34ubuntu1.

 -- Colin Watson <email address hidden> Mon, 11 May 2009 11:22:35 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers