Installer highlights incorrect time zone for some cities

Bug #341375 reported by Thomas Mashos on 2009-03-11
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Jaunty daily, 2009-03-11
Jaunty alpha 6

1. In the installer, advance to the "Where are you?" step.
2. From the menus, choose any of these cities:
    - "America" > "New York"
    - "America" > "Los Angeles"
    - "Australia" > "Perth"
    - "Australia" > "Melbourne"
    - "Australia" > "Sydney"
    - "Pacific" > "Auckland"
    - "Africa" > "Johannesburg"

What happens: The time zone immediately to the east of the selected city is highlighted.
What should happen: The time zone that the city is actually in is highlighted.

The same problem does not happen with other cities, such as "Europe" > "London", "Europe" > "Paris", or "Australia" > "Darwin".

For example selecting "Johannesburg" displayed a (non-editable) time which is 2 hours ahead of the current time.

During a fresh installation of Ubuntu 9.04 the modem was set to Local Only internet (Not International). This may have caused an incorrect Time Zone interpretation obtained from local time servers. During installation the computer clock was advanced by 2 hours. This had to be corrected manually after installation. A few days after installation, it is noted that some of the system files (created or modified at boot-time) show the correct boot time, while others show the time it was modified 2 hours in the future.

(This bug report previously also covered cities being shown in the wrong place, which is reported separately as bug 334284. Also do not confuse this with bug 342586, about some cities being completely unclickable.)

GTpyro (dmitriyp13) wrote :

Same problem here for the New York timezone. Screenshot attached.

GTpyro (dmitriyp13) wrote :

Forgot to mention that this is in Alpha 6

Thomas Mashos (tgm4883) wrote :

Not sure if it helps, but mine also shifted one timezone to the right (Same as the attached image from GTpyro). From Pacific Time to Mountain Time (although the problem was only cosmetic)

Matthew Paul Thomas (mpt) wrote :

This report seems to be about a combination of two bugs, bug 334284 and bug 342586. I'll mark it as a duplicate of 342586.

Matthew Paul Thomas (mpt) wrote :

Actually, I'll reopen this just to cover the case of the incorrect time zone being highlighted.

description: updated
GTpyro (dmitriyp13) wrote :

I believe this is tied to Daylight Savings Time. If the date is set to early February (standard time), most of these problems go away. In the US, most cities get the timezone offset with a test date of June 2, 2009.

Perhaps a good solution to this (if the installer can differentiate between standard and daylight savings time) is to only use standard time. Not sure how hard it would be to patch though.

Here's a list of a few problem cities (Tested with date set to Feb 2, 2009):
Americas:
  Argentina/ Buenos Aires
  Argentina/ Coboda
  Argentina/ Jujuy
  Argentina/ Tucuman
  Caracas (no timezone highlighted)
  Montevideo
  Sao Paulo
Australia:
  Adelaide (no timezone highlighted)
  Broken Hill (no timezone highlighted)
  Currie
  Eucla (no timezone highlighted)
  Hobart
  Melbourne
  Perth
  Sydney
Asia:
  Colombo (no timezone highlighted)
  Kolkata (no timezone highlighted)
Antarctica:
  Davis
  Mawson
  McMurdo (no city shown)
  South Pole (no city shown)
  Vostok (no city shown)
Indian:
  Mauritius
Pacific:
  Apia (no city shown)
  Auckland
  Chatham (no timezone highlighted, no city shown)
  Easter
  Enderbury
  Kiritimati (no timezone highlighted)
  Midway (no city shown)
  Walllis

GTpyro (dmitriyp13) wrote :

This seems to be fixed in Beta

It's not fixed for Zurich yet in the Kubuntu Beta. See attached .png. The time displayed is correct. It's just that the wrong timezone is highlighted.

description: updated
Evan (ev) wrote :

I do believe this was fixed before release. Can anyone still confirm it on Ubuntu or Kubuntu?

Changed in ubiquity (Ubuntu):
status: New → Incomplete

Not sure about Johannesburg, but most other cities are now correct in
Ubuntu.

Dmitriy

Dmitriy Plaks
<email address hidden>

On Tue, Jul 7, 2009 at 8:58 AM, Evan Dandrea <email address hidden> wrote:

> I do believe this was fixed before release. Can anyone still confirm it
> on Ubuntu or Kubuntu?
>
> ** Changed in: ubiquity (Ubuntu)
> Status: New => Incomplete
>
> --
> Installer highlights incorrect time zone for some cities
> https://bugs.launchpad.net/bugs/341375
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “ubiquity” package in Ubuntu: Incomplete
>
> Bug description:
> Jaunty daily, 2009-03-11
> Jaunty alpha 6
>
> 1. In the installer, advance to the "Where are you?" step.
> 2. From the menus, choose any of these cities:
> - "America" > "New York"
> - "America" > "Los Angeles"
> - "Australia" > "Perth"
> - "Australia" > "Melbourne"
> - "Australia" > "Sydney"
> - "Pacific" > "Auckland"
> - "Africa" > "Johannesburg"
>
> What happens: The time zone immediately to the east of the selected city is
> highlighted.
> What should happen: The time zone that the city is actually in is
> highlighted.
>
> The same problem does not happen with other cities, such as "Europe" >
> "London", "Europe" > "Paris", or "Australia" > "Darwin".
>
> For example selecting "Johannesburg" displayed a (non-editable) time which
> is 2 hours ahead of the current time.
>
> During a fresh installation of Ubuntu 9.04 the modem was set to Local Only
> internet (Not International). This may have caused an incorrect Time Zone
> interpretation obtained from local time servers. During installation the
> computer clock was advanced by 2 hours. This had to be corrected manually
> after installation. A few days after installation, it is noted that some of
> the system files (created or modified at boot-time) show the correct boot
> time, while others show the time it was modified 2 hours in the future.
>
> (This bug report previously also covered cities being shown in the wrong
> place, which is reported separately as bug 334284. Also do not confuse this
> with bug 342586, about some cities being completely unclickable.)
>

Evan (ev) wrote :

Marking as fixed, given the comments confirming it being resolved in the final release. If you are still experiencing this issue in Karmic, please file a new bug or feel free to reopen this one.

Thanks!

Changed in ubiquity (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers