[jaunty] ”Incomplete Language Support” message not shown anymore after installation

Bug #337748 reported by Timo Jyrinki on 2009-03-04
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson
Jaunty
High
Colin Watson

Bug Description

Binary package hint: ubiquity

Incomplete Language Support message, available (with translations) in language-selector package (/usr/share/language-support/incomplete-language-support-gnome.note), does not get shown after installation anymore even if it would be needed. Installed a fresh Jaunty from 20090303.1 daily-live, without network connection.

To reproduce:
1. Use eg. VirtualBox, but with disabled network connection, to install Ubuntu in non-English language (I chose Finnish) so that language support will be incomplete after installation
2. After installation, enable network connection again and boot into Ubuntu

Expected result:
After staring at the "cryptic" (English) desktop for a while, a light bulb should appear (as in Ubuntu 8.10) telling that language support is incomplete. The text should be in in the installation language. From the dialog one can choose to go to language-selector which (now in jaunty!) correctly guides you through installing the complete language support, first refreshing repositories if needed.

Actual result:
You keep staring the desktop, nothing happens/appears.

Tested: 20090303.1 daily-live, 20090316 daily-live

description: updated
Adi Roiban (adiroiban) on 2009-03-22
tags: added: i18n
Adi Roiban (adiroiban) wrote :

I can confirm this bug.

Right now, if there is no network I think that language support is not installed.

We can ship some dummy packages, version 0.0.0 on the live CD and then update manager should take care of them at the first update

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

Thanks for confirmation. That's actually an interesting solution proposal to the problem in general, even though not related directly to this bug. The same end result could be had if update-manager could mark missing language support for installation as well, since language-selector has anyway the detection and installation code to install support which was not installed at install time (but the user has to find her way to the tool with the guidance of this now-missing light bulb or otherwise).

Anyway, better to discuss those separately from this bug.

Colin Watson (cjwatson) wrote :

This was broken by the fix for bug 290398.

Colin Watson (cjwatson) on 2009-03-30
Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
assignee: nobody → cjwatson
Colin Watson (cjwatson) on 2009-04-03
Changed in ubiquity (Ubuntu Jaunty):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.12.3

---------------
ubiquity (1.12.3) jaunty; urgency=low

  * Sync with netcfg 1.44: Define IPv6 ::1 address as "localhost" (thanks,
    Robb Topolski; LP: #301430).
  * Silently skip non-existent devices in /proc/swaps (LP: #290947).
  * Use small print rather than italics in "Who are you?" (LP: #287626).
  * Revert r2984 from ubiquity 1.11.5, and instead filter out language packs
    that don't exist in the live filesystem's apt cache; this allows us to
    accurately produce incomplete language support notifications again.
    Thanks to Mario Limonciello for testing (LP: #337748).
  * Mythbuntu frontend:
    - Don't crash if --no-migration-assistant was used (LP: #354368).
  * Automatic update of included source packages: partman-base 129ubuntu6.

 -- Colin Watson <email address hidden> Fri, 03 Apr 2009 23:39:10 +0100

Changed in ubiquity (Ubuntu Jaunty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers