The prepare disk space (installation) seems to display the information incorrectly about the "side-by-side" option

Bug #336203 reported by Huygens on 2009-03-01
2
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Colin Watson
ubiquity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: ubiquity

When installing Ubuntu 9.04 alpha 5 (Jaunty) 64bit from Live CD/USB, an incorrect preview of the partition setup is shown on the "Prepare disk space" step (Step 5 out of 8). This error only occurs if the user selects "Install them side-by-side, choosing between them each startup" option. When that option is selected the image preview of the hard drive partitions show Ubuntu taking up more than the available free space (see disk-partition-sidebyside.png notice that I have about 17GB of free space, which is not shown here on the graphic).

Actually, when using this option several problem are displayed:
  - The total pourcentage of all partitions created is then 129% (19%+64%+35%+11%)!?!
  - The colour of the graphic at the bottom and the legend mismatch (or at least it seems)
  - It seems that my second NTFS partition is resized
  - It is then unclear what this option is and what is the difference with the option "Use the largest continuous free space"

To recapitulate:
  - Correct previews occur when the "Use entire disk" option is selected
  - An incorrect preview occurs when the "Use the largest continuous free space" option is selected, this bug has already been reported: bug #289663
  - An incorrect preview occurs when the "Install them side-by-side, choosing between them each startup" option is selected, this is this bug report

All this has been tested on Jaunty alpha 5 Live. Note that I haven't try to go further to the next step, but I do not want to mess my partitions...

Related branches

Huygens (huygens-25) wrote :
Evan (ev) on 2009-03-19
Changed in ubiquity (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-9.04
status: New → Confirmed
Evan (ev) on 2009-03-25
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

Errata added for beta:

 * In some cases, the "Prepare Disk Space" screen in the desktop installer displays obviously incorrect partition sizes in its graphical disk previews. This is only an error in the preview and does not reflect a problem with the partitioning changes that will actually be applied. Bug:336203

I'm leaving this bug at "Fix Committed" since bug 289663 has not been fixed yet and so there's a possibility that we might have to carry this over to the final release notes.

Changed in ubuntu-release-notes:
assignee: nobody → cjwatson
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.6 KiB)

This bug was fixed in the package ubiquity - 1.12.0

---------------
ubiquity (1.12.0) jaunty; urgency=low

  [ Colin Watson ]
  * Update for new message context system in GTK+ 2.15.1, and update
    imported translations from gtk+2.0 2.16.0-1ubuntu2.
  * Stop setting message attribute in InstallStepError; it isn't used and it
    generates a deprecation warning with Python 2.6. Similarly, rename
    PartedServerError's message attribute to parted_error.
  * Always set auto-login for OEM installations.
  * KDE frontend:
    - Hide auto-login and require-password radio buttons for OEM
      installations.
  * Remove reimplementation of gdm and kdm auto-login support for OEM
    installations, since user-setup handles this now and the duplication
    causes oem-config to be unable to undo autologin (LP: #347900).
  * Fix ubiquity/install_bootloader handling (LP: #348660):
    - Check the seen flag rather its value when deciding whether to override
      it with the UI's value.
    - Outside automatic mode, default the UI's "Install boot loader"
      question to the value of ubiquity/install_bootloader.
  * Offer "Yes" and "No" choices for user-setup/password-weak (LP: #349173).
  * Depend on grub | grub-pc, and don't remove grub-pc until after
    grub-installer has had the chance to decide whether it wants to use it
    (LP: #349835).
  * Add a compatibility wrapper for update-dev to ensure that it never
    attempts to call 'udevadm trigger', which isn't necessary in ubiquity
    and can cause problems (LP: #349937).
  * Permit dmraid-style /dev/mapper/* device names in advanced boot loader
    selector, as well as disk and partition numbers over 9 (LP: #342354).
  * Remove /target/var/lib/apt-xapian-index per Michael Vogt, since it needs
    to be rebuilt based on the installed system's sources.list, and apt's
    cron.daily script and/or synaptic will do this.
  * Preserve ordering of automatic partitioning choices when replacing them
    with our customised strings (LP: #351547).
  * Update translations from Launchpad.
  * Automatic update of included source packages: apt-setup 1:0.37ubuntu11,
    base-installer 1.98ubuntu4, console-setup 1.28ubuntu7, grub-installer
    1.36ubuntu5, hw-detect 1.71ubuntu6, partman-base 129ubuntu4,
    partman-target 58ubuntu6.

  [ Evan Dandrea ]
  * Make the partman/unmount_active dialog a yes or no question
    (LP: #346589).
  * Sort the list of regions on the timezone page (LP: #344334).
  * Merge Roman's city placement code into the GTK frontend.
  * Work in bytes rather than percentages in the partition bar code
    (LP: #336203).
  * Fix partition bar slider (for resizing) code by adding correct
    calculations for bounds checking and slider positioning.
  * Properly encode data from os-prober (LP: #345573).
  * Make sure that the before and after partitioning bars use the same
    colors for the same partitions (LP: #289324).
  * Fix the placement of the partition bars in scrolled windows when
    necessary.
  * Don't let the partition bars eat up any extra space.
  * Move selecting a disk from radio buttons to a drop down box on the
    automatic partitioning page. This saves a lot of space when...

Read more...

Changed in ubiquity:
status: Fix Committed → Fix Released
xenophed (xenophed) wrote :

Does this fix involve the lock-up's I had happen on two different machine that required hard reset (hold power button till power off )note kubuntu 9.04 both with 1GB mem and xp partitions

Colin Watson (cjwatson) wrote :

xenophed: Any lockups are entirely unrelated to this bug, and are probably kernel bugs.

Steve Langasek (vorlon) wrote :

The errata entry from the beta doesn't apply to final since this bug has been fixed. If bug 289663 needs to be documented, that will be handled separately.

Changed in ubuntu-release-notes:
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers