[MASTER] ubiquity should warn users about unusable mounted partitions

Bug #335376 reported by Evan on 2009-02-27
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Evan

Bug Description

Binary package hint: ubiquity

From #ubuntu-installer:
<evand> cjwatson: do you recall why we decided to filter all disks with mounted partitions from parted_devices rather than just /cdrom?
 It seems to be creating a headache for a number of users, and I'm wondering if we should try to unmount the partitions in question, then try again, or filter less out.
<cjwatson> evand: because if any partition is mounted on a disk then you can't tell the kernel to reread its partition table. We added partman/filter_mounted so that they can control it
<evand> oh, of course
<cjwatson> I think this is a bit of a lose-lose situation
<evand> Ugly, but perhaps a dialog warning them that they wont see the following disks because they have mounted partitions
<cjwatson> or a question asking them whether they want to unmount those partitions or not; of course they may have documents open on them ...
 feels like perhaps the sort of thing that should be done in ubiquity rather than partman-base
 in d-i it's much less likely that partitions will be mounted
<evand> indeed
<cjwatson> no objection to ameliorating the lose-lose on either side of course :-)

Following this, we should move the partition filtering into ubiquity and wrap it in a debconf question that asks if the user wants the installer to try and unmount the partitions that will be filtered out before continuing.

Evan (ev) on 2009-03-02
Changed in ubiquity:
importance: Undecided → High
status: New → Confirmed
Andreas Kern (kerna) wrote :

this seems to be a duplicate of Bug #290415

Evan (ev) wrote :

I think we still need to do this in partman-base, as we don't want the disk we're installing from to appear when usb-creator was used to create an alternate image.

Evan (ev) on 2009-03-16
Changed in ubiquity (Ubuntu):
assignee: nobody → evand
status: Confirmed → In Progress
Evan (ev) wrote :

Proposed patch

Evan (ev) wrote :
Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers