Timezone map cities are incorrectly placed

Bug #334284 reported by Colin Ian King on 2009-02-25
124
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
ubiquity (Ubuntu)
Medium
Evan
Jaunty
Medium
Evan

Bug Description

Testing ISO http://cdimage.ubuntu.com/daily-live/20090225/jaunty-desktop-amd64.iso the TZ map selection was different to the previous TZ map selections (see attached png)

The odd part was that when I had to click in mainland Europe to select the London Time Zone. I realise the UK is part of Europe, but not geographically speaking the location is more like Paris than London on this TZ selection map.

Test: http://testcases.qa.ubuntu.com/Install/DesktopOem, Ubiquity OEM Install, Case ID: uoi-001

Not to be confused with bug 341375, "Incorrect time zone highlighted for some cities".

Patrice Vetsel (vetsel-patrice) wrote :

For me Europe/Paris is not at the right place too. Bug confirmed.

Changed in ubiquity:
importance: Undecided → Medium
status: New → Confirmed
Evan (ev) on 2009-02-26
Changed in ubiquity:
assignee: nobody → evand
sam tygier (samtygier) wrote :

if you resize the window the positioning gets even worse.

Keith Worrell (keith-penguin) wrote :

This bug is overly specific. All the cities as far as I could tell had their horizontal position incorrect. Not certain, but I think they are all shifted one time zone to the right, US Mountain time ends up in gulf of mexico, US eastern times end up in Atlantic Ocean.

This isn't limited to London. It is the new map entirely.

Looks great otherwise.

Can the duplicate bugs (likely for many cities) be merged?

Evan (ev) wrote :

Yes, duplicate bugs can be merged. Please make sure they are bugs about the timezone cities being in the wrong place on the map, and not anything else.

Thanks!

Note that when using the Install option directly from boot menu, in 1400x1050, in addition to cities being placed wrong (both horizontal and vertical for me), the map is very slow. It takes ca. 5-10s for each click to be processed on a Pentium-M 1.6GHz. When using a windowed ubiquity, both the places are correct and map functions faster. The slowness might be worth its own bug, but let's see when the bug is otherwise corrected.

Using daily-live from today.

David Wilson (mcs6502) wrote :

Same problem here in Australia - clicked East coast of Australia and it selected "Australia Adelaide". Changed city to Sydney and the Tasman sea was highlighted on the map.

der_vegi (m-may) wrote :

Yeah, same problem here. But for me, the cities of middle and northern Europe are too far in the north: I didn't know that Brussels lies in Denmark. ;)
Maybe this a screen resolution problem? Mine is 1280x800.

On Sun, Mar 8, 2009 at 9:35 PM, der_vegi <email address hidden> wrote:
> Yeah, same problem here. But for me, the cities of middle and northern Europe are too far in the north: I didn't know that Brussels lies in Denmark. ;)

No use reporting other misplaced cities. Most of them are wrong.

--
 .
..: Lucian

Evan (ev) on 2009-03-09
Changed in ubiquity:
milestone: none → ubuntu-9.04-beta
status: Confirmed → In Progress

Testing ISO http://cdimage.ubuntu.com/daily-live/20090311/jaunty-desktop-amd64.iso London is now shifted up to Norfolk (originally when I tested this last time it was in mainland Europe!).

So all in all London is getting closer - it's now in the British Isles, but still quite a distance from where it should be. I believe this bug has something to do with the screen resolution - I've seen London in different locations on different sized screens. This one it's on a Dell 6400 Inspiron Laptop with screen resolution 1280x800 (16:10 aspect ratio)

Colin Ian King (colin-king) wrote :

Attached - png of where London is located now on the map.

Evan (ev) wrote :

I've made some progress on this in ubiquity bzr. The placement no longer worsens as the map grows, and the current algorithm uses the correct projection for plotting the time zone cities and factors the longitude shift and missing arctic region into its calculation. However, it's still not placing cities properly and London is sitting in the English channel.

Please note that this is not in a released version of ubiquity yet.

nullack (nullack) wrote :

Noting that apart from the city being too far horizontally as others have stated, mine has the highlight to show the timezone incorrect as well. Attaching SydneyTooFarNorth.png to show it.

cldershem (cldershem) wrote :

Los Angeles, Chicago, and Indianapolis are all shifted one time zone off, also.

Jonathan Jesse (jjesse) wrote :

as of jaunty alpha4 this is still ap roblem for all US cities that I have tried.

Michael Doube (michael-doube) wrote :

This bug is still present in Jaunty alpha 6: London is being placed in southern Norway, clicking on Auckland (NZ) selects Fiji....

This is also happening in the UNR image for Jaunty alpha 6 since the faulty package is probably the same one.

description: updated

In ubiquity (1.11.19) Lisbon is in the water...

My resolution is 1440x900

Evan (ev) on 2009-03-20
Changed in ubiquity (Ubuntu Jaunty):
milestone: ubuntu-9.04-beta → ubuntu-9.04
razor7 (ghiamar) wrote :

the same here...Buenos Aires is in Paraguay!

Vishal Rao (vishalrao) wrote :

Adding "me too" for India. Unable to select the IST (UTC+530) timezone with incorrect highlighting. It's not important to be able to select the traditional city (Calcutta/Kolkata) itself, just being able to click anywhere in the red coloured country area should be fine. I will re-test and report back once Jaunty Beta is released.

Colin Ian King (colin-king) wrote :

ISO testing, http://cdimage.ubuntu.com/daily-live/20090323.3/jaunty-desktop-amd64.iso

Now London is near the far middle and south of the UK, near Southampton. It's getting closer..

Colin Ian King (colin-king) wrote :

..however Reykjavik (Iceland) is floating around in the Atlantic.

Colin Ian King (colin-king) wrote :

..and from the same ISO on the OEM installation user configuration screens where the map is full screen one gets London in Norway.

Colin Ian King (colin-king) wrote :

In the London in Norway example it's getting to the point where London is almost outside the TZ and it's really not obvious where to click to select the required geographic location - it took me a minute or so hunting around to find it.

Dave Morley (davmor2) wrote :

They are now a lof closer than they used to be :)

Colin Ian King (colin-king) wrote :

An inch is a as good as a mile :-)

Evan (ev) wrote :

I've committed a fix for this today, based off additional work that Roman Shtylman did for the KDE frontend. However, this will not make the CDs until after beta.

nullack (nullack) wrote :

Can people please keep in mind that subscribers do not appreciate bug spam. Once the bug is confirmed, you can report your effected as well by clicking on this bug effects me too. Unnecessary bug spam in the comments just reduces the signal to noise ratio of the bug report and could lead to bug subscribers unsubsribing.

Steve Langasek (vorlon) wrote :

We shouldn't ship with this bug, so there's no reason for it to be documented in the release notes. Marking this task invalid.

Changed in ubuntu-release-notes:
status: New → Invalid
Evan (ev) wrote :

Steve,

I'm not sure I follow. My understanding is it's too late to release the fix from trunk into the archive and rebuild the CDs, so wouldn't it make sense to put this in the errata for the beta? Or is subscribing ubuntu-release-notes the wrong way to codify that task?

Changed in ubiquity (Ubuntu Jaunty):
status: In Progress → Fix Committed
Steve Langasek (vorlon) wrote :

The original intent of the ubuntu-release-notes project was for tracking bugs that need to be documented in the actual final release notes, not for the technical overview. It seems this time around we're using it for both due to popular demand; in any case, this bug is now documented in the beta errata. :)

JD (jacobdorne) wrote :

For me, Auckland (NZ) is not at the right location either, it is in the ocean?

Screenshot attached.

Kevin W. (eyecreate) wrote :

On Kubuntu's ubiquity, it seems the time zone is also misaligned, but not fixed in the latest beta.

Baldur (baldurpet) wrote :

Reykjavík, the capital of Iceland is way off. It's even in a different time zone.
This is a pretty 'minor' bug, but it has to be fixed asap

Colin Watson (cjwatson) wrote :

Could people who are having problems please try with a current daily build (http://cdimage.ubuntu.com/daily-live/current/), *not* with the beta? I believe that these problems have been fixed, but would like confirmation.

The_ZoRo (mazterthe) wrote :

All the cities in northern Europe is where they are supposed to be. Clicking on the country selects the capital of the country.

I say it's fixed.

Thanks :D

Vishal Rao (vishalrao) wrote :

Apparently not fixed for India in Kubuntu's jaunty-desktop-amd64.iso daily approx Apr 3rd with md5 as bd45a7b1894034eaceba8684487c0445 both starting the installer directly from grub or after starting a live session.

Clicking anywhere in India either selects Kathmandu (Nepal) or Colombo (Sri Lanka) and only if you click near Kolkata city in the east of India does it select the right timezone. Only Nepal is highlighted correctly not India nor Sri Lanka.

Will download and test Ubuntu Jaunty daily amd64 live image shortly in case the fix is there but not yet in Kubuntu...

Vishal Rao (vishalrao) wrote :

Not fixed for India/surrounding areas in Ubuntu Jaunty amd64 daily live CD iso either with md5 as 869a73d83c044116cb4b4f4a59882e37 approx Apr 3rd.

If you click around the center of India it selects Kolkata fine, but sometimes selects Colombo (Sri Lanka). Not possible to select Colombo by clicking Sri Lanka itself though. And impossible to select Nepal at all. If you do manage to select India (Kolkata) it does not highlight the timezone with the bright green band...

Matthew Paul Thomas (mpt) wrote :

Vishal, the problem with Indian cities is bug a separate issue, bug 344348.

Colin Watson (cjwatson) wrote :

There remain some specific issues here, but the general problem of incorrect map projection is now believed to be fixed, so I'm going to go ahead and close this bug.

(The recently-mentioned problem with getting the Indian timezone band selected was fixed by adding details for the UTC+5.5 timezone to the installer, which had been missing by mistake.)

Changed in ubiquity (Ubuntu Jaunty):
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.