The desktop icon is put in the ubiquity package rather than ubiquity-ubuntu-artwork.

Bug #322174 reported by Twisted Lincoln, Inc. on 2009-01-28
2
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Low
Evan

Bug Description

Binary package hint: ubiquity-frontend-gtk

Ubuntu derivative distributions (such as Nexradix, the GNU/Linux distro we maintain) have to modify Ubiquity before deployment in order to remove references to Ubuntu from code.

Currently, line 1183 in gtk_ui.py (/usr/lib/ubiquity/ubiquity/frontend) in the ubiquity-frontend-gtk package is:

"self.new_os_title = 'Ubuntu'"

This line controls what Ubiquity prints when showing the user the name of the new OS it is installing. Rather than hardcoding this to read Ubuntu, this could simply look at the distro listed in /etc/lsb-release and print that name instead. That would keep derivative distros from having to manually modify the package.

Related, but not as critical:

In the regular ubiquity package, /usr/share/pixmaps/ubiquity.png contains the trademarked Ubuntu logo. I suggest replacing this with the same icon without Ubuntu's logo, so this package doesn't have to be modified by downstream distros in order to comply with Canonical's trademark policy. I've attached the icon that we use in Nexradix.

Also, I have no idea where in Ubiquity it is actually displayed, but the ubiquity-artwork package has a image with the Ubuntu logo in it. I doubt this is an issue, though as it doesn't seem to be displayed anywhere...

Any chance of any of these issues being fixed for the final Jaunty version of Ubiquity? I'd love to avoid continuing to fork Ubiquity in our next version of Nexradix.

Evan (ev) wrote :

The resizing functionality has been moved into the partition bars for 9.04, and makes use of the get_release_name function in ubiquity/misc.py. This grabs the release name from /cdrom/.disk/info.

Evan (ev) wrote :

We'll fix this for Karmic.

summary: - Ubiquity uses hard-coded references to Ubuntu rather than looking to
- /etc/lsb-release
+ The desktop icon is put in the ubiquity package rather than ubiquity-
+ ubuntu-artwork.
Changed in ubiquity (Ubuntu):
importance: Undecided → Low
milestone: none → later
status: New → Confirmed
Evan (ev) on 2009-04-28
Changed in ubiquity (Ubuntu):
assignee: nobody → Evan Dandrea (evand)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.13.0

---------------
ubiquity (1.13.0) karmic; urgency=low

  [ Mario Limonciello ]
  * Mythbuntu Frontend:
    - Explicitly allow the user to progress when the graphics driver is
      selected. For Wubi installs that contain an NVIDIA or AMD graphics
      card, the installer would be stuck on this page because of being in
      automatic mode. This page is not shown on Non-NVIDIA or AMD systems.
    - Be more specific about packages that are removed in role selection.
      Unfortunately prior to this fix, choosing a Frontend role for example
      was not cleaning up mysql, apache, or mythtv-backend (completely
      defeating the purpose of a frontend role).

  [ Evan Dandrea ]
  * Initially set the extra autopartition options to an insensitive
    state (LP: #362914).
  * Properly reset the 'after' partition bar when switching between 'use
    the largest continuous free space' and 'install them side by side'
    (LP: #364181).
  * Add translation support for the "Free Space" string in the GTK frontend
    partition bars (LP: #365490).
  * Re-enable the alpha intro message.
  * Provide better labels for the partition buttons (LP: #336764).
  * Move the ubiquity icon into the ubiquity-ubuntu-artwork package
    (LP: #322174).

  [ Colin Watson ]
  * Strip whitespace from username (LP: #358656).
  * GTK frontend:
    - Fix return value from get_keyboard/get_keyboard_variant if the stored
      default layout/variant is None (LP: #364539).
    - Make create/edit partition mount combo box activate the window default
      (LP: #364564).
    - Widen password entry boxes a bit (LP: #364499).
  * Update imported translations from gtk+2.0 2.16.1-0ubuntu3.
  * Automatic update of included source packages: apt-setup 1:0.40ubuntu1,
    base-installer 1.99ubuntu1, choose-mirror 2.28ubuntu2, console-setup
    1.34ubuntu1, debian-installer-utils 1.67ubuntu1, grub-installer
    1.37ubuntu1, localechooser 2.11ubuntu1, partman-auto 85ubuntu1,
    partman-newworld 21, partman-target 59ubuntu1.
  * Adjust for changes in console-setup 1.34ubuntu1.

 -- Colin Watson <email address hidden> Mon, 11 May 2009 11:22:35 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers