ubiquity crashed with InstallStepError in configure_user()

Bug #317068 reported by Roy Jamison on 2009-01-14
82
This bug affects 12 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Evan

Bug Description

Binary package hint: ubiquity

Jaunty daily ISO 14 Jan 2009

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: ath_hal
Package: ubiquity 1.11.3
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/5420/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with InstallStepError in configure_user()
Uname: Linux 2.6.28-4-generic x86_64
UserGroups:

Roy Jamison (xteejx) wrote :
Roy Jamison (xteejx) wrote :
Roy Jamison (xteejx) wrote :
Roy Jamison (xteejx) wrote :

Managed to install - changed a few things though differences follow:

Selected Install instead of Run Live CD option on boot
ext4 partition changed to ext3
Did not select require password to decrypt home folder option

All other options were set the same, so I assume one of the above is the cause of the problem.
Note: When I rebooted after the mess up (1st install) grub error 15 - I assume the installer didn't get to install GRUB bootloader?

Hope the above helps.

Jan Rathmann (kaiserclaudius) wrote :

I have seen the same crash on my system today, with daily-live 20090116.1 amd64.

If I select "require password to login" instead of "... and to decrypt your home folder", ubiquity does not crash and the installation finishes as usual.

Kind regards,
Jan

Colin Watson (cjwatson) wrote :

This is due to an error in the file-copy blacklisting logic - Evan mentioned it yesterday on IRC and was working on it.

Changed in ubiquity:
assignee: nobody → evand
status: New → In Progress
Luca Zorzi (lucazorzi91) wrote :

I can confirm that this issue is related to the encrypted home, without that option enabled it works well.

karlrt (karlrt) wrote :

yeah, same as luca wrote, i just got to know this bug, without homeencryption there is no problem!

D3xter (andreas-sinz) wrote :

I've installed Jaunty 20090203.1 and home-encryption works now.

Evan (ev) on 2009-02-04
Changed in ubiquity:
status: In Progress → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers