[Feature Request] OEM config should offer support to show EULAs

Bug #315646 reported by Mario Limonciello on 2009-01-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
oem-config (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Evan

Bug Description

Binary package hint: oem-config

Some ISVs would prefer to be able to show EULA's before their software packages are fully installed. In the case that they are factory installed, there needs to be a way to present a EULA.

OEM Config should look in a documented directory for EULA txt files and present a screen with all of the found EULAs. The user shouldn't be able to progress through OEM config unless they accept the EULAs.

If no EULAs are found, the screen should be automatically skipped.

Changed in oem-config:
assignee: nobody → evand
Loye Young (loyeyoung) wrote :

I myself am a lawyer and agree that EULAs need to be better integrated into the entire ecosystem. I am highly skeptical that, if the issue were squarely presented, Texas and US Federal courts would enforce a license buried in the bowels of an operating system for which the user had no opportunity to review or consent before using the software.

I am strongly convinced, however,that oem-config is the WRONG place to do it because only the user who happened to be turning on the machine the first time would have agreed to the *End User* License Agreement.

In addition, placing EULA in oem-config would violate the Free Software Definition and would violate the GPL because it would force a user to agree to one license as a condition to using other software.

"The Right Way"

The better practice is to run the EULA script by the x-session-manager. The login manager (gdm, xdm, etc.) calls x-session-manager when the user logs in. X-session-manager, in turn, runs the scripts in /etc/X11/Xsession.d, which handle all sorts of preparations for the user session. This is how, for example, new users get their directories and get the default .gconf files, etc.

The EULA script in /etc/X11/Xsession.d/ should fire off a window asking for consent to the EULAs. If the user did not consent to the licenses required for the system and the desktop to run at all, the login would exit and return the system to the login manager. With respect to other EULAs , the EULA script would add the user to a group with permissions to use the software. If the user did NOT agree, the user would not be added to that group, which would allow the user to proceed to use other software.

IYCC is interested in developing a "EULA" package that "Does The Right Thing". If anyone would like to participate, please advise.

By the way, we have debtagged every package in our default installation with the type of license that covers the package. We use the debtags to create a booklet with a copy of each license and a list of the packages covered by such package. The booklet ships with our product as an additional users manual. We will soon be making the debtags available for others. If you need them sooner, please advise.

Happy Trails,

Loye Young
Isaac & Young Computer Company
Laredo, Texas
http://archive.iycc.net

Loye Young (loyeyoung) wrote :

I misspoke on my last message.

The requested change in this report would violate the Open Source Definition (Section 9), not (necessarily) the Free Software Definition.

Changed in dell:
importance: Undecided → Wishlist
status: New → Triaged
Jerone Young (jerone) wrote :

Considered Eula text at times can be in different languages. S need a model to support this.

Colin Watson (cjwatson) on 2009-07-16
affects: oem-config (Ubuntu) → ubiquity (Ubuntu)
tags: added: oem-config
John Gilmore (gnu-gilmore) wrote :

Free software (and Ubuntu in particular) should not be trying to impose clickwrap contracts on end-users. Our software is licensed under a copyright license. Any terms that don't work in a copyright license (e.g. because they try to control something other than whether users can copy the software) do not belong in free software.

If the software is actually free, then a user who disagrees with the proposed clickwrap license is free to decline it, and then go into his or her own machine and modify the software to eliminate the clickwrap license. Being able to remove bugs, misfeatures, and impediments from the software is the essence of the freedom that we grant to every user. I have personally done this to several attempted free software EULAs, including on Fedora, a Dell netbook, and on Mozilla Firefox. See: http://www.toad.com/gnu/sysadmin/ and search for EULA.

Jerone Young (jerone) on 2009-10-21
Changed in dell:
status: Triaged → New
importance: Wishlist → Undecided
Jerone Young (jerone) wrote :

@John
        Appreciate your comments. Though this is for software that is not apart of the Ubuntu distribution or even non software related items that may be included.

Changed in dell:
importance: Undecided → Wishlist
status: New → Confirmed
Jerone Young (jerone) wrote :

This issue maybe resolved now but not in Ubuntu:
https://wiki.ubuntu.com/FoundationsTeam/Specs/KarmicOEMConfigImprovements

See section "Ability to add pages" .

Colin Watson (cjwatson) wrote :

Closing the oem-config task that somehow reappeared on this bug; oem-config has been merged into ubiquity.

Mario, can you confirm whether plugins meet your needs? I agree with John that this doesn't really make sense in Ubuntu proper.

Changed in oem-config (Ubuntu):
status: New → Invalid

Colin:

Yes the plugins architecture appears to be sufficient for the needs of the
original bug.

On Tue, Feb 9, 2010 at 11:53, Colin Watson <email address hidden> wrote:

> Closing the oem-config task that somehow reappeared on this bug; oem-
> config has been merged into ubiquity.
>
> Mario, can you confirm whether plugins meet your needs? I agree with
> John that this doesn't really make sense in Ubuntu proper.
>
> ** Changed in: oem-config (Ubuntu)
> Status: New => Invalid
>
> --
> [Feature Request] OEM config should offer support to show EULAs
> https://bugs.launchpad.net/bugs/315646
> You received this bug notification because you are a member of Ubuntu
> Installer Team, which is subscribed to ubiquity in ubuntu.
>

--
Mario Limonciello
<email address hidden>

Tony Espy (awe) wrote :

Marking as WontFix in the Dell task, as this project is used to track non-public hardware enablement work.

Changed in dell:
status: Confirmed → Won't Fix
Jerone Young (jerone) wrote :

Also to add now that there is a plugin system for ubiquity. Dell is now using that to display EULAs.

Changed in ubiquity (Ubuntu):
status: New → Fix Released
Changed in somerville:
importance: Undecided → Wishlist
status: New → Won't Fix
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305449

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers