Ubuntu

ubiquity crashed with KeyError in partman_edit_dialog()

Reported by Tormod Volden on 2008-12-20
132
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned
Nominated for Jaunty by Ernst Sjöstrand

Bug Description

Binary package hint: ubiquity

I had selected a partition on my external USB drive (sdb7) and clicked the "Edit partition" button below. The "Edit partition" dialog had nothing selected in "Use as:" nor "Mount point:", and I tried to cancel it by clicking Cancel, which didn't work. (My intention was to try right-clicking on the partition instead, but I didn't get that far before apport kicked in.)

ProblemType: Crash
Architecture:amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.5
Package: ubiquity 1.11.1
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/9700/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with KeyError in partman_edit_dialog()
Uname: Linux 2.6.28-3-generic i686
UserGroups:

Tormod Volden (tormodvolden) wrote :

This happened here a on an internal, SATA-connected drive.

GreeneNY (digital8doug) wrote :

Kubuntu' jaunty jackalope' A2 X64 on an Asus G1S-B1 laptop, 200 GB ST HD 'ASG' model. Ubiquity crashed when selecting Manual partition, had not yet selected partition or 'Edit'
Similar to 311333, which is an HTS541080G9SA00 HD with 'GPT' DiskLabelType. Could 'back' and complete the earlier installation with Guided -Resize OK.

Also has nemo update problem again, was unable to complete bug report due to Network problem Could not upload report data (detailed) to crash database. <urlopen error The read operation timed out>
 Was in matter of seconds, definitely less than a minute

jerrylamos (jerrylamos) wrote :

Daily Build 20081227 install, manual edit partition, install hangs at "use as".

Easy to reproduce, any info anyone needs other than apport (attached)?

Any hints on how to do the install? "Guided" always, always, always picks the wrong partition.

Thanks, Jerry

ide connected drive
amd64 architecture

description: updated

unable to continue installation
unable to select file system in partition menu
unable to select mount point in partition menu

tdflanders (thomasdelbeke) wrote :

Bug #312363:
This report is public

I am sorry, I posted the above one as I was not sure it would be entirely the same, eg. have some added info.

It happend after the big rsync (539MB), speedup 1.25. (jaunty-desktop-i386.iso)

CeesSluis (testcees) wrote :

Similar error if you try to install Jaunty in a vmplayer environment if you do not use guided setup but try to edit a existing partition.

CeesSluis (testcees) wrote :

It is a known issue in the Jaunty Alpha 2 release notes. It should not be reported as a bug. Sorry.

Just because the bug is known this does not mean it is not a bug (that should be tracked). IMHO it should never happen that an issue is mentioned in the release notes without a ticket number attached.

Changed in ubiquity:
status: New → Confirmed
jerrylamos (jerrylamos) wrote :

Not being able to "install" is a pain in the !@#$% which impacts my ability to test jaunty on my four different test pc's. There are tons and tons and tons of updates being released, however without being able to install in the first place it's pointless.

"Guided" is a very lame excuse for me. "Guided" absolutely refuses to pick a blank formatted partition and INSISTS on blasting one of my existing very useful partitions.

Partial solution is what I'm using here, download the Daily Live .iso, install in a 1 gb partition (800 mb would do), create a 512 mb casper-rw to use persistent. Booting is a bit slow on two of the pc's because I have to boot in rescue mode and manually vim /etc/X11/xorg.conf every time to put in Driver "Intel" Option "NoAccel" "true" which is another one of the stated Alpha 2 bugs which hasn't been fixed yet either. Oh, yes, rescue mode doesn't start the network so do a sudo dhclient.

In spite of all that, when I do get Jaunty up, it's running very nicely for me, youtube videos and all. Scrolling is languid with the NoAccel but at least it works.

Jerry

Evan Dandrea (ev) on 2009-01-12
Changed in ubiquity:
status: Confirmed → Fix Committed
Changed in ubiquity:
importance: Undecided → High
status: Fix Committed → Confirmed
Evan Dandrea (ev) on 2009-01-13
Changed in ubiquity:
status: Confirmed → Fix Committed
jerrylamos (jerrylamos) wrote :

Today's daily build 20080113 oversize at 795.3 MB (!) install edit partition still fails. Anyone have any idea when the promised ubiquity fix may be available?

Thanks, Jerry

Ernst Sjöstrand (ernstp) wrote :

The fix seems to have been commited to Ubiquity in "upstream": https://code.launchpad.net/~ubuntu-installer/ubiquity/trunk (rev 2966?)
I assume they will make a package with it any time now.

Evan Dandrea (ev) on 2009-01-14
Changed in ubiquity:
status: Fix Committed → Fix Released
Ernst Sjöstrand (ernstp) wrote :

Downloaded the update on a livecd from last week and now everything went fine!

what package did you update?
I enabled all software sources, and updated ubiquity but it still crashed/got stuck.

Workaround: I deleted the partition and created a new one from the free space. I could now select the filesystem/mount-point and continue installing.

Evan Dandrea (ev) wrote :

Lucian,
If you are getting a crash using ubiquity 1.11.3, please file a new bug.

Evan Dandrea (ev) wrote :

ubiquity (1.11.3) jaunty; urgency=low

  [ Colin Watson ]
  * Correct Bazaar link in debian/copyright, really this time.
  * Update copyright years.
  * Fetch subarchitecture in remove_extras (LP: #316446).

  [ Evan Dandrea ]
  * Fix the edit partition dialog by properly preseeding
    partman/active_partition.
  * Add support for encrypting the home directory to the gtk frontend.
  * Automatic update of included source packages: apt-setup
    1:0.37ubuntu8, partconf 1.30ubuntu1.

  [ Mario Limonciello ]
  * Reset random mysql password on every ubiquity mythbuntu invocation.
  * Don't set anything in the mythbuntu_summary step.
  * Transition apply-type code into python to be called directly from
    mythbuntu_install.py instead.
    - Along with this, handling for leaving files when not reformatting
      /home should be fixed. (LP: #305236)
    - Mythweb acl to SQL should be fixed now, but not necessarily
      authentication.

 -- Evan Dandrea <email address hidden> Tue, 13 Jan 2009 21:28:32 -0500

jerrylamos (jerrylamos) wrote :

Today's build 20090114 got farther on manual partition however refused to continue install because /cdrom, a hard disk partition, was still mounted. gparted has no trouble formatting a partition with other partitions mounted, ubiquity shouldn't have stopped because of this. See bug #313452.

I tried pre formatting the partition to be installed to however ubiquity still hung up because some other partition that it was not installing to was mounted. This is a 7 boot setup, only one of them is to be installed to, with no resizing or anything else, just set its mount point to /.

Is ubiquity trying to rewrite the entire partition table?

Thanks, Jerry

jerrylamos (jerrylamos) wrote :

Today's build 20090115 still fails. Installer says it needs to "commit changes to the partition table" and will not do it because there is another partition mounted than the one it wants to change.

What's the change the installer wants to do?

Format shouldn't change the partition table?

Mount point shouldn't change the partition table?

Previous CD Live did not have this problem.

Appreciate a fix so I can test the new build.

Thanks, Jerry

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers