Ubuntu

no partitions listed in partition table

Reported by bob on 2008-10-24
58
This bug affects 8 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

ubiquity, ubuntu 8.10 rc1

Step 4 of 7: Prepare Partitions:

- Partition table is empty (no devices or partitions listed)
- All buttons (New partition table, New partition, ...) grayed out
- 'Next' button gives the error: 'No root file system is defined. Please correct this from the partitioning menu.'

I'm installing on a machine with a single SATA hard drive. The disk currently has two ext3 partitions, two ntfs partitions and a swap partition.

It worked fine in one of the late betas (beta 5 I'm fairly sure).

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.5
Package: ubiquity 1.10.7
ProcAttrCurrent: unconfined
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
Uname: Linux 2.6.27-7-generic i686

bob (amagee) wrote :
bob (amagee) wrote :

It also works fine if I choose to install directly rather than running the live cd. Even if I start to install, then cancel (which takes me to the live cd), then install from there, it works.

Wenbo Yang (solrex) wrote :

I encountered this problem too. Installed from HD drive using:
http://archive.ubuntu.com/ubuntu/dists/intrepid/main/installer-i386/current/images/hd-media/[initrd.gz, vmlinuz]

ISO Version:
RC: ubuntu-8.10-rc-alternate-i386.iso 22-Oct-2008 06:08 698M
and Daily Build: intrepid-alternate-i386.iso 25-Oct-2008 07:34 701M

A single 40G hard drive(maybe ATA).

# fdisk -l
Disk /dev/sda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xfd478bc7

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 765 6144831 83 Linux
/dev/sda2 766 2040 10241437+ 83 Linux
/dev/sda3 2041 2078 305235 82 Linux swap / Solaris
/dev/sda4 2079 4865 22386577+ 83 Linux

/dev/sda2: / of a Ubuntu 8.04 Linux
/dev/sda1: previously / of a CentOS Linux, formated.
/dev/sda4: normal data, /data

Kamalakar Agashe (kagashe) wrote :

I am also facing this problem and could not install. only-ubiquity also does not work for me.

I am using Desktop RC ISO released on Oct 23.

Is there any workaround for this.

Kamalakar Agashe (kagashe) wrote :

I made Live USB from System/Administrartion and tried the installer from the desktop. Partitions were not listed.

Then I tried only-ubiquity option. This time partitions of USB stick were listed but hard disc was still not detected.

I feel this is a serious type of bug.

Kamalakar Agashe (kagashe) wrote :

Ok. I was facing this problem because I was trying to install by copying Live CD to one partition and trying to install on another partition of same hard disc. The partition where I copied the contents of Live CD gets mounted as /cdrom and that is the reason why Ubiquity does not detect the partitions.

When I was booting from USB it also detected the partition where I had previously copied the LIve CD and mounted it at /cdrom.

Then I deleted the Live CD contents from the hard disc and tried again by booting from USB stick.

This time USB stick was mounted at /cdrom and Ubiquity detected the hard disc partitions.

For me there is no problem.

GibbZ (b33tr00t) wrote :

Yea i seem to be having the same problem here. I`ve tried both the full new release desktop 8.10 and alternate cd s. I tried the guided route as well and still no partitions listed. I too , have only one sata drive that`s got two ntfs partitions and two ext3 partitions , non off which show in ubiquity ? Trying to find my usb stick to give that ago but as it stands at moment , no Ubuntu 8.10 for me :( . If there is any more info you need , let me know ?

GibbZ (b33tr00t) wrote :

Ok now i`ve tried installing from a live usb but still no further forward . In the partitioner their is no partitions showing only one hard drive (sda) which appears to be empty .

GibbZ (b33tr00t) wrote :

Now i really don`t know whats going on but i just tried to install 8.04 LTS and try to upgrade but Hardy is doing the same thing and only showing one drive without any partitions . Must be something to do with my set up so scrap my input on this.
I`m a bit lost now , but thanks anyway :)

gulch (gulch-live) wrote :

 Fix Ubuntu 8.10 Intrepid bug/288675 "no partitions listed in partition table"
http://ubuntuforums.org/showthread.php?p=6081365

That is an easy way to solve the problem:

1. plesae use the Alternative iso;

2. when partition, run shell, you can see /hd-media,
only need run as following:
# umount -l /hd-media
# exit

3. now you can see partition tab, good luck!!!

Thanks for the last tip, Im using the desktop ISO booting from a pen drive, my list is empty but if umount the partitions of my hard disk (that are mounted by default) and start the installer again the partitioner goes forward.

Appears just to be a problem with the partitions already being mounted and not appearing.

Regards.

To have all the partitions listed in ubiquity it did also work for me to unmount everything that had been mounted on my hard drive.

However, this turned out to be a major problem as I had previously used UNetbootin to set up a partition to boot and install Xubuntu from on that same hard drive.

I was also wondering why there was anything being mounted from my hard drive in the first place except for the partition where I intended to be installing from?

Nick Glynn (exosyst) wrote :

I hunted out this as I had a similar problem as I was installing without CD-ROM by extracting the ISO to an existing Fedora install and booting from there via grub.

I *simply* performed the following which prompted ubiquity to spring back to the realm of usable:

sudo umount -l -r -f /dev/sda3 (where sda3 was the device mounted as cdrom)

Ric Flomag (ricflomag) wrote :

Thanks NickSpencer!

jnewm (jessenewmark) wrote :

Ditto the thanks NickSpencer. I had the same problem using Unetbootin for Ubuntu 8.10 and going to install through the Live CD.
PS I actually unmounted my hard drive though, I think; I put sudo umount -l -r -f /dev/sda1 (after using sda3 didn't work). Then my hard drive popped up in Nautilus under My Computer. And when I started install, my partitions showed up.

marmuta (marmuta) wrote :

This just happened to me on 9.04 Jaunty Alpha4 too.
The Live CD automounted an USB Stick that happend to be plugged in at the time of installation.
The Prepare Partition step then showed up empty. Unmounting the sticks partitions solved it.
IMO Ubiquitiy should at least show an error message when there are mounted partitions. Like it is right now there is no hint of what to do when the list is empty.

Ivan Frederiks (idfred) wrote :

I think, this bug is related to dug #548894 and not to bug #335376.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Jonathan (miareggeti) wrote :

This is a duplicate of another bug, which says "Fixed Released"

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers