Guided Partitioning: Ubiquity should not offer to resize partitions further than it is possible to resize them without losing data.

Bug #287547 reported by Sarah Kowalik on 2008-10-22
4
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Colin Watson
Intrepid
Critical
Colin Watson

Bug Description

Binary package hint: ubiquity

On a 12gb drive, guided partitioning, ubiquity gives me the default option of having the previous ubuntu install resized to be 2gb, and the new install to use the rest of the available space. It then complains that the (I presume, previous - it doesn't actually say) partition size is too small (with an unprofessional error message). Making the previous partition bigger, and the new ubuntu install smaller seems to solve this (or if it doesn't, will result in another bug).

If the partition size is too small, why is it allowed by the partitioner anyway? I presume that it is refusing to resize the previous ubuntu, as it would result in data loss.

Intrepid Ibex RC candidate.

This eventually hangs, then shows an error dialog, and drops you to a manual partitioning box.

Changed in ubiquity:
importance: Undecided → Critical
milestone: none → ubuntu-8.10

Error dialog occurs at 50% of resizing partition dialog

Error dialog: An error occured while writing changes to the storage devices. The resize operation has been aborted.

It then drops you to a manual partitioning dialog.

Alan Searchwell (searchie) wrote :

I have made sme comments at the following link that I hope could provide some solutions to the problems of partitioning:

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/268115/comments/1

Alan

Evan (ev) wrote :

Sarah,

Can you run ubiquity in debug mode (ubiquity -d) and attach /var/log/syslog, /var/log/installer/debug, and /var/log/partman to this bug report?

The too small size message happens when ubiquity feeds back a smaller size than partman-partitioning will allow, usually due to a rounding error or loss of accuracy when converting between units. I can easily fix that by having it feed back the minimal accepted value when it intended to send back a value less than that, but I will think over the implications of this first.

I agree that "Too small size" is a terrible error message and have filed bug 287635 for it.

I suspect your resizing error actually occurred in resize2fs or in partman-partitioning's selection of a wrong minimal resize value, but I'll need to see the logs to be sure.

Thanks

Colin Watson (cjwatson) wrote :

I analysed this on the train. I agree with Evan that the problem is due to rounding; specifically, the resize widget is returning a percentage that isn't properly clipped to the minimum and maximum sizes. While we should certainly do this clipping, I think it would improve things further if the resize widget passed a precise size through to the backend rather than simply a percentage. How does the attached patch look?

This is a clear regression in the new resize widget that many users will run into during installation without doing anything particularly outrageous, and so I think it's critical for 8.10 final. IMO we should get this or something similar tested and uploaded today.

Changed in ubiquity:
status: New → Triaged
Colin Watson (cjwatson) on 2008-10-24
Changed in ubiquity:
status: Triaged → In Progress
Colin Watson (cjwatson) on 2008-10-26
Changed in ubiquity:
assignee: nobody → kamion
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.10.8

---------------
ubiquity (1.10.8) intrepid; urgency=low

  [ Jonathan Riddell ]
  * KDE Frontend, in liveinstaller.ui change size policy to
    stop release notes widget being half hidden
  * ubiquity-dm: turn off compositing for kwin (also don't run dcopserver)
    Closes LP: #285626

  [ Evan Dandrea ]
  * Optimize the blacklist generation. Thanks Colin Watson.
  * Add ubiquity/install/generate-blacklist preseed key for file
    blacklist generation.

  [ Colin Watson ]
  * Clip the resize widget's value to the allowed minimum and maximum size,
    and pass it to the backend as an exact size rather than as a percentage
    to avoid rounding errors (LP: #287547).
  * Automatic update of included source packages: grub-installer
    1.32ubuntu10, kboot-installer 0.0.1ubuntu8, partman-target 55ubuntu5.

 -- Colin Watson <email address hidden> Sun, 26 Oct 2008 04:19:31 +0000

Changed in ubiquity:
status: Fix Committed → Fix Released
Changed in ubiquity (Ubuntu):
status: Fix Released → New
Evan (ev) wrote :

Please do not reopen bugs without reason. If you are experiencing a bug in the installer, please file a new bug by following these instructions:
https://help.ubuntu.com/community/ReportingBugs

Changed in ubiquity (Ubuntu):
status: New → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers