blank window on livecd with "Install" boot option

Bug #285626 reported by Benjamin Kay on 2008-10-18
2
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Jonathan Riddell
Intrepid
High
Jonathan Riddell

Bug Description

Binary package hint: ubiquity

The Kubuntu 8.10 (Intrepid) Beta amd64 Desktop livecd provides a number of boot options, like "Try Ubuntu Without Installing", "Install Ubuntu", "Check CD For Defects", and so forth. If the user opts to try without installing, everything works fine, including installation via the "Install" icon on the Desktop.

If the user choses the "Install" boot option, he gets a Desktop environment with a blank/empty Ubiquity window on an all-black background with no Task Manager at the bottom of the screen. Attempting to close the Ubiquity window has no effect. This is on a Thinkpad T61 with an Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c).

This would probably confuse the heck out of someone who doesn't know you can also install via the "Try Ubuntu Without Installing" boot option.

Colin Watson (cjwatson) wrote :

It's possible that this is hardware-specific, but I'll have to try it to find out. The download has an ETA of 3 hours, though, so it'll take a while ...

It is of course deliberate that the Task Manager is missing. That's the point of the "Install Kubuntu" mode - it saves memory and provides a simpler environment by not starting a full desktop. Of course it does go rather wrong if Ubiquity fails to start up usefully, which isn't meant to happen!

Benjamin Kay (benkay) wrote :

Thanks for looking into this. I recently tested the "Install" boot option on the Ubuntu 8.10 Beta CD, and it works fine. I retested with the Kubuntu 8.10 Beta CD just to be sure, and it's definitely broken. The background is all black and the Ubiquity window, while decorated, is empty. Pressing Ctrl+Alt+Backspace gets me into the livecd desktop environment I would have ended up in if I had gone with the "Try without installing" boot option.

Evan (ev) wrote :

I cannot reproduce this with the latest Kubuntu daily-live (20081019)

Benjamin,

Can you arrow to the "Install" option, press F6 and add debug-ubiquity to the options. When you get to the blank installer screen, press ctrl-alt-backspace, which should bring you to a regular desktop. From there can you attach /var/log/syslog and /var/log/installer/debug.

Thanks!

Colin Watson (cjwatson) wrote :

In addition to what Evan said, /var/log/installer/dm would be good too.

Evan (ev) wrote :

Sorry, to be clear, attach those files to this bug report following the instructions in http://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs

Benjamin Kay (benkay) wrote :

I booted in "Install" mode with debug-ubiquity as the last option using today's daily-live. Today's daily is slightly different from the Beta (even without the debug option) in that there's no ubiquity window -- just a blank, black screen with an X shaped mouse pointer.

I've attached the requested log files.

Evan, what graphics card are you using? Are you using the x86 or the x86_64 CD?

Colin Watson (cjwatson) wrote :

I get almost exactly the same output on a working system (kvm emulation, i386) except that you have an additional:

  Application::crashHandler() called with signal 11; recent crashes: 1

Could you look in /var/crash/ and see what files are listed there?

Benjamin Kay (benkay) wrote :

Sure, I'm attaching the only file in /var/crash.

Jonathan Riddell (jr) wrote :

I can confirm this. It also happens after a Wubi install. I wouldn't have thought the kwin crash was the problem, kwin does recover.

Changed in ubiquity:
status: New → Confirmed
Jonathan Riddell (jr) on 2008-10-21
Changed in ubiquity:
importance: Undecided → High
Jonathan Riddell (jr) wrote :

Tested today with an image of 20081022 i386 in VMware 6.5 (Display configured with acceleration)

Ubiquity starts just fine, though the black screen and "X" cursor is there for a second or two longer than you'd expect.

Also fine with acceleration turned off for that VM

Nothing in /var/crash

Things may not be right because the root window doesn't have a colour, it starts black but turns into the colour of the window

Benjamin Kay (benkay) wrote :

This bug is still manifest in the release candidate. I still get nothing but a blank, black screen with an X shaped mouse pointer.

Colin Watson (cjwatson) wrote :

I'm afraid I need a Kubuntu expert to debug this. I've tried and got nowhere.

Colin Watson (cjwatson) wrote :

Oh, sorry, never mind that last comment. Jonathan already mentioned to me that he'd committed a fix to bzr (i.e. disabling compositing), but I forgot about that. Marking as fix-committed.

Changed in ubiquity:
assignee: nobody → jr
status: Confirmed → Fix Committed
milestone: none → intrepid-updates
milestone: intrepid-updates → ubuntu-8.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.10.8

---------------
ubiquity (1.10.8) intrepid; urgency=low

  [ Jonathan Riddell ]
  * KDE Frontend, in liveinstaller.ui change size policy to
    stop release notes widget being half hidden
  * ubiquity-dm: turn off compositing for kwin (also don't run dcopserver)
    Closes LP: #285626

  [ Evan Dandrea ]
  * Optimize the blacklist generation. Thanks Colin Watson.
  * Add ubiquity/install/generate-blacklist preseed key for file
    blacklist generation.

  [ Colin Watson ]
  * Clip the resize widget's value to the allowed minimum and maximum size,
    and pass it to the backend as an exact size rather than as a percentage
    to avoid rounding errors (LP: #287547).
  * Automatic update of included source packages: grub-installer
    1.32ubuntu10, kboot-installer 0.0.1ubuntu8, partman-target 55ubuntu5.

 -- Colin Watson <email address hidden> Sun, 26 Oct 2008 04:19:31 +0000

Changed in ubiquity:
status: Fix Committed → Fix Released
Benjamin Kay (benkay) wrote :

Tested with the October 27 daily-live. The GUI is drawn a bit ugly (especially buttons), but it works. Thanks, everyone!

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers