[Intrepid] Partition labels overlap in partitioner

Bug #271554 reported by Ioannis Ramfos on 2008-09-18
52
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Evan
Intrepid
Medium
Evan

Bug Description

Binary package hint: ubiquity

When reaching the partitioner of the installer, 3 options are presented:
1. Guided - resize ...
2. Guided - use entire disk
3. Manual

At first, the installer shows the partition labels under the bars correctly (screenshot partitioner_1). When selecting the second or third option, the labels overlap (screenshot partitioner_2), even if selecting the first option again.

Ioannis Ramfos (isr81) wrote :
Ioannis Ramfos (isr81) wrote :

Changing bug status to confirmed. Intrepid i386 desktop alpha 6 live cd.

Changed in ubiquity:
status: New → Confirmed

Confirming for the AMD64 desktop install CD of alpha 6

Colin Watson (cjwatson) on 2008-09-29
Changed in ubiquity:
importance: Undecided → Medium
status: Confirmed → Triaged
milestone: none → ubuntu-8.10
Martin Pitt (pitti) wrote :

I see that as well, also, the second bar is fairly useless at the moment, since it never actually shows how the target schema will look like. There "Ubuntu 8.10 -35%" is confusing; I guess it refers to the previous installation, but there's no way to tell, and there is not a single bit of orange in the bar either.

Dave Morley (davmor2) wrote :

This bug is tied into bug 271512 also evand is aware of it and it working on it I believe :)

Ara Pulido (ara) wrote :

I can confirm that this happens for Xubuntu Desktop (20081001), when installing in Spanish

Colin Watson (cjwatson) on 2008-10-02
Changed in ubiquity:
assignee: nobody → evand
status: Triaged → Fix Committed
Colin Ian King (colin-king) wrote :

and I can confirm this happens for Ubuntu Desktop AMD64 (20081001), when installing in English http://cdimage.ubuntu.com/daily-live/20081001/intrepid-desktop-amd64.iso

MadsRH (madsrh) wrote :

I can confirm this for the beta release too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.10.4

---------------
ubiquity (1.10.4) intrepid; urgency=low

  [ Colin Watson ]
  * Only show the "EFI boot partition" option while creating a partition if
    the current hardware supports it usefully.
  * When creating a new partition, default to logical if a primary partition
    already exists, since there are stricter constraints on primary
    partitions and the only real reasons for them are Microsoft operating
    systems or boot partitions (LP: #218938).
  * Fix intltool handling; po/Makefile.in.in was still coming from gettext.
    Pass no-xml to IT_PROG_INTLTOOL so that we don't need to build-depend on
    libxml-parser-perl.
  * Check whether log files exist before copying them (thanks, Vitaly
    Petrov; see LP #279003).
  * Adjust live filesystem mounting for Debian (thanks, Vitaly Petrov; see
    LP #279003).
  * Reconfigure splashy (thanks, Vitaly Petrov; see LP #279003).

  [ Evan Dandrea ]
  * Accurately place and calculate the total size of the new partitions
    (LP: #271512).
  * Calculate the allocation for the labels after adding a new segment in
    segmented_bar (LP: #271554).
  * Do not remove the files for packages that will break other packages when
    removed (LP: #276657).
  * Fix a crash in the noninteractive frontend due to missing auto_login
    functions.
  * Automatic update of included source packages: partman-ext3
    52ubuntu3, partman-jfs 26ubuntu2, partman-reiserfs 41ubuntu3,
    partman-xfs 41ubuntu2, user-setup 1.20ubuntu8.
  * Automatic update of included source packages: partman-efi 18ubuntu1.

  [ Emmet Hikory ]
  * Build partman-efi udebs for amd64 and lpia
  * Build grub-installer udeb for lpia (LP: #277225)

 -- Evan Dandrea <email address hidden> Wed, 08 Oct 2008 14:01:39 -0400

Changed in ubiquity:
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers