Intrepid: Partition reports incorrect sizing

Bug #271512 reported by Dave Morley on 2008-09-17
34
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Evan
Intrepid
Medium
Evan

Bug Description

RELEASE: Intrepid
CD/DVD VARIANT: 32bit Ubuntu Desktop cd
ISO BUILD: 20080917.1

SYMPTOMS: Display shows that there is a -1 sized partition.

CAUSE: Unknown

STEPS TO REPRODUCE:
1/ install Ubuntu on the resize partition it shows the incorrect sum

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :
Evan (ev) on 2008-09-24
Changed in ubiquity:
assignee: nobody → evand
importance: Undecided → Medium
status: New → Confirmed
Colin Watson (cjwatson) on 2008-10-01
Changed in ubiquity:
milestone: none → ubuntu-8.10
status: Confirmed → Triaged
Evan (ev) on 2008-10-02
Changed in ubiquity:
status: Triaged → Fix Committed
VladNistor (vladnistor) wrote :

I can confirm the bug. This also happened to me when i tried to install Ubuntu from the Live Session. It's the 30.09 i386 desktop version of Intrepid Beta.
I got negative numbers [%] on the partition i was resizing for Intrepid. I got an error saying that there were "uncorrected errors on my ext3 partition" i was resizing. I chose the "Continue option" to ignore the problem [there wasn't really any problem, the installer just thought there was] and then i got an error "There was an error writing the changes to the storage device. The resizing operation has been aborted."
This only occurred when i tried to install from Live Session, it worked perfectly fine when i chose "Install Ubuntu" on boot instead of "Try Ubuntu without any changes to your system" which takes me to Live Session.
I'm attaching photos. If you need anything else you think i can get i'd be more than glad to help.

VladNistor (vladnistor) wrote :
VladNistor (vladnistor) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.10.4

---------------
ubiquity (1.10.4) intrepid; urgency=low

  [ Colin Watson ]
  * Only show the "EFI boot partition" option while creating a partition if
    the current hardware supports it usefully.
  * When creating a new partition, default to logical if a primary partition
    already exists, since there are stricter constraints on primary
    partitions and the only real reasons for them are Microsoft operating
    systems or boot partitions (LP: #218938).
  * Fix intltool handling; po/Makefile.in.in was still coming from gettext.
    Pass no-xml to IT_PROG_INTLTOOL so that we don't need to build-depend on
    libxml-parser-perl.
  * Check whether log files exist before copying them (thanks, Vitaly
    Petrov; see LP #279003).
  * Adjust live filesystem mounting for Debian (thanks, Vitaly Petrov; see
    LP #279003).
  * Reconfigure splashy (thanks, Vitaly Petrov; see LP #279003).

  [ Evan Dandrea ]
  * Accurately place and calculate the total size of the new partitions
    (LP: #271512).
  * Calculate the allocation for the labels after adding a new segment in
    segmented_bar (LP: #271554).
  * Do not remove the files for packages that will break other packages when
    removed (LP: #276657).
  * Fix a crash in the noninteractive frontend due to missing auto_login
    functions.
  * Automatic update of included source packages: partman-ext3
    52ubuntu3, partman-jfs 26ubuntu2, partman-reiserfs 41ubuntu3,
    partman-xfs 41ubuntu2, user-setup 1.20ubuntu8.
  * Automatic update of included source packages: partman-efi 18ubuntu1.

  [ Emmet Hikory ]
  * Build partman-efi udebs for amd64 and lpia
  * Build grub-installer udeb for lpia (LP: #277225)

 -- Evan Dandrea <email address hidden> Wed, 08 Oct 2008 14:01:39 -0400

Changed in ubiquity:
status: Fix Committed → Fix Released
Ioannis Ramfos (isr81) wrote :

In daily 20081014, the negative sized partition is corrected, but the total partition sum is wrong. All the partitions sum up to 98% or 99% in a VM with a preinstalled daily (preexisting ext3 and swap). The percentages on the bars are also inconsisent with the percentages on the Guided - resize option, probably due to the swap partition.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers