Ubuntu

desktop install does not install fstab, causing boot failure

Reported by Martin Pitt on 2008-08-13
6
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Colin Watson
Intrepid
Critical
Colin Watson

Bug Description

Binary package hint: ubiquity

With the current 20080813 desktop CDs, ubiquity does not create an fstab (/etc/fstab in the installed system just has "#UNCONFIGURED FSTAB FOR BASE SYSTEM"). This causes grub-installer to fail later on:

   grub-installer: Cannot determine root device. Assuming /dev/hda1
   grub-installer: This error is probably caused by an invalid /etc/fstab

and thus the booting fails.

Related branches

Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :

The alternate CD works, it creates a proper fstab and grub-installer does its job.

Both installs (deskop and alternate) were done with standard options and "use entire disk".

Changed in ubiquity:
importance: Undecided → Critical
Ara Pulido (apulido) wrote :

This is happening also in Kubuntu desktop CDs

Changed in ubiquity:
status: New → Confirmed
Martin Pitt (pitti) wrote :

Colin, can you please have a look or delegate to Evan as appropriate?

Changed in ubiquity:
assignee: nobody → kamion
milestone: none → intrepid-alpha-5
Martin Pitt (pitti) wrote :

I ran the install again in debugging mode (will attach logs in a minute), but there is not a single mention of partman-target in /var/log/partman. finish.d/ doesn't even seem to run. However, since I have no clue how the log is supposed to look like, this is all just speculation.

Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :

Apparently this is caused by http://bazaar.launchpad.net/~ubuntu-installer/ubiquity/trunk/revision/2753, so that the squashfs'es /etc/fstab overwrites the one which gets created in /target/.

According to Mario, this is the only file we create prior to copying, thus we special-case fstab for alpha-4.

Martin Pitt (pitti) wrote :

Confirmed this bug on real hardware, originally I believed it was only an issue in kvm (since we got two positive test results on real iron). A4 blocker.

Changed in ubiquity:
milestone: intrepid-alpha-5 → intrepid-alpha-4
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.9.9

---------------
ubiquity (1.9.9) intrepid; urgency=low

  * Explicitly remove etc/fstab from the list of files to be copied over.
    It is created from partman prior to file copy, so the recent commit
    to unlink files if they exist already is remvoing it. (LP: #257580)

 -- Mario Limonciello <email address hidden> Wed, 13 Aug 2008 14:30:41 -0500

Changed in ubiquity:
status: Confirmed → Fix Released
Ara Pulido (apulido) wrote :

I have tested the fix successfully under kubuntu live cd 20080813.2

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers