Installer doesn't know whether you have Internet access

Bug #254639 reported by Matthew Paul Thomas on 2008-08-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

Ubuntu Intrepid alpha 3

1. Start the installer.

What you see:
* "If you have Internet access, read the release notes for information on problems that may affect you."
* A "Release Notes" link.

What you should see:
* If you are connected to the Internet, the "Release notes" link should be available (or the release notes should be displayed in the installer itself).
* If you are not connected to the Internet, the link should be greyed out. This could be explained with adjacent text, also greyed out: "Not available because this computer is not connected to the Internet."
* If you go online or offline while this panel is displayed, the link's availability should change automatically.

Checking whether you are connected to the Internet could be achieved by actually trying to retrieve the release notes. (After all, there's no point in offering them if you are online but ubuntu.com happens to be down.)

description: updated
Endolith (endolith) wrote :

And if you don't have Internet access, you can't see any release notes at all? This is braindead all around. If your network card isn't supported, then you can't download the release notes that tell you that your network card isn't supported?

What should happen:

1. Release notes should be included on the CD.
2. During installation, try to download the latest release notes.
3. If you can download them, display them in the installer, with hardware incompatibilities listed prominently (rich text with links would be best)
4. If you can't download them, say so and then display the old notes with a note explaining that they are old and more problems may have been discovered since they were written.
5. Provide a button to try loading them again after connecting a network cable.

Changed in ubiquity:
status: New → Confirmed
Phillip Susi (psusi) wrote :

The release notes have been removed, so this is no longer an issue.

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers