Criação de partição de swap

Bug #247993 reported by jc on 2008-07-12
24
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Colin Watson
Hardy
Medium
Colin Watson

Bug Description

Binary package hint: ubiquity

Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 1463, in on_partition_create_use_combo_changed
    text = str(self.create_dialog.partition_create_use_combo.currentText())
UnicodeEncodeError: 'ascii' codec can't encode character u'\xe1' in position 0: ordinal not in range(128)

Marcus Asshauer (mcas) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" [WWW] http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at [WWW] http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).
Thanks!

Changed in ubiquity:
status: New → Incomplete
Colin Watson (cjwatson) wrote :

Fixed for the next upload, thanks.

Changed in ubiquity:
assignee: nobody → kamion
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.9.5

---------------
ubiquity (1.9.5) intrepid; urgency=low

  [ Colin Watson ]
  * Update README to document --automatic option.
  * Direct questions to the ubuntu-installer list rather than to me
    personally.
  * Depend on kdesudo | kdesudo-kde4 (the latter is transitional now).
  * KDE frontend:
    - Fix crash on selecting non-ASCII options in the "Use as:" menu while
      creating a partition (LP: #247993).
    - Fix crash when entering a non-ASCII mount point (LP: #128554).
  * Preseed netcfg/dhcp_ntp_servers from install component rather than
    clock-setup, since the latter doesn't have debconf database access at
    the right time (LP: #251089).

  [ Jonathan Riddell ]
  * language.py: Change string to unicode, fixes crash when using KDE
    frontend, closes LP: #251097
  * KDE frontend
   - comment out dcop code
   - add set_hostname method
   - temporarily force sudo until we work out why kdesudo stops it passing
     partitioning stage, bug 251203

  [ Evan Dandrea ]
  * Automatic update of included source packages: user-setup
    1.20ubuntu3.

 -- Evan Dandrea <email address hidden> Wed, 23 Jul 2008 12:48:57 -0400

Changed in ubiquity:
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

Installation failure with a straightforward fix; I think we should clean this up for Ubuntu 8.04.3.

Changed in ubiquity:
importance: Undecided → Medium
milestone: none → ubuntu-8.04.3
status: New → Triaged
Colin Watson (cjwatson) on 2009-06-04
Changed in ubiquity (Ubuntu Hardy):
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

Accepted ubiquity into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubiquity (Ubuntu Hardy):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Beattie (sbeattie) wrote :

I was able to reproduce this issue with ubiquity from kubuntu 8.04.2 and can confirm that the version of ubiquity in hardy-proposed, 1.8.14, addresses the issue and allows installation to complete (tested with language set to Portuguese). Marking as verification-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.8.14

---------------
ubiquity (1.8.14) hardy-proposed; urgency=low

  * KDE frontend:
    - Fix crash on selecting non-ASCII options in the "Use as:" menu while
      creating a partition (LP: #247993).
    - Fix crash when entering a non-ASCII mount point (LP: #128554).
  * Automatic update of included source packages: partman-basicfilesystems
    56ubuntu5.

 -- Colin Watson <email address hidden> Tue, 09 Jun 2009 22:41:48 +0100

Changed in ubiquity (Ubuntu Hardy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers