ubiquity on intrepid kubuntu fails to start

Bug #247537 reported by Dave Morley on 2008-07-11
2
Affects Status Importance Assigned to Milestone
kdesudo-kde4 (Ubuntu)
Low
Unassigned
Intrepid
Low
Unassigned
ubiquity (Ubuntu)
High
Unassigned
Intrepid
High
Unassigned
xorg-server (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

Intrepid Alpha 2 build date of 20080710.

Ubiquity fails to start.

Running ubiquity from CLI gives me the following error:
File "/usr/bin/ubiquity", line 120, in <module> main()
File "/usr/bin/ubiquity", line 116, in main os.execvp(toexec[0], toexec)
File "/usr/lib/python2.5/os.py", line 354, in execvp _execvpe(file, args)
File "/usr/lib/python2.5/os.py", line 390, in _execvpe func(fullname, *argrest)
OSError: [Errno 2] No such file or directory

Steve Langasek (vorlon) wrote :

Specific to kubuntu; the issue here is that kdesudo-kde4 is not on the CD, so ubiquity isn't able to successfully reexec itself with root permissions under kdesudo.

That alone is probably insufficient to fix this bug, since kdesudo-kde4 doesn't ship kdesudo in /usr/bin, it ships it under /usr/lib/kde4/bin; so ubiquity still won't be able to re-exec itself without some path changes. Opening a kdesudo-kde4 task for this.

Changed in kdesudo-kde4:
importance: Undecided → High
milestone: none → intrepid-alpha-3
status: New → Confirmed
Changed in ubiquity:
importance: Undecided → High
milestone: none → intrepid-alpha-2
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.9.1

---------------
ubiquity (1.9.1) intrepid; urgency=low

  [ Evan Dandrea ]
  * Fixed the missing definition of HOSTNAME_BADDOTS, which was causing a
    crash when the user entered a hostname that ended in a dot.
  * Fix a crash introduced by the fix for LP: 40590.

  [ Jonathan Riddell ]
  * ubiquity-frontend-kde depends on kde-window-manager (KDE 4), not kwin
    (KDE 3).

  [ Colin Watson ]
  * Update file name for apt-setup 1:0.32.
  * Add apt-setup local generator to improve preseeding facilities.
  * KDE frontend: Use kdesudo-kde4 for now, and adjust ubiquity-wrapper to
    look for it in /usr/lib/kde4/bin/ (LP: #247537).
  * Automatic update of included source packages (limited to those packages
    where ubiquity code already expects newer versions): apt-setup
    1:0.37ubuntu2, partconf 1.27, partman-auto 78ubuntu1, partman-auto-loop
    0ubuntu15, partman-base 121ubuntu3, partman-basicfilesystems 60ubuntu1,
    partman-basicmethods 39ubuntu1, partman-efi 17ubuntu1, partman-ext3
    52ubuntu1, partman-jfs 26ubuntu1, partman-newworld 19ubuntu1,
    partman-partitioning 59ubuntu2 (LP: #247519), partman-reiserfs
    41ubuntu1, partman-target 55ubuntu1, partman-xfs 41ubuntu1.

 -- Colin Watson <email address hidden> Fri, 11 Jul 2008 13:19:10 +0100

Changed in ubiquity:
status: Confirmed → Fix Released
Colin Watson (cjwatson) wrote :

kdesudo fails to start ubiquity usefully because xauth generate fails; this turns out to be because the SECURITY extension is missing from the X server.

Colin Watson (cjwatson) wrote :

xorg-server (2:1.4.99.905-0ubuntu4) intrepid; urgency=low

  * debian/rules:
    Add --enable-xcsecurity --enable-appgroup. The SECURITY module was
    disabled by default in commit 86b2e59bfb79bd042a13c35fbb4ccecec576f629,
    as part of the SELinux merge. However, we need the security module
    for xauth on Kubuntu, else ubiquity fails. (Ref. LP 247537)

 -- Bryce Harrington <email address hidden> Wed, 16 Jul 2008 06:01:45 -0700

Changed in xorg-server:
milestone: none → intrepid-alpha-3
status: New → Fix Released
Colin Watson (cjwatson) wrote :

Now that X has been fixed, the kdesudo path change is not release-critical.

Changed in kdesudo-kde4:
importance: High → Low
milestone: intrepid-alpha-3 → none
Colin Watson (cjwatson) wrote :

This is fixed by the newer version in kdesudo (as opposed to kdesudo-kde4).

Changed in kdesudo-kde4:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers