Need to report resize errors

Bug #218973 reported by Brian Murray on 2008-04-18
6
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: ubiquity

ISO TESTED:
Kubuntu KDE4 amd64 daily build 20080417.1

I choose the guided resize option during installation for partition sda3, which is ext3, and it failed.

Brian Murray (brian-murray) wrote :
Brian Murray (brian-murray) wrote :
Brian Murray (brian-murray) wrote :
Evan (ev) wrote :

Apr 17 17:25:14 ubuntu ubiquity: resize2fs 1.40.8 (13-Mar-2008)
Apr 17 17:25:14 ubuntu ubiquity: Please run 'e2fsck -f /dev/sda3' first.
Apr 17 17:25:14 ubuntu ubiquity:
Apr 17 17:25:14 ubuntu partman: Error resizing the ext2/ext3 file system

Changed in ubiquity:
importance: Undecided → Low
status: New → Confirmed
Evan (ev) wrote :

Brian retried and the install completed fine, but I'm going to leave this open as we could fail more gracefully in this situation.

Evan (ev) wrote :

Also worth noting that the installer possibly switches to the manual partitioning page after this occurs.

Brian Murray (brian-murray) wrote :

I ran into this again with 20080423 and can confirm that it does switch to the manual partitioning page.

Brian Murray (brian-murray) wrote :

After exiting ubiquity because the resize failed I ran 'e2fsck -f /dev/sda8'. I then started ubiquity again and the resize failed and looking in syslog I see a message about running 'e2fsck -f /dev/sda8'. The relevant syslog is attached.

Brian Murray (brian-murray) wrote :

I ran ubiquity in debug mode to see if it would get anything more informative.

Steve Beattie (sbeattie) wrote :

Brian, Evan: is this still an issue in the Intrepid installer? You can use tune2fs -C to set the mount count high enough to require fscking (e.g. tune2fs -C 999 /dev/sda8). Or is there some other error occurring that is causing resize2fs to think that your filesystem needs fscking?

Michael Leandersson (tripokey) wrote :

it happened to me in kubuntu 8.10 amd64 beta2

according to this page:
http://raetsel.wordpress.com/2006/10/22/laptop-build-ntfs-resize-first-clean-your-windows/

all you need to do to reproduce it is to hard reboot your computer while running windows

tags: added: ubiquity-1.8.7
tags: added: hardy
Phillip Susi (psusi) on 2014-01-11
summary: - 20080417.1 Guided resize failed
+ Need to report resize errors
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers