Timezone map zooming is too sudden and disorienting

Bug #203423 reported by Matthew Paul Thomas on 2008-03-18
30
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Evan
Hardy
Undecided
Unassigned

Bug Description

Additional annoying usability bugs were discovered in ubiquity and were unable to be fixed in time for 8.04. These proposed changes should improve the experience of selecting a timezone location on the map for all users with minor risk of regression.

TEST CASE:
Run ubiquity and navigate to the time zone page. Check to see if the following problems occur:
- the zoom starts too quickly, it's not easy to move the mouse pointer over a country in less than one second which means it zoom on the wrong area while you are still moving.
- the zoom out effect needs a delay too, it's too easy to get the mouse pointer out of the widget while scrolling.
- the zoom is not correctly centered, putting the mouse pointer over the France make it zoom in the north of England for example.

The proposed patch as uploaded as part of ubiquity 1.8.8 can be found here:
http://launchpadlibrarian.net/14906817/203423-zoommap-usability.diff

Original report:

Ubuntu Hardy, alpha 6

When entering the map area to select a city, the map zooms in very quickly and jerkily. Combined with the high zoom level, this can make it difficult to see where you are in the map.

I suggest that the map (a) pause for one second after you enter, before it starts zooming in; (b) takes one second (or maybe even two) to zoom in; (c) pauses for one second after you exit, before it starts moving out; and (d) takes one second (or maybe even two) to zoom out.

description: updated
Evan (ev) on 2008-03-18
Changed in ubiquity:
assignee: nobody → evand
Michael Rooney (mrooney) wrote :

Thanks for your bug report. Luckily, this is a known issue and is a duplicate of bug #195159.

Matthew Paul Thomas (mpt) wrote :

No, it isn't. Bug 195159 is about how the map moves once it *is* zoomed in.

Colin Watson (cjwatson) wrote :

How do you feel about the behaviour in current daily builds? We made a number of changes:

ubiquity (1.8.5) hardy; urgency=low

  [ Evan Dandrea ]
  * Move the map when the cursor is near an edge instead of whenever the
    cursor moves (LP: #214989, #195159).
  * Various fixes to the new tzmap. Thanks Colin Watson.
    - Wait half a second before zooming in.
    - Zoom in from the position of the mouse, rather than the top left
      corner.
    - Widen the hover-to-move areas.
    - Find the closest hotspot if there are several nearby.
    - Zoom to 4.5x.

A half-second delay felt better than a second in my experiments, and I think the zoom level is now much more comprehensible combined with the zoom location fixes.

This doesn't yet involve a slower zoom, nor does it involve a delay on leaving the map before zooming out. I think those are probably still sensible ideas.

Sebastien Bacher (seb128) wrote :

The current version is still not nice to use, some issues are:

- the zoom starts too quickly, it's not easy to move the mouse pointer over a country in less than one second which means it zoom on the wrong area while you are still moving, maybe it should zoom after you stop moving the mouse for a second or so, that would allow user to select slowly their location?
- the zoom out effect needs a delay too, it's too easy to get the mouse pointer out of the widget while scrolling
- the zoom is not correctly centered, putting the mouse pointer over the France make it zoom in the north of England for example

Savvas Radevic (medigeek) wrote :

Bug #195159 is what the subject recommends: "The new time zone / city choosing is annoying"
I thought it would be best to sum them all up under one topic to keep track of things
But I guess you're talking about a different matter

Matthew Paul Thomas (mpt) wrote :

The map in 8.10 final is a little easier than before, thanks partly to implementation of (a). I still think implementing (b), (c), and (d) would make it much easier.

I can also reproduce the problem Sebastian experiences: if I move to Oslo in the first second, after zooming in the pointer is in the Arctic ice pack. Perhaps that should be a separate bug report.

Evan (ev) on 2008-05-30
Changed in ubiquity:
importance: Undecided → Medium
status: New → Confirmed
Evan (ev) wrote :
description: updated
description: updated
Changed in ubiquity:
milestone: none → ubuntu-8.04.1
status: New → Fix Committed
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Steve Beattie (sbeattie) wrote :

I have reproduced the usability problems in the original version of ubiquity, 1.8.7, as included with the 8.04 release. I then enabled the proposed repository and installed the current ubiquity in hardy-proposed, 1.8.11, and the usability of the timezone chooser is very much improved, the delays are pronounced enough to make the tool much more usable and less jarring.

I am still seeing the mouse pointer being in the wrong location after the chooser zooms in, but this appears to be because the mouse pointer is not moved to the center of the image after zooming, but remains in place (e.g. if you move to US/Alaska in the upper left corner, the chooser zooms in on it, but the pointer remains in the upper left). In my opinion, this is not a significant enough usability problem to block this fix from going in.

Marking verification-confirmed.

Steve Langasek (vorlon) wrote :

ubiquity 1.8.12 has been copied to hardy-updates.

Changed in ubiquity:
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

The same fixes appear to have been applied to Intrepid, although the changelog didn't contain a bug number so this bug never got closed:

ubiquity (1.9.0) intrepid; urgency=low

  [ Colin Watson ]
  * Fix ownership of /home/oem/Desktop in OEM installations (LP: #209683).
  * Silence deprecation warning in zoommap.
  * Add ubiquity-dm implementation for matchbox-window-manager (thanks,
    Patrick Hétu; see LP #159363).
  * Make use of RAWMINSIZE, RAWCURSIZE, and RAWMAXSIZE variables from
    partman-partitioning 59ubuntu2 to set accurate bounds on the resize
    widget.

  [ Evan Dandrea ]
  * Usability fixes for the timezone widget:
    - Make the hover-to-zoom areas relative to the widget size.
    - Zoom in on the location of the cursor, not the edge relative to its
      position.
    - Add a delay for zooming out.
  * Handle the migration-assistant UI being fed non-UTF data gracefully.
  * Make capitalization of migration-assistant consistent (LP: #225555).
  * Remember hostname between runs of ubiquity (LP: #40590).
  * Disable the close button for progress windows (LP: #107686).
  * Reset stay_on_page when the back button is pressed (LP: #235374).

  [ Mario Limonciello ]
  * Enable --automatic and preseeding support on the Mythbuntu frontend.

 -- Evan Dandrea <email address hidden> Mon, 02 Jun 2008 14:26:30 -0400

Changed in ubiquity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers