Ubuntu

"Less than a minute remaining" text is confusing and unnecessary

Reported by Caleb on 2008-03-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Andrew
ubiquity (Ubuntu)
Low
Andrew

Bug Description

The "Copying Files" text below the progress bar during the install process changes to "Copying files - less than a minute remaining" at some point in the process. However, it doesn't indicate less than a minute remaining in the entire install process, it appears to indicate that there is less than a minute remaining in the "copying files" stage. This can confuse and disappoint users when the install process takes longer than they expected. I suggest removing that bit of text entirely, because it isn't needed. Perhaps a "time-remaining" indicator should be added that applies to the entire install process.

Related branches

lp:ubiquity
Adolfo Jayme (community): Disapprove on 2014-04-02
Ondrej Pačay: Pending requested 2013-12-11
Jorge O. Castro (jorge) wrote :

Saw this on a reinstall, confirming.

Changed in ubiquity:
status: New → Confirmed
Colin Watson (cjwatson) on 2008-07-27
Changed in ubiquity:
importance: Undecided → Low
status: Confirmed → Triaged
Chris Myers (chris-ascent) wrote :

Confirmed. This could disappoint new users to Ubuntu.

ShawnJGoff (shawn-goff) on 2009-06-18
Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → round-7
Andrew (and471) wrote :

Do we want this string removed all together or just different wording?

(Ie. Nearly finished copying file)

As it is a good indicator of what is happening (and also useful for bug reports)

Changed in hundredpapercuts:
assignee: nobody → rugby471 (rugby471)
James Dearing (dearingj) wrote :

I say change the wording. As for the time-remaining indicator that applies to the whole install process, I think it's a good idea but do we have any reliable way to estimate that? I hate it when the Windows XP installer says I have like 15 minutes left and it ends up taking twice that long.

Andrew (and471) wrote :

I also think this needs to be a bigger part of a cleanup of ubiquity's installing dialog. my comment below will sum it up

Andrew (and471) wrote :

1) First the installer jumps from 15% to 0% when formatting the disks and then back to 15% when finished. this needs to be fixed as a continuous process

2) Copying files (less than a minute remaining) > Nearly finished copying files

3) Dialog has title 'Detecting hardware' and secondary text 'detecting hardware', no need for both, change title to 'installing system'

4) Dialog has 'Installing language packs' and no secondary text, change to title Installing system and secondary text 'installing language packs'

Attached is a video of the current installation process

Andrew (and471) on 2009-08-26
Changed in hundredpapercuts:
assignee: rugby471 (rugby471) → nobody
Andrew (and471) wrote :

I have submitted a branch which fixes this problem to be merged

Changed in hundredpapercuts:
assignee: nobody → rugby471 (rugby471)
status: Confirmed → In Progress
Changed in ubiquity (Ubuntu):
assignee: nobody → rugby471 (rugby471)
status: Triaged → In Progress
Evan Dandrea (ev) on 2009-09-08
Changed in ubiquity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.99.18

---------------
ubiquity (1.99.18) karmic; urgency=low

  [ Evan Dandrea ]
  * Do not provide an inaccurate remaining time estimate for the file copy
    process (LP: #199834). Thanks rugby471!
  * Call reboot as root. Thanks Mario Limonciello!
  * Don't let the user proceed past the timezone page until a selection has
    been made (LP 425011).
  * Automatic update of included source packages: partman-auto
    89ubuntu1, partman-partitioning 71ubuntu1.

  [ Michael Terry ]
  * Add a default oem-config post-install hook that restarts HAL. This lets
    HAL pick up any keyboard changes we made. LP: #395625

  [ Colin Watson ]
  * More packaging simplifications: move dh_clean arguments to debian/clean;
    remove old $(BUILDDIR) cruft; move architecture-specific
    build-dependencies to debian/control, which dpkg has supported for quite
    a while; use dh-di for partman scripts.
  * Update translations from Launchpad.
  * Fix method name to allow page changing in partitioner (LP: #427347).
  * Fix oem-config crash if the KDE frontend is detected, due to trying to
    delete UBIQUITY_MIGRATION_ASSISTANT from the environment when it's not
    there (LP: #414854).
  * Stop ubiquity-dm crashing if a process it's trying to kill doesn't exist
    (LP: #423700).

  [ Jonathan Riddell ]
  * Update path to kdesu in ubiquity-wrapper

 -- Evan Dandrea <email address hidden> Fri, 11 Sep 2009 19:26:50 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Andrew (and471) on 2009-09-19
Changed in hundredpapercuts:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers