The new time zone / city choosing is annoying

Bug #195159 reported by Savvas Radevic on 2008-02-24
84
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Evan

Bug Description

Ubuntu Hardy Heron 8.04 Alpha up to Beta

ubiquity:
  Installed: 1.7.10
  Candidate: 1.7.10
  Version table:
 *** 1.7.10 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

If you compare the 7.10 and 8.04 version of picking the time zone / city on a map, the new way is kind of annoying you have to be precise about your every mouse move over the city you want to choose. If you see the screenshot, you'll see that I somehow managed to highlight with the mouse over 3 cities at the same time.

I think the old way of choosing (click to zoom, click at city) was much more convenient.
It would be better if you reverted back to the Gutsy map to choose a country / city / time zone.

Related branches

Savvas Radevic (medigeek) wrote :
Colin Watson (cjwatson) on 2008-02-29
Changed in ubiquity:
importance: Undecided → Medium
status: New → Confirmed
Evan (ev) on 2008-02-29
Changed in ubiquity:
status: Confirmed → Fix Committed
Nanley Chery (nanoman) wrote :

I agree. Installing Hardy Alpha 6, the sensitivity for choosing the time zone is way too high. It is very difficult to chose now, where it only took little time in Gutsy.

bubba_169 (simonsos) wrote :

Agreed this is definately a problem. It took me about a minute, moving the mouse millimeters at a time, to choose my city. Compared to Gutsy's two clicks taking a couple of seconds in total this is terrible.

Savvas Radevic (medigeek) wrote :

Are you sure this is fixed? In which version?

Evan (ev) on 2008-03-14
Changed in ubiquity:
status: Fix Committed → Confirmed
Savvas Radevic (medigeek) wrote :

uh.. I reported mine at 2008-02-24 and this bug is a duplicate of a newer one??
Should be the other way around

description: updated
Evan (ev) wrote :

This should be a little bit easier to use in the daily live CDs and on the beta, but admittedly there's still work to be done on fixing it properly. Mitigating the issue is a top priority of mine. Reverting it would mean losing the ability to fit the ubiquity window in low resolution screens.

Changed in ubiquity:
assignee: nobody → evand
Evan (ev) wrote :

Savvas,

There is no such policy on marking duplicates. I tend to pick the bug report with the most activity as the master report.

Matthew Paul Thomas (mpt) wrote :

Would it be possible to highlight the city that the pointer is closest to, regardless of how far away it is? That would vastly increase the target area for most cities -- even if two cities were close, you could approach your city from the side opposite the other city.

Savvas Radevic (medigeek) wrote :

The thing is that some capital cities are too close to each other, we need the old "click to zoom - click to pick" map

Yes, Gutsy map was better.
I tried Hardy Alpha 4, and the new map was horrible. It even hanged on me once (don't know the reason) ..

Tarmas (maciejtarmas) wrote :

I haven't tried the map with a mouse, but installing Hardy on a laptop and moving around the map with a touchpad was a PAIN. It looks nice, but it's unusable in the current state.

Savvas Radevic (medigeek) wrote :

Confirming for hardy beta. The design is much better, but the map moves along with the mouse, this will cost a lot of people some time to choose their location. As Tarmas stated, laptop users will have a hard time using it.

description: updated
Evan (ev) on 2008-03-21
Changed in ubiquity:
milestone: none → ubuntu-8.04

Hmmm, I will try to be short to avoid ranting ;-)
... the old method "just worked"... the new/current method is a disater of usability, drove me completely nuts after only 5/10 seconds of (trying to) use it. I resorted to using the drop-down list, which revealed yet another usability porblem: the list is VERY long (of course), but the widget that is used does NOT provide a scroll bar.. so it took me ages to scroll down all the way down to pick up my time-zone. So after the map tested my nerves and accuracy as a mouse operator, the drop-down list tested my patience. ;-)

Savvas Radevic (medigeek) wrote :

I have to agree on that too, maybe they could make, instead of a drop-down box, a static plain list with a vertical bar on the side. simple, yet usable :)

Yes. Also, when you are asked to select the keyboard layout and the language, you also have a very long list of choices, but in both cases you have a scroll bar to let you find quickly what you need. So using the same arrangment for the time zine would solve the usability issue, as well as make things consistent accross ubiquity. And consistency being itself an important aspect of usability... we win twice ;-)

Hugh Wimberly (hugh-wimberly) wrote :

The old map was replaced because it caused problems, forcing the size of the window to be large enough that on computers where the install didn't correctly detect the resolution or couldn't use more than 800x600, it was impossible to read the the text on the buttons to move through the process.

I agree that the new map is a disaster (maybe even worse than not being able to read the button text), but we still need to use a map that will work on a low resolution installs.

Nanley Chery (nanoman) wrote :

The accuracy and smoothness has greatly improved in Hardy Beta. This bug is fixed for me!

johnwren (johnwren) wrote :

I agree, much better in the beta -- I have installed using a mouse, and it was fine. I'll try it later on a laptop with the touchpad.

Yes, the beta works much better for me too. The only thing that I could
suggest adding is a tooltip that would popup whenever you are over a city as
I found it hard to choose the correct city. I knew I was in the right area
but had to click on a few before I found Edmonton.

Thanks,
Gord

On Sat, Mar 22, 2008 at 11:29 PM, Nanley Chery <email address hidden>
wrote:

> The accuracy and smoothness has greatly improved in Hardy Beta. This bug
> is fixed for me!
>
> --
> The new time zone / city choosing is annoying
> https://bugs.launchpad.net/bugs/195159
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Tom Adams (holizz) wrote :

This is better than the alphas, but it seems to require two-pixel accuracy for clicking on a city, otherwise the map zooms back out and the city doesn't change (I assumed it had accepted my click on London, until I looked at the city name). Two-pixels is a really small target. I found it a challenge to hit cities.

Perhaps it would be a good idea to provide a more visible indicator that the city has changed (stick a big pin in it, perhaps? Or a text bubble with the name of the city pointing to the city, like Google Maps).

I also think it would be better if the map didn't scroll as the cursor was moved (moving targets are harder to hit). Perhaps clicking anywhere on the first click zooms (like previously), and after clicking anywhere but a city zooms in a bit more until a maximum zoom level is reached.

I fully agree with the above...

David Balažic (xerces8) wrote :

OK, guys, requiring the user to hit a 2 pixel area, while the background moves around is not funny.
It might have looked cool on the management presentation, but in practice it fails completely.

Hint: don't reinvent the wheel. Selecting items on maps (or actually selecting a timezone) has been done years/decades ago. Pick a working solution and move on to work on real problems.

Savvas Radevic (medigeek) wrote :

As it is stated on comment: https://bugs.edge.launchpad.net/ubuntu/+source/ubiquity/+bug/195159/comments/16
The older map was quite huge for some folks, so why not give it two or even three levels of zooming by clicking? I have to stick to my opinion that the moving background is still giving a lot of people a hard time. The aesthetic value is probably 0. The only thing that I can think of it being useful, is in the case of accessibility.

cerealkilla (cerealkilla23) wrote :

The scrolling is also horrible to make sense of when using the nv drivers, which all nvidia users will be at install time. It's too jerky to hit anything properly.

Still very difficult to select time zone in Beta.

Jumpy time zone selection in Beta should be fixed. It worked much better in Gutsy. It should not be broken for everyone just to support rare cases of very low 640x480 resolutions.

Current state is especially problematic for
- The handicapped
- Older people, or anyone without very good mouse skills and good motorics
- Users of alternative pointing devices

For everyone else, it just looks broken.

The main things that should be fixed are
- Pixel precission: clickable areas should be at least 5x10 px, preferably larger
- Moving backround: it should stay put.

I can see that this is already being fixed (assigned). Thanks for the fix you're working on!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.8.5

---------------
ubiquity (1.8.5) hardy; urgency=low

  [ Evan Dandrea ]
  * Move the map when the cursor is near an edge instead of whenever the
    cursor moves (LP: #214989, #195159).
  * Various fixes to the new tzmap. Thanks Colin Watson.
    - Wait half a second before zooming in.
    - Zoom in from the position of the mouse, rather than the top left
      corner.
    - Widen the hover-to-move areas.
    - Find the closest hotspot if there are several nearby.
    - Zoom to 4.5x.
  * Removed 12system_partitions_formatted. It now lives in partman-target.
  * Automatic update of included source packages: console-setup
    1.21ubuntu7, partman-target 54ubuntu6.

  [ Mario Limonciello ]
  * Default the MythTV theme to the newly changed Mythbuntu-8.04 theme
    to prevent upgrade crashes. (LP: #215036)

  [ Colin Watson ]
  * Allow diagonal scrolling in timezone map.
  * Update translations from Launchpad.
  * Fix typo in German welcome message (LP: #195075). This needs to be fixed
    in Launchpad or it *will* regress, but this will at least paper over it
    for 8.04.
  * Set OVERRIDE_ALLOW_PRESEEDING=1 while calling console-setup to force it
    to allow preseeding (LP: #188492).

 -- Evan Dandrea <email address hidden> Mon, 14 Apr 2008 20:47:52 -0400

Changed in ubiquity:
status: Confirmed → Fix Released
Savvas Radevic (medigeek) wrote :

Evan, I've tested the pre-RC (Release Candidate) iso from iso.qa.ubuntu.com in a virtual machine (virtualbox)
86dc6f4792fa5a69e73e30cd33cdfd11 *hardy-desktop-i386.iso

- I love the way the map can be resized and maximized! Could you put in a button or something to go fullscreen or maximize *just* the map? It could help a lot in reaching those small city pixels :)
- It's too "jumpy", too sensitive on the arrows at the four corners of the map and it moves too quickly.
- I would suggest a 500ms (or more) wait when the mouse is over a region and idle and then to zoom in.
Also, could you make a list of the city list?

I won't change the fix released, until this is confirmed on a physical machine.

James Payne (james-sonifex) wrote :

Whilst this is vastly improved in final with certain types of mouse and touchpads it can still be very annoying. I'd personally prefer it to scroll slowly and be patient.

Nick_Hill (nick-nickhill) wrote :

In 8.04.1 I can confirm selecting a city is difficult on some computers, easier on others. Seemingly dependent on graphics processing ability.

Scrolling whilst zoomed in doesn't usually work for me, Very snatchy movement, and imprecise. Frustrating.

I usually revert to wading through the long list of cities and select using the combo-box (drop-down list).

The city selection system on versions previous to Hardy always worked well for me.

Evan (ev) wrote :

We planned on reworking the timezone map for better usability in the ubiquity-visual-refresh [1] specification, but ran out of time in the 8.10 cycle. It will most likely land in Jaunty.

1: http://wiki.ubuntu.com/UbiquityVisualRefresh

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers