ubiquity crashed with TypeError: on_partition_list_edit_activate() takes exactly 2 arguments (4 given)

Bug #194688 reported by moma on 2008-02-23
38
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Evan

Bug Description

Binary package hint: ubiquity

Hello,

This test: Hardy alpha5 (i386). The CD and MD5SUM check are OK.

0) I start the installation from the LiveCD's install icon on the desktop.

1) I have some problems to set the / (root partition) and the /tmp partition (see bug https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/194684 ) but I finally manage to set them right.

2) The actual installation starts.

3) Installation fails because it cannot create ext3 file system on /dev/sda7 which is assigned to /tmp (will become the distros /tmp folder).
See picture: http://bildr.no/view/159623

/dev/sda7 is a small partitions (6GB of size) which I daily use as /tmp for various distros (ubuntu 7.10, 8.04, fedora). The partition is 100% ok.

ProblemType: Crash
Architecture: i386
Date: Sat Feb 23 11:15:18 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.5
Package: ubiquity 1.7.10
PackageArchitecture: i386
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcCwd: /home/ubuntu
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/9345/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with TypeError: on_partition_list_edit_activate() takes exactly 2 arguments (4 given)
Traceback: TypeError: on_partition_list_edit_activate() takes exactly 2 arguments (4 given)
Uname: Linux ubuntu 2.6.24-8-generic #1 SMP Thu Feb 14 20:40:45 UTC 2008 i686 GNU/Linux
UserGroups:

Related branches

moma (osmoma) wrote :
moma (osmoma) wrote :

Important note.

The title of this bug is wrong. I got several bugs and unfortunately the title got wrong in that hassle.

The correct title is: "Failed to create ext3 file system on /dev/sda7"

Colin Watson (cjwatson) wrote :

Broken by r2452; looks like the popup menu code wasn't updated.

Changed in ubiquity:
assignee: nobody → evand
status: New → Confirmed
Colin Watson (cjwatson) wrote :

We can fix the first crash you reported, but unfortunately the logs you posted don't cover the failure to create a file system, so we can't tell why it happened. If you can reproduce this, please post logs from an installation run covering that problem.

moma (osmoma) wrote :

Rehello,

I have produced the first error several times with other partitions (dev/sda5 and /dev/sda9). I rebooted between each test. Good you fixed it.

But I cannot reproduce the file system error anymore, so at the moment, I have no additional data logs to give.
I'll report to you immediately if the filesystem (formatting error) strikes.

So long, thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.7.12

---------------
ubiquity (1.7.12) hardy; urgency=low

  [ Colin Watson ]
  * Slight shell efficiency improvement in
    partman/check.d/03partition_too_small.
  * Use 'autoreconf -fi' so that Autotools files reliably get upgraded.
  * Upgrade to gettext 0.17.

  [ Evan Dandrea ]
  * Update partman_popup with respect to other recent changes
    (LP: #194688). Thanks Colin Watson.
  * Regain root when moving /etc/default/console-setup out of the way
    (LP: #188492). Thanks Colin Watson.
  * Minor changes to ubiquity-dm from suggestions by Colin Watson.
  * Remove suffix from icon path in .desktop file (LP: #188221).

  [ Jonathan Riddell ]
  * Fix QApplication args in ubiquity/frontend/kde_ui.py

 -- Jonathan Riddell <email address hidden> Mon, 25 Feb 2008 10:13:27 -0500

Changed in ubiquity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers