All hyperlinks provided by Ubiquity are opened with gedit

Bug #1945658 reported by Akbarkhon Variskhanov
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Olivier Tilloy

Bug Description

Reproducible only during Live session. See comment #2.

Ubuntu Impish daily-live 20210930
ubiquity 21.10.6
xdg-utils 1.1.3-2ubuntu2

Commit 33e306c9d77c6688e02d0cbae9a1d86f404272d3 to ubiquity changed sensible-browser to xdg-open to open hyperlinks.

As a result, all hyperlinks are opened with gedit.

Per comment #4 by mymedia:
— This happens because of sanitized environment in the ubiquity.desktop file.

Starting up ubiquity through shell with $XDG_DATA_DIRS included fixes it.

Related branches

Changed in xdg-utils (Ubuntu):
status: New → Confirmed
Revision history for this message
Akbarkhon Variskhanov (kbar) wrote (last edit ):

journalctl entry. Nothing too fancy, just confirming that it is indeed opened with gedit.

Launchpad won't let me add another attachment but here is the strace output: https://pastebin.ubuntu.com/p/JVFybhDvhb/

tags: added: ubiquity xdg-open xdg-utils
description: updated
description: updated
Revision history for this message
Julian Andres Klode (juliank) wrote :

Reproduced with 20210930 image - Boot live session, start ubiquity, click on release notes link.

Changed in xdg-utils (Ubuntu):
status: Confirmed → Triaged
tags: added: rls-ii-incoming
description: updated
summary: - The link to the release notes is opened with gedit
+ Link to release notes on Ubiquity language plugin page is opened with
+ gedit
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote : Re: Link to release notes on Ubiquity language plugin page is opened with gedit

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1945658

tags: added: iso-testing
description: updated
description: updated
description: updated
description: updated
Revision history for this message
Nicholas Guriev (mymedia) wrote (last edit ):

This happens because of sanitized environment in the ubiquity.desktop file.

ubuntu@ubuntu:~$ grep ^Exec= /usr/share/applications/ubiquity.desktop
Exec=sudo --preserve-env=DBUS_SESSION_BUS_ADDRESS,XDG_RUNTIME_DIR sh -c 'ubiquity gtk_ui'

Please add the $XDG_DATA_DIRS environment variable into the whitelist to fix the issue. You can find among autotests a complete list of environment variables that may affect xdg-utils.

https://git.launchpad.net/ubuntu/+source/xdg-utils/tree/autotests/test-lib.sh?id=b866789ac7e7ae8d62dbc52256ba758df0db17f7#n203

affects: xdg-utils (Ubuntu) → ubiquity (Ubuntu)
Revision history for this message
Akbarkhon Variskhanov (kbar) wrote (last edit ):

Nice find! That is indeed the case.

Running ubiquity through shell with $XDG_DATA_DIRS included fixes it.

I reckon these are the files to be modified:

/ubiquity/gsettings.py
/data/ubiquity.desktop.in

summary: - Link to release notes on Ubiquity language plugin page is opened with
- gedit
+ All hyperlinks provided by Ubiquity are opened with gedit
description: updated
Revision history for this message
Olivier Tilloy (osomon) wrote :

Very nice catch Nicholas! I can confirm that modifying the ubiquity desktop file in a live session to add XDG_DATA_DIRS to the list of preserved environment variables fixes the bug indeed.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon)
Changed in ubiquity (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Akbarkhon Variskhanov (kbar) wrote :

Awesome! Great work!

Olivier Tilloy (osomon)
Changed in ubiquity (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 21.10.8

---------------
ubiquity (21.10.8) impish; urgency=medium

  * Updated translations.

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 05 Oct 2021 18:39:30 +0200

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Olivier Tilloy (osomon) wrote :

The latest daily ISO as of today (2021-10-07) appears to still have ubiquity 21.10.6, but if I launch a live session and upgrade ubiquity to 21.10.8, then I can confirm that the problem is fixed.

Revision history for this message
Akbarkhon Variskhanov (kbar) wrote (last edit ):

It's not fixed on my side, though `apt-cache policy` shows that 21.10.8 is available and was successfully installed.

Is running `apt install ubiquity` enough?

Thanks!

Revision history for this message
Olivier Tilloy (osomon) wrote :

I forgot to mention, in a live session the desktop file on the desktop isn't a symlink to the one installed by ubiquity, so it also needs manual editing to replicate the changes to the Exec line.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

I'll respin the desktop images, the amd64 one seemed to have failed to build. We should have a new one soon.

Revision history for this message
Olivier Tilloy (osomon) wrote :

Verified fixed in the 20211008.1 daily live ISO.

Revision history for this message
Akbarkhon Variskhanov (kbar) wrote :

I can also confirm that the bug is fixed in Ubuntu Desktop amd64 20211008.1 daily build.

Just in case. :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers