link for opening release notes no longer works

Bug #1945015 reported by Brian Murray
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Fix Released
High
Olivier Tilloy

Bug Description

With the removal of the Firefox deb from the Ubuntu Desktop image the link to open the release notes of Ubuntu no longer works.

ProblemType: Bug
DistroRelease: Ubuntu 21.10
Package: ubiquity 21.10.5
ProcVersionSignature: Ubuntu 5.13.0-16.16-generic 5.13.13
Uname: Linux 5.13.0-16-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu69
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.465
CurrentDesktop: ubuntu:GNOME
Date: Fri Sep 24 19:39:51 2021
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed maybe-ubiquity quiet splash ---
LiveMediaBuild: Ubuntu 21.10 "Impish Indri" - Beta amd64 (20210924)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Brian Murray (brian-murray) wrote :
Revision history for this message
Brian Murray (brian-murray) wrote :

In ubiquity/misc.py launch_uri() calls 'sensible-browser', manually running 'sensible-browser http://www.ubuntu.com' produced the following error message:

Couldn't find a suitable web browser!
Set the BROWSER environment variable to your desired browser.

Revision history for this message
Brian Murray (brian-murray) wrote :

The error is a red herring though as sensible-browser calls /usr/bin/gnome-www-browser which is a symlink to /etc/alternatives/gnome-www-browser which then was a symlink to /usr/bin/firefox before the firefox deb was removed. Now there is no /etc/alternatives/gnome-www-browser.

tags: added: rls-ii-incoming
Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-21.10
Revision history for this message
Olivier Tilloy (osomon) wrote :

That's essentially the same problem as bug #1870640: snaps do not have a way to integrate with the update-alternatives system (this was discussed in https://forum.snapcraft.io/t/how-to-make-snap-eligible-for-update-alternatives/21654 without a solution).

The way this was addressed for chromium is a transitional deb package that installs the snap, and that has postinst scripts to register the snap as a valid x-www-browser and gnome-www-browser alternative with the host system.

Revision history for this message
Sebastien Bacher (seb128) wrote :

We discussed it a bit, since we not going to turn the firefox deb into a transitional package this cycle we need to address this in some other way. The issue isn't specific to ubiquity and is going to impact anything trying to use the alternative. One way would be to create an empty deb with maintainer scripts to register the alternative and install that deb by default.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

Olivier suggested we could also make the installer and upgrader register the alternative

Revision history for this message
Olivier Tilloy (osomon) wrote :

There's one additional problem: registering /snap/bin/firefox as an alternative appears to work (at least from update-alternatives' standpoint), but invoking e.g. gnome-www-browser doesn't, because /snap/bin/firefox is a symlink to /usr/bin/snap, and so the snap command is run with whatever parameters/URIs were passed to gnome-www-browser.

    osomon@dantian:~$ update-alternatives --query gnome-www-browser
    Name: gnome-www-browser
    Link: /usr/bin/gnome-www-browser
    Status: manual
    Best: /usr/bin/google-chrome-stable
    Value: /snap/bin/firefox

    Alternative: /snap/bin/firefox
    Priority: 50

    Alternative: /usr/bin/firefox
    Priority: 40

    Alternative: /usr/bin/google-chrome-stable
    Priority: 200

    osomon@dantian:~$ gnome-www-browser http://example.org
    error: unknown command "http://example.org", see 'snap help'.

Revision history for this message
Olivier Tilloy (osomon) wrote :

Replacing the call to 'sensible-browser' by 'xdg-open' in ubiquity would probably work, because if BROWSER isn't set xdg-open falls back on a hardcoded list of well-known browser names, and that includes firefox.

Revision history for this message
Olivier Tilloy (osomon) wrote :

I just did a quick and dirty test to confirm the above: in a live installer session, I replaced the /usr/bin/sensible-browser binary by a symlink to /usr/bin/xdg-open, and clicking the "release notes" hyperlink did open the release notes in firefox, as expected.

Changed in ubiquity (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon)
Changed in ubiquity (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 21.10.6

---------------
ubiquity (21.10.6) impish; urgency=medium

  [ Didier Roche ]
  * debian/ubiquity.templates: fix formatting of error message to not
    contain markup

  [ Olivier Tilloy ]
  * ubiquity/frontend/gtk_ui.py, ubiquity/misc.py, debian/control: use
    xdg-open instead of sensible-browser to open the release notes and
    other hyperlinks consistently (LP: #1945015)

  [ Yuan-Chen Cheng ]
  * bin/ubiquity: add pre-install hookdir for oem-config mode

 -- Olivier Tilloy <email address hidden> Mon, 27 Sep 2021 15:14:25 +0200

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Olivier Tilloy (osomon) wrote :

Verified fixed in the latest daily ISO.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers