No WiFi on installed system if drivers were installed using 'Additional Drivers' in live-session before starting the installer.

Bug #1923477 reported by Sai Vinoba on 2021-04-12
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
ubiquity (Ubuntu)
Status tracked in Impish
Impish
Undecided
Unassigned

Bug Description

Release: Tested on Ubuntu MATE (UM)-20.04.2 and LinuxMint-20.1 on a MacBookPro with broadcom wireless chipset. Our user who initially reported the issue on the community forum confirmed with Ubuntu 20.10 and also mentioned they *always had issue* with any of the releases tried.

Software, version: ubiquity, version probably does not matter as user reported they always had same issue.

How to reproduce:
1. Boot up (any) Ubuntu iso image (or derivative which uses ubiquity) and login to live-session.
2. Make sure there is no internet connectivity. 'Enable WiFi' is missing from the network indicator's list. 'Ethernet Network' is not available (greyed out saying disconnected on UM).
3. Bring up 'Additional Drivers' (or Device Manager or similar), broadcom (proprietary) driver is shown, select and hit 'Apply Changes'.
4. Drivers are loaded and WiFi gets enabled (a notification is shown). We could actually connect to an AP and confirm internet works but this is not required.
5. Start installer, when the page comes up, select 'Install third-party software....' checkbox.
6. Proceed with installation and reboot system when prompted.

Expected: When we login, WiFi should be enabled/available.

Actual: WiFi is disabled. Situation is same as in when booted first into live-session before installing drivers from 'Additional Drivers'.

Following 4 tests were done using Ubuntu MATE-20.04.2. In all cases, I booted up and confirmed no internet connectivity. 'Enable WiFi' is missing from the drop-down list. 'Ethernet Network' is greyed out saying disconnected.

Test-1: Install drivers using 'Additional Drivers' in live-session, connect to WiFi, start installer, choose to install third-party packages.
Result: No WiFi connection on installed system.

Test-2: Do NOT install broadcom driver beforehand from 'Additional Drivers', start installer, choose to install third-party packages.
Result: WiFi available on installed system.

Test-3: Install drivers using 'Additional Drivers' in live-session, do NOT connect to WiFi, start installer, choose to install third-party packages, ignore suggestion to connect to WiFi within the installer.
Result: No WiFi connection on installed system.

Test-4: Choose 'Install Ubuntu MATE' on grub menu instead of 'Try Ubuntu MATE', start installer (there will be no internet as confirmed from indicator icon), tick "Install third-party software...." checkbox, proceed with installation.
Result: WiFi available on installed system.

So,
1) if wireless drivers were installed using 'Additional Drivers' in live-session *before* running the installer, the drivers will not be copied over to the installed system and hence no WiFi.
2) if we start installer and choose to install drivers with it ("Install third-party software...."), it makes sure the drivers are available on the installed system.

When broadcom driver is installed/enabled from 'Additional Drivers', it creates a 'bcmwl...' folder under `/usr/src`.
a) In cases 1 and 3, it is created in live session but fails to copy it over to installation directory (/target/usr/src).
b) In cases 2 and 4, bcmwl folder was copied over to installation directory (/target/usr/src) and hence available once booted into installed system.

Sai Vinoba (saivinob) on 2021-04-12
summary: - No WiFi on installed system although drivers were installed in live-
- session before install using 'Additional Drivers'
+ No WiFi on installed system if drivers were installed using 'Additional
+ Drivers' in live-session before starting the installer.
Sai Vinoba (saivinob) on 2021-04-12
tags: added: focal
tags: added: groovy hirsute linuxmint
Leó Kolbeinsson (leok) wrote :

@saivinob Sai Vinoba

Tested on Mac mini 7,1 (2014) with WiFi AirPort Broadcom BCM4360 1.0
Ubuntu Hirsute 21.04 daily ISO 20210412

I tested as per your Test-1 thru Test-4 (Ubuntu) and got the same results as you reported in the original report.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1923477

tags: added: iso-testing
tags: added: rls-hh-incoming
Changed in ubuntu-release-notes:
status: New → Fix Released
tags: added: fr-1327
tags: removed: rls-hh-incoming
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers