default locale when selecting english(US) and belgian timezone is incorrect

Bug #1907914 reported by Koen on 2020-12-12
26
This bug affects 15 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Gunnar Hjalmarsson

Bug Description

When installing ubuntu (20.04 and later (earlier also probably))selecting
- english (US) language
- Brussels-Belgian timezone

ubuntu selects de_BE as locale which is teh Belgian German-language locale

in Belgium about 60% are dutch-speaking (nl_BE) and 40% are french speaking (fr_BE) and less than 1% are german speaking (de_BE)--> choosing de_BE seems to be a bad default value

related ubiquity code is here : https://git.launchpad.net/ubiquity/tree/scripts/localechooser-apply

it seems when a language (en) is selected for Belgium which is not available as a locale (i.e. en-BE) the locale de_BE is chosen using this code

-- code --
  combined="$(grep ' UTF-8' /usr/share/i18n/SUPPORTED | \
   grep "${deflang}_$COUNTRY[.@ ]" | head -n1 | \
   cut -d' ' -f1)"
-- code --

de_BE is chosen as I suppose it is alphabetically before fr_BE and nl_BE

I'm not sure what the best solution is

I'd propose the following changes in order of my preference
1. add a en_BE locale (https://www.localeplanet.com/icu/en-BE/index.html) and make that default for non wa, nl, fr and de languages
2. allow user to select nl_BE or fr_BE locale when installing ubuntu (and maybe also de_BE or wa_BE which have much smaller % of people in Belgium) - may require a change of ubuntu install process - but I guess Belgium is not the only country with several languages with similar issues : Switzerland, ...
3. set default language nl for Belgium (might be politically problematic for 40% of Belgian people) but makes more sense than de

related AskUbuntu question : https://askubuntu.com/questions/1299522/belgian-formats-when-choosing-us-language-regional-language-settings-issue

Koen (koen-beek) on 2020-12-12
description: updated
Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for your report!

#1 would be a more long-term solution. For that you would need to propose en_BE to be created and convince the upstream glibc maintainers that it's needed.

https://sourceware.org/bugzilla/enter_bug.cgi?product=glibc;component=localedata

#2 would be a non-trivial change to the installer, and it would add an extra step to the installation, even if it wouldn't be useful for most users.

For now I think #3 is what's doable. I submitted a merge proposal which would do that.

Changed in ubiquity (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
importance: Undecided → Medium
status: New → In Progress
Gunnar Hjalmarsson (gunnarhj) wrote :

The proposal was approved and merged:

https://git.launchpad.net/ubiquity/commit/?id=6423d4b8

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 21.04.4

---------------
ubiquity (21.04.4) hirsute; urgency=medium

  [ Jean-Baptiste Lallement ]
  * Moved from deprecated sip4 to sip from PyQt5 (LP: #1903378) Thanks Rik
    Mills for the references.
  * Replaced deprecated module imp by importlib (LP: #1898494)

  [ Shih-Yuan Lee (FourDollars) ]
  * set() has a random order when looping it that makes the failure of
    dependencies issue random. Sort the list of package to make it predictable
    and easier to diagnose dependency issues.

  [ Łukasz 'sil2100' Zemczak ]
  * Provide some minimal user feedback on the UI when ubuntu-drivers is busy
    while running in the background. (LP: #1824905)

  [ Gunnar Hjalmarsson ]
  * d-i/patches/localechooser-post-base-installer.patch:
    - Set nl (Dutch) as the default Belgian language (LP: #1907914)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Fri, 08 Jan 2021 18:13:07 +0000

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

I have played with the latest daily build in a VM, pretending to install from Brussels, and confirmed that the change is effective in accordance with the intentions.

So when installing in English, the nl_BE.UTF-8 locale is now set for regional formats, while when installing in French the formats locale is still set to fr_BE.UTF-8.

Amedee Van Gasse (amedee) wrote :

This bug is a duplicate of a bug first reported way back in 2014: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1295627

Amedee Van Gasse (amedee) wrote :

Setting Dutch as the default language is politically sensitive for 40% of Belgian people.

How is this problem solved in other countries with multiple languages, for example Switzerland?

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2021-03-19 19:37, Amedee Van Gasse wrote:
> This bug is a duplicate of a bug first reported way back in 2014:

That's formally correct. But since this bug was submitted, I had forgotten about the other bug, and a fix referring to this one was implemented, I marked it the other way around. Doesn't matter in practice - you are here now, right? :)

On 2021-03-19 19:42, Amedee Van Gasse wrote:
> How is this problem solved in other countries with multiple
> languages, for example Switzerland?

Switzerland seems to have the same situation:

$ grep _CH /usr/share/i18n/SUPPORTED | grep 'UTF-8'
de_CH.UTF-8 UTF-8
fr_CH.UTF-8 UTF-8
it_CH.UTF-8 UTF-8
wae_CH UTF-8

I.e. the installer picks de_CH.UTF-8 if the user selects English as language. But since German is spoken by the majority in Switzerland, it's a sensible default and there is no problem to solve. Besides the "political" one then, but users in countries like Belgium and Switzerland have to live with that. The installer does not have a mechanism for setting the formats locale explicitly, and it can easily be tweaked afterwards in Settings.

Gunnar Hjalmarsson (gunnarhj) wrote :

I'd like to add that the issue was mentioned in a discourse topic about planned changes to the desktop installer.

https://discourse.ubuntu.com/t/refreshing-the-ubuntu-desktop-installer/20659/32

Anyone who wants to see changes to the installer is encouraged to get involved in that project, for instance by commenting in that topic.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1907914

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers