Ubiquity not selecting correct timezone when connected to Internet

Bug #1903312 reported by Leó Kolbeinsson
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
geoip-database (Ubuntu)
Undecided
Unassigned
Hirsute
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned
Hirsute
Undecided
Unassigned

Bug Description

Installing Xubuntu 21.04 daily 20201106 ISO

1. Connected to Internet via WiFi connection
2. Boot Hirsute Xubuntu and run the installer
3. Advance to the time zone selector

The correct time zone in my instance should be Reykjavik,Iceland

However the result is New York

This is most likely a duplicate of bug 1898501 - which was filed against Calamares
see: https://bugs.launchpad.net/ubuntu/+source/calamares/+bug/1898501

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: ubiquity 20.10.13
ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
Uname: Linux 5.8.0-25-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu51
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.455
CurrentDesktop: XFCE
Date: Fri Nov 6 14:40:36 2020
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/xubuntu.seed maybe-ubiquity quiet splash ---
LiveMediaBuild: Xubuntu 21.04 "Hirsute Hippo" - Alpha amd64 (20201106)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RebootRequiredPkgs:
 linux-image-5.8.0-25-generic
 linux-base
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu62
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.461
CurrentDesktop: XFCE
DistroRelease: Ubuntu 21.04
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/xubuntu.seed maybe-ubiquity quiet splash ---
LiveMediaBuild: Xubuntu 21.04 "Hirsute Hippo" - Beta amd64 (20210409)
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
Package: ubiquity
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 5.11.0-13.14-generic 5.11.7
RebootRequiredPkgs:
 linux-image-5.11.0-13-generic
 linux-base
Tags: hirsute ubiquity-21.04.14 xubuntu
Uname: Linux 5.11.0-13-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
_MarkForUpload: True

Revision history for this message
Leó Kolbeinsson (leok) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1903312

tags: added: iso-testing
Revision history for this message
Leó Kolbeinsson (leok) wrote :

Tested Xubuntu Hirsute daily http://cdimage.ubuntu.com/xubuntu/daily-live/20201122/hirsute-desktop-amd64.iso

This bug still occurring when connected to Internet - tested both WiFi and Ethernet connections
Machines used were:
1. Acer [Aspire] E3-111-P60S running in UEFI + secure boot - tested with WiFi and Ethernet connections
2. Lenovo V14 IIL i3-1005G1 running in UEFI+ secure boot - tested with WiFi connection

Also ran a 3rd test in VirtualBox (machine used InWin BL641 i5-10400 ) and the installer selected the correct location.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Tested Xubuntu Hirsute daily http://cdimage.ubuntu.com/xubuntu/daily-live/20201123/hirsute-desktop-amd64.iso

Acer [Aspire] E3-111-P60S (Pent.N3530, 4GB, Intel HD Graphics, Realtek RTL8111/81681/8411 GB Ethernet, Qualcomm Atheros AR9462 Wireless, Bluetooth Atheros A315-53, 500 GB hd)

The installer selected New York as location - Reykjavik is the correct location

I should also mention that when installing I could not select "download updates" even though I just connected the WiFi to the Internet- the installer reported "no Internet" connection,--however when I restart the machine the WiFi connection is active and in Software & Updates the server for Iceland is selected as the download source.

Attached is the syslog from the installation media.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Further to my comment number 4

I also tested the following machine with an ethernet connection:

Lenovo X230i i3-3120M,4GB,Intel HD graphics,WiFi,Ethernet,Bluetooth,320GB hd
Testcase:UEFI+secure boot,no encryption,full disk,Internet with ethernet connection

Again the installer selected New York as the location but allowed me to download updates during the install (which I declined to do) - on reboot Iceland server was also the download server in Software & Updates

Attached is the syslog

Revision history for this message
Bernard Stafford (bernard010) wrote :

Kubuntu 21.04 QA Testing Build 01-18-2021 Did not select correct pre-selected time zone with internet during install. Adding this bug report to my QA Test results.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Kubuntu 21.04 QA Testing build 01-20-21 -

InWin BL641 i5-10400 running in VirtualBox

At install the preselected timezone was correct but the city is shown as Atingua and Barbuda - Reykjavik is correct location.
After reboot I checked the regional settings (formats and timezone) and all were correctly set to Iceland.

See attached screenshot

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
Sai Vinoba (saivinob) wrote :

Haven't seen this issue in recent daily-builds (Ubuntu MATE, Xubuntu). Currently on 20210227.

Revision history for this message
Sai Vinoba (saivinob) wrote :

Testing daily-builds since atleast 20210225. Testing both Ubuntu MATE and Xubuntu. Haven't seen the bug.

Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Leó Kolbeinsson (leok) wrote :

Testing daily build Xubuntu Hirsute 20210308

Test machine : Lenovo L450 i5-5200U,8GB,Intel HD5500,WiFi/Ethernet,Bluetooth,500GB hd

I am still receiving this bug - please note that this only occurs when using WiFi connection - ethernet connection to the Internet - all normal

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Testing daily build Ubuntu Hirsute 20210308

Test machine: Lenovo T430i i3-3110M,8GB,Intel HD graphics 4000,WiFi,Ethernet,Bluetooth, 500GB hd

Received this bug using WiFi connection to the Internet.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Correction to my comment # 12 -

It should read : Testing daily build Ubuntu MATE Hirsute 20210308 - MATE not Ubuntu

Sorry for any confusion.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Received on todays daily ISO for Xubuntu Hirsute

Testing Xubuntu Hirsute daily 20210311 - Lenovo V14 IIL i3-1005G1 with WiFi connection -

This is not occuring on Ethernet connections.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Further to comment number 14 -

I am attaching the session log file.

Changed in ubiquity (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in geoip-database (Ubuntu):
status: New → Confirmed
Revision history for this message
Bernard Stafford (bernard010) wrote :

Ubiquity during install of Kubuntu 21.04 QA Testing did not present the correct time zone. It displayed the wrong country. Internet was working. Daily build 20210319

Revision history for this message
Brian Murray (brian-murray) wrote :

When using an Ubuntu build what location does the following url say you are at?

https://geoip.ubuntu.com/lookup

@Bernard - were you connected via Ethernet or WiFi?

Revision history for this message
Leó Kolbeinsson (leok) wrote :

@brian-murray

re yr comment #18 - when testing https://geoip.ubuntu.com/lookup

I receive Atlantic/Reykjavik which is correct -

However when testing Kubuntu 21.04 QA build 2021-03-21

InWin BL641 i5-10400 running in VirtualBox (ethernet connection)

The results are the same as in comment #7 -

At install the preselected timezone was correct but the city is shown as Atingua and Barbuda - Reykjavik is the correct location.
After reboot I checked the regional settings (formats and timezone) and all were correctly set to Iceland.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Tested Ubuntu Mate Hirsute daily build 2021-03-26 and the installer selected New York as location. This was run on Lenovo X230i with WiFi connection.

Also ran another test in VirtualBox on another machine with ethernet connection and no error occurred.

tags: added: rls-hh-incoming
Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-21.04
tags: removed: rls-hh-incoming
tags: added: fr-1262
Revision history for this message
Brian Murray (brian-murray) wrote :

I tested this using an Ubuntu 21.04 daily image (20210405) in kvm with a fake WiFi connection setup per (https://wiki.ubuntu.com/Ubiquity/Testing#Testing_WiFi_in_VM) and my timezone was not correctly identified. That being said the IP address being looked up was the address associated with my VPN connection. Once I brought that network connection down the location look up worked fine.

Attached is a screenshot of the bad lookup.

Revision history for this message
Brian Murray (brian-murray) wrote :

I then tested this using a Xubuntu 21.04 daily image (20210405) in kvm with a fake WiFi connection setup and the location look up worked correctly.

Attached is a screenshot of the good lookup.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

New York I think is a default fallback when there is no internet connectivity.

Is internet connected properly?

Revision history for this message
Leó Kolbeinsson (leok) wrote :

@xnox

Yes the internet is connected properly - this only occurs when using WiFi connect and only with ubiquity. Will do further tests with the next daily ISO.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

@xnox

Re: comments 23 and 24 -

I just ran a quick install using the Xubuntu Hirsute daily iso 20210408 on the same test machine as the original bug report i.e. Lenovo V14 IIL and everything worked fine.

The test I ran earlier today was the same ISO but on an old MacMini with a USB network adapter.
Assume this is no longer a problem.

Revision history for this message
Leó Kolbeinsson (leok) wrote : Casper.txt

apport information

tags: added: apport-collected ubiquity-21.04.14
description: updated
Revision history for this message
Leó Kolbeinsson (leok) wrote : Dependencies.txt

apport information

Revision history for this message
Leó Kolbeinsson (leok) wrote : ProcCpuinfoMinimal.txt

apport information

Revision history for this message
Leó Kolbeinsson (leok) wrote : UbiquityDebug.txt

apport information

Revision history for this message
Leó Kolbeinsson (leok) wrote : UbiquityDm.txt

apport information

Revision history for this message
Leó Kolbeinsson (leok) wrote : UbiquityPartman.txt

apport information

Revision history for this message
Leó Kolbeinsson (leok) wrote : UbiquitySyslog.txt

apport information

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Tested again - this time with Lenovo x230i.

I selected after boot "Try Xubuntu" and entered the desktop and connected the WiFi network with no problems - then I ran the Install and again ubiquity selected New York as location even though the network was connected.

After the install I ran apport-collect as evident in comments #26 to #32.

Revision history for this message
Martin Wimpress  (flexiondotorg) wrote :

I can not reproduce this in Ubuntu MATE 21.04 (20210420)

Revision history for this message
Leó Kolbeinsson (leok) wrote :

@flexiondotorg Martin Wimpress

re#34

I will test this on another machine and report back.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Installed on 2 machines Ubuntu Mate Hirsute ISC 20210420

1. Lenovo V14 IIL i3-1005G1,20GB,Intel UHD Graphics,WiFi Realtek 802.11ac

2. Lenovo L450 i5-5200U,8GB,Intel HD5500,WiFi

in both case connected to WiFi network and ubiquity selects New York as location -
also ran test in VirtualBox with ethernet connection and no error occurred.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Further comment -

I think in order to reproduce this bug - it has to be tested on bare metal machine with WiFi connection - I have never received this using ethernet and/or virtual machines (bothe QEMU and VirtualBox).

Hope this helps.

Revision history for this message
Brian Murray (brian-murray) wrote :

@leok - Do you have another location and WiFi network where you can test this? It'd be interesting to know if it happens there. Thanks!

Revision history for this message
Leó Kolbeinsson (leok) wrote :

@brian-murray

Re comment #38 - No I do not have another location and/or WiFi net work available at the moment -

I will check more on this in the A.M. 11-05.2021 - I also notice difficulties with Impish ISO's
connecting to WiFi - todays builds Xubuntu and Kubuntu - have not the time this evening as it is late here.

Will post further after my tests.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

@brian-murray

I ran tests on the daily 11-05-2021 ISO's for Xubuntu,Kubuntu,Ubuntu Mate and Ubuntu on 2 test machines -

1. Dell [ Optiplex] MT 7040 ( i7-6700,32 GB, Intel HD Graphics 530,Intel i219-LM GB Ethernet, M.2 256GB SATA SSD) with TP-Link TL-WN823N USB WiFi adapter (Ethernet unplugged)

2. Lenovo V14 IIL i3-1005G1,20GB,Intel UHD Graphics,WiFi Realtek 802.11ac, bluetooth 4.2, 256GB M2NVMe SS

In all tests the WiFi connection in test machine #1 (Dell) successfully reported correct location
However on test machine # 2 (Lenovo) only Ubuntu successfully reported location (Reykjavik) the others all showed New York

Importantly I also noticed that when advancing to "Updates and other software" on the Lenovo machine all testcases with the exception of Ubuntu failed to select the option "Download updates while installing Ubuntu" -

It appears to me this is maybe a driver issue - I will attach as an example the syslog from Kubuntu iso 11-05-2021 for the Lenovo install and in a seperate comment the Ubuntu syslog same dates for comparison -

Revision history for this message
Leó Kolbeinsson (leok) wrote :
Revision history for this message
Leó Kolbeinsson (leok) wrote :
Revision history for this message
Leó Kolbeinsson (leok) wrote :

Re: my comment # 40

This should read --- I ran tests on the Impish daily 11-05-2021 ISO's for Xubuntu,Kubuntu,Ubuntu Mate and Ubuntu on 2 test machines -

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Tested Kubuntu Impish daily ISO 2021-12-05

Machine tested - Lenovo V14 IIL i3-1005G1

This time I booted and selected "Try Kubuntu" connected the WiFi and ran the install by selecting "Install Kubuntu" on the desktop.No errors encountered.

Second test same machine but selecting "Install Kubuntu" after boot - install failed to select correct location (New York selected).

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Tested Kubuntu Impish Daily ISO 2021-14-05 and can confirm that connecting to WiFi network and location selection (Reykjavik) was successful with no errors. Also note that upon reboot the machine reconnected to the WiFi network.

Machine tested - Lenovo V14 IIL i3-1005G1

Will also test the other flavors re comment # 40 soonest -

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Tested Xubuntu Impish Daily ISO 2021-16-05 and same results as in comment # 45

Confirm that connecting to WiFi network and location selection (Reykjavik) was successful with no errors. Also note that upon reboot the machine reconnected to the WiFi network.

Machine tested - Lenovo V14 IIL i3-1005G1

Revision history for this message
Brian Murray (brian-murray) wrote :

I've tested an Ubuntu Impish daily image from 2021-06-21 and booted it in KVM with no network adapter e.g.:

kvm -m 4096 -boot d -nic none -cdrom /srv/new-vms/isos/ubuntu/impish-desktop-amd64.iso -hda /srv/vms/impish.qcow2

Even though I had no network adapter and connection the 'Where are you?' map showed my location as New York. So given that and the testing that you have done it seems to me that you were seeing New York as the location because the system being tested, Lenovo V14 IIL, did not have the drivers installed for its wireless network adapter. Have I missed anything from your testing?

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Leó Kolbeinsson (leok) wrote (last edit ):

@brian-murray

You have not missed anything from my testing.
However please note - This has only been a problem with my Lenovo box and not a problem with Ubuntu.
The most recent occurence was with Xubuntu Impish daily iso - 20210613.

I agree it seems to be related to the driver not being installed for the WiFi adapter.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

@brian-murray

Ran a test with Xubuntu Impish daily 20210615 (latest available on QA testing site)and the bug still exists.However the drivers are installed - and upon reboot the the WiFi network connection is active.

Revision history for this message
Leó Kolbeinsson (leok) wrote :

@brian-murray

Further tests - this time with Kubuntu Impish daily ISO http://cdimage.ubuntu.com/kubuntu/daily-live/20210623/impish-desktop-amd64.iso

ran 3 tests with ethernet connections:

http://iso.qa.ubuntu.com/qatracker/milestones/424/builds/232474/testcases/1300/results

1. Dell [ Optiplex] MT 7040 bare metal - selected New York incorrectly as location
2. Dell [ Optiplex] MT 7060 bare metal - selected New York incorrectly as location
3. InWin BL641 -run in VirtualBox - correctly selected Reykjavik as location

Again note - the connections were with ethernet not WiFi

Revision history for this message
Leó Kolbeinsson (leok) wrote :

Further tests:

Kubuntu Impish daily ISO http://cdimage.ubuntu.com/kubuntu/daily-live/20210628/impish-desktop-amd64.iso

1. Dell [ Optiplex] MT 7060 bare metal - selected Reykjavik correctly as location

2. InWin BL641 -run in VirtualBox - correctly selected Reykjavik as location

Revision history for this message
Brian Murray (brian-murray) wrote :

Given that nothing significant has changed with ubiquity in the past couple of days and you've had different results on the same hardware I'm suspecting this is either a race condition or something with your network. Have you seen any other bug reports about ubiquity where people are experiencing the same issue as you?

Changed in ubiquity (Ubuntu Hirsute):
status: Confirmed → Won't Fix
Revision history for this message
Leó Kolbeinsson (leok) wrote (last edit ):

@brian-murray

No I have not seen any other bug reports on this - also note this does not occur in Ubuntu - only Xubuntu and Kubuntu.Also never occurs in Virtual Box or QEMU.

I will test the next dailies in the morning and report again.

Revision history for this message
Leó Kolbeinsson (leok) wrote (last edit ):

@brian-murray

re: your comment # 52 - I agree this must have been a race condition -

Tested 4 machines today with Kubuntu Impish 01072021 and was unable to reproduce the bug.

Here is a link to my test results on the QA site:

http://iso.qa.ubuntu.com/qatracker/milestones/424/builds/232851/testcases/1300/results

As no others have reported/confirmed this I would think this should be closed.

Thanks for the help.

Revision history for this message
Brian Murray (brian-murray) wrote :

Thanks for all of your testing, I've gone ahead and set this to Invalid although that's not a great status for this.

Changed in geoip-database (Ubuntu):
status: Confirmed → Invalid
Changed in geoip-database (Ubuntu Hirsute):
status: Confirmed → Invalid
Changed in ubiquity (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers