prepare plugin does not run in automatic mode

Bug #1895351 reported by Mauricio Faria de Oliveira
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Mauricio Faria de Oliveira
Focal
Undecided
Mauricio Faria de Oliveira
Groovy
Undecided
Unassigned
Hirsute
Medium
Mauricio Faria de Oliveira

Bug Description

[Impact]

 * Currently ubiquity's prepare plugin, which installs the
   3rd party drivers, is not run at all in automatic mode.

 * This prevents automatic installation of such drivers
   (e.g., nvidia drivers) which are shipped / available
   in the ISOs now; and thus could actually be installed.

 * That causes additional network bandwidth consumption
   or additional steps to install them in offline cases.

[Fix]

 * The MR allows the prepare plugin to run in automatic
   mode unconditionally in Hirsute and later, and Focal
   gets the 'ubiquity/prepare_automatic' preseed option
   to enable it (so not to change the default behavior.)

 * Now users can use the existing 'ubiquity/use_nonfree'
   preseed option to install 3rd party drivers while in
   automatic mode (i.e., with the 'automatic-ubiquity'
   option, or running 'ubiquity --automatic'.)

[Test Case]

 * Boot the live installer with the 'automatic-ubiquity'
   option, or run 'ubiquity --automatic' in the shell.

 * Check whether the 'Updates and other software' page
   is listed or not.
   - Before: it is not.
   - After:
     - Hirsute: it is.
     - Focal: according to 'ubiquity/prepare_automatic'.

 * The page can be automatically configured via preseed
   options, and be skipped with the key preseed option
   'ubiquity/use_nonfree'.

 * Then 3rd party drivers should be installer or not
   according to the option value and system hardware.

[Where problems could occur]

 * Automatic installations that didn't configure the
   'ubiquity/use_nonfree' option configured will now
   block in the 'Updates and other software' page,
   waiting for input (in Hirsute and later) and thus
   need to have their preseed file/options updated.

 * In Focal that behavior doesn't change by default,
   and the users have to opt-in with the new option
   'ubiquity/prepare_automatic', so they are already
   updating the preseed file/options.

 * If there are any existing problems in the prepare
   plugin, they may now be exposed in automatic mode.
   However, since it runs by default in manual Desktop
   installs it's not expected to have any known issues.

 * If issues happen with the option enabled in Focal,
   users can opt-out with the new preseed option; and
   in Groovy (where it's not available), bug reports
   on it before release may be reported and addressed.

[Other Info]

 * Hirsute and Focal are patched; Groovy is not because
   there are no more Desktop ISO spins planned (standard
   release) thus this patch is not effectively used on G.

[Original Description]

Currently the prepare plugin is just not run at all in automatic mode.

But some users could benefit from it now that the ISOs ship with
e.g., nvidia drivers, to install 3rd party drivers automatically
during install, and not consume network bandwidth to download it.

The MR introduces the 'ubiquity/prepare_automatic' preseed option
to allow the prepare plugin to run in automatic mode (i.e. with
the 'automatic-ubiquity' option / ubiquity --automatic)

Related branches

Changed in ubiquity (Ubuntu):
assignee: nobody → Mauricio Faria de Oliveira (mfo)
importance: Undecided → Low
status: New → Confirmed
tags: added: sts
Changed in ubiquity (Ubuntu):
importance: Low → Medium
Changed in ubiquity (Ubuntu):
status: Confirmed → In Progress
description: updated
Changed in ubiquity (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Mauricio Faria de Oliveira (mfo) wrote :

Added Groovy as Won't Fix, since there are no more installer spins.

Added Focal as In Progress, the backport MR has been submitted [1].

[1] https://code.launchpad.net/~mfo/ubiquity/+git/ubiquity/+merge/396500

Changed in ubiquity (Ubuntu Groovy):
status: New → Won't Fix
Changed in ubiquity (Ubuntu Focal):
status: New → In Progress
assignee: nobody → Mauricio Faria de Oliveira (mfo)
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

@mfo, merged in focal. Can you document the bug report for the SRU?

Revision history for this message
Mauricio Faria de Oliveira (mfo) wrote :

@jibel done! sorry, I missed adding it earlier.

description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 21.04.6

---------------
ubiquity (21.04.6) hirsute; urgency=medium

  * Revert "BD on iproute2" There's a mock 'ip' command which is supposed to
    be used actually.
  * Append _fn to netcfg mock_path name. This is actually why the mock 'ip'
    command wasn't being found. The check library now generates the testcase
    with `_fn` appended, so we need to rename our directory to follow suit.

 -- Iain Lane <email address hidden> Mon, 25 Jan 2021 19:02:50 +0000

Changed in ubiquity (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Mauricio, or anyone else affected,

Accepted ubiquity into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubiquity/20.04.15.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubiquity (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

I did the verification of 20.04.15.5 in focal with the following tests:

- nothing seeded and automatic option not set:
  => the installer runs as usual
- prepare_automatic set, use_nonfree not set or use_nonfree set and seen flag set to false, automatic flag set:
  => prepare step is displayed.
- prepare_automatic set, use_nonfree set and seen flag set to true, automatic option set:
  => prepare step is not displayed.
- prepare_automatic not set, use_nonfree set and seen, automatic option set:
  => prepare step is displayed.

Marking as verification done.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 20.04.15.5

---------------
ubiquity (20.04.15.5) focal; urgency=medium

  [ Mauricio Faria de Oliveira ]
  * Add preseed option 'ubiquity/prepare_automatic' (default: false) to
    include the prepare page in automatic mode. (LP: #1895351)
    - debian/ubiquity.templates: add ubiquity/prepare_automatic.
    - ubiquity/plugins/ubi-prepare.py: do not bail if it's true.

  [ Shih-Yuan Lee (FourDollars) ]
  * install_misc.py: Use another mechanism to install the packages. (LP:
    #1908023)

 -- Iain Lane <email address hidden> Mon, 25 Jan 2021 18:28:35 +0000

Changed in ubiquity (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for ubiquity has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers