US keyboard layout even if a non english language is selected in ubiquity-dm

Bug #1892040 reported by Jean-Baptiste Lallement on 2020-08-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Dimitri John Ledkov
Focal
Critical
Łukasz Zemczak
Groovy
Critical
Dimitri John Ledkov

Bug Description

[Impact]

Last known good version: 20.04
This regression appeared in 20.04.1 and 20.10. We have fixed it for groovy on release week and it's time to backport the fix for 20.04.2. Without the fix users using the installer live session won't have correct keyboard layout, per the default for a given language.

[Test Case]

1. Boot to ubiquity-dm
2. In the list of languages select 'French'
3. Boot to the live session

= Expected result =
 * Verify that there is a keyboard indicator in the indicator area and that 'fr' is displayed
 * Open a terminal, press the 'a' key and verify that 'a' is displayed in the terminal.

= Actual result =
There is no keyboard indicator.
The keyboard layout is 'US' instead of FR.

[Where problems could occur]

It's hard to say. Since this SRU is modifying gsettings keys, I think any regressions might most likely be happening in relation of that. But sadly I can't think of any obvious scenario that could be broken.

[Original Description]

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: ubiquity 20.04.15.2
ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
Uname: Linux 5.4.0-42-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu27.4
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.445.1
CurrentDesktop: ubuntu:GNOME
Date: Tue Aug 18 13:17:24 2020
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed initrd=/casper/initrd quiet splash --- maybe-ubiquity
LiveMediaBuild: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
tags: added: regression-update
tags: removed: rls-ff-incoming rls-gg-incoming
Steve Langasek (vorlon) on 2020-08-27
Changed in ubiquity (Ubuntu Focal):
importance: Undecided → Critical
Changed in ubiquity (Ubuntu Groovy):
importance: Undecided → Critical
tags: added: id-5f3e94a7b2197760f0c36649
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu Focal):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
Alex (errantscientist) wrote :

Due to the bug #1871268 had to use a daily installer (downloaded yesterday, so might be the previous version already (07.10.2020). Choosing russian language during installation (btw suggested by default after choosing russian language at the beginning of the installation) didn't make the "en>" icon to appear at the top panel of Gnome and, obviously, didn't allow me to type in russian letters in the check box. Though it did work just fine with the usual installer from Ubuntu's main webpage, but, again, I used the daily installer to avoid a crash during installation.
After the installation was complete, I had both layouts added, working fine, just as I selected during the installation process. So, I had the ability to change the name (not the "username") of the user, since, initially, I wanted to type it in in russian letters, but couldn't do it during the installation process since any other keyboard layouts (I've clicked through a couple) didn't work.

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1892040

tags: added: iso-testing
Changed in ubiquity (Ubuntu Groovy):
milestone: none → ubuntu-20.10
assignee: nobody → Łukasz Zemczak (sil2100)
tags: added: fr-207
Changed in ubiquity (Ubuntu Groovy):
status: Confirmed → In Progress
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

It works as expected on Xubuntu Desktop 20201019.1 which doesn't use gnome-shell.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 20.10.13

---------------
ubiquity (20.10.13) groovy; urgency=medium

  * misc.py: unset gsd keys to trigger keyboard settings migration.
    (LP: #1892040)

 -- Dimitri John Ledkov <email address hidden> Mon, 19 Oct 2020 18:29:34 +0100

Changed in ubiquity (Ubuntu Groovy):
status: In Progress → Fix Released
Iain Lane (laney) on 2020-10-20
Changed in ubiquity (Ubuntu Groovy):
assignee: Łukasz Zemczak (sil2100) → Dimitri John Ledkov (xnox)
Iain Lane (laney) on 2020-11-16
Changed in ubiquity (Ubuntu Focal):
assignee: nobody → Łukasz Zemczak (sil2100)
Revision history for this message
Marcin Wisniewsk (maly83) wrote :

Automat

Changed in ubiquity (Ubuntu Focal):
milestone: none → ubuntu-20.04.2
Changed in ubiquity (Ubuntu Focal):
status: Confirmed → In Progress
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Uploaded to the focal Unapproved queue. Before proceeding I have validated that the cherry-picked fix also works for 20.04.

description: updated
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Jean-Baptiste, or anyone else affected,

Accepted ubiquity into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubiquity/20.04.15.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubiquity (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Mathew Hodson (mhodson) on 2021-01-22
Changed in ubiquity (Ubuntu):
milestone: ubuntu-20.10 → none
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Downloaded and booted up ubuntu-20.04.1-desktop-amd64.iso in a kvm. After ubiquity started, I opened up the terminal, enabled focal-proposed in /etc/apt/sources.list and upgraded ubiquity (to version 20.04.15.4, there was some hackery involved as debconf database is locked). I have then selected 'Français' from the language selection and pressed the equivalent of 'Try Ubuntu'. After the live-session started, I confirmed that the language indicator displays 'fr' and the keyboard input was correct on the terminal.

Earlier, when preparing the cherry-pick backport, I have already confirmed that the bug was reproducible on that image.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for ubiquity has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 20.04.15.4

---------------
ubiquity (20.04.15.4) focal; urgency=medium

  * Backport Dimitri's misc.py change from groovy: unset gsd keys to trigger
    keyboard settings migration. (LP: #1892040)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 21 Jan 2021 15:29:03 +0100

Changed in ubiquity (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers