ubiquity confirmation window off partially offscreen

Bug #1890931 reported by Chris Guiver
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Low
Unassigned

Bug Description

Two QA-test installs of Lubuntu 18.04.5 daily. (amd64 & i386)
hp dx6120mt (mini-tower, pentium 4 dual core, 3gb, winfast clone of nvidia 7600gt)
dell [optiplex] 755 (c2d-e8300, 8gb, amd/ati radeon rv610/radeon hd2400 pro/xt)

Using the Manual Partitioning option, after making up my partitions (/ and /home) a confirmation dialog box appears on screen, however it's not fully on-screen.

(a like message also appeared during install-alongside somewhat off screen too)

--
Do you want to return to the partitioner?
The file system on /dev/sda1 assigned to / has not been marked for formatting. Directories containing file system files (/etc, /lib, /usr, /var, ...) that already exist under any defined mountpoint will be deleted during the install.
Please ensure that you backed up any critical data before installing.
--
Write the changes to disk?
If you continue, the changes below will be written to disks. Otherwise, you will be able to make furher changes...

The partition tables of the following devices are changed:
 SCSI4 (0,0,0) (sda)

The following partitions are going to be formatted
 partition #5 of SCSI4 (0,0,0) (sda) as ext4
--

On one box it was only partially visible (single monitor, left of dialog box was on screen). On one box both screens were mirrored at boot so the same two portions were visible (photo to be uploaded in later comment #5)

On this box with two displays, the right side of the dialog box was visible on the second monitor.

Minor importance though, as on three+ boxes I could grab & drag dialog box so it was fully visible

(I got the feeling the dialog box was centering on my cursor, which wasn't a good idea as the cursor was near the bottom right of the screen as that was where I last clicked NEXT)

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubiquity 18.04.14.15
ProcVersionSignature: Ubuntu 5.4.0-42.46~18.04.1-generic 5.4.44
Uname: Linux 5.4.0-42-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.16
Architecture: amd64
CasperVersion: 1.394.3
CurrentDesktop: LXDE
Date: Sun Aug 9 17:10:36 2020
InstallCmdLine: file=/cdrom/preseed/lubuntu.seed boot=casper initrd=/casper/initrd quiet splash ---
LiveMediaBuild: Lubuntu 18.04.5 LTS "Bionic Beaver" - Release amd64 (20200806.1)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Chris Guiver (guiverc) wrote :
tags: added: i386
Chris Guiver (guiverc)
description: updated
Revision history for this message
Chris Guiver (guiverc) wrote :

this `scrot` image was created on a third box; dc7700 which had the same issue...

this box has two screens. the panel on the left screen can be used to show the portion that appears offscreen when on the initial dx6120 (i386) box, though appeared on second display for both d755-8 & dc7700 (this box) due to 2nd monitor.

description: updated
Revision history for this message
Chris Guiver (guiverc) wrote :

this `scrot` image was created on a third box; dc7700 which had the same issue...

this box has two screens. the panel on the left screen can be used to show the portion that appears offscreen when on the initial dx6120 (i386) box, though appeared on second display for both d755-8 & dc7700 (this box) due to 2nd monitor.

description: updated
Chris Guiver (guiverc)
description: updated
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1890931

tags: added: iso-testing
Revision history for this message
Chris Guiver (guiverc) wrote :

Exploring an issue on a i386 box, I did an install using the i386 Lubuntu 18.04 LTS daily on an amd64 box

On the box the screens are mirrored during install, so the message appears twice (in photo the picture looks strange as displays are landscape+portrait in orientation)

The message on this box (an install-alongside qa-test)
--
Write the changes to disk?
If you continue, the changes below will be written to disks. Otherwise, you will be able to make furher changes...

The partition tables of the following devices are changed:
 SCSI4 (0,0,0) (sda)

The following partitions are going to be formatted
 partition #5 of SCSI4 (0,0,0) (sda) as ext4
--

description: updated
Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Revision history for this message
Chris Guiver (guiverc) wrote :

Repeating #5 on a different amd64 box (booting & doing a install-alongside using i386 ISO) the issue has NOT occurred.

Maybe it's

- screen resolution dependent (the window appeared to the left of my screen now); this box has 1920x1080 screens which are higher resolution than the 3:4 older style displays used on prior boxes mentioned in this report

OR

- I used "Try Lubuntu" before starting the install, instead of selecting the "Install Lubuntu" at the first selection screen, thus issue didn't occur maybe?

Either way, on this box the identical text mentioned in #5 appears in a small window on screen now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers