ubiquity crashes when "release notes" selected

Bug #1890137 reported by Leó Kolbeinsson on 2020-08-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Low
Unassigned

Bug Description

Ubiquity crashes when "release notes" selected in Step2 on live session.

Running the ISO from:
http://cdimage.ubuntu.com/kubuntu/focal/daily-live/20200731/focal-desktop-amd64.iso

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: ubiquity 20.04.15.2
ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
Uname: Linux 5.4.0-42-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.4
Architecture: amd64
CasperMD5CheckResult: skip
CasperVersion: 1.445.1
CurrentDesktop: KDE
Date: Mon Aug 3 11:21:13 2020
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/kubuntu.seed maybe-ubiquity quiet splash ---
LiveMediaBuild: Kubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Leó Kolbeinsson (leok) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1890137

tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

From syslog:

 Exception in KDE frontend (invoking crash handler):
 Traceback (most recent call last):
   File "/usr/lib/ubiquity/plugins/ubi-language.py", line 485, in on_release_notes_link
     self.openURL(url)
   File "/usr/lib/ubiquity/plugins/ubi-language.py", line 512, in openURL
     misc.regain_privileges_save()
   File "/usr/lib/ubiquity/ubiquity/misc.py", line 118, in regain_privileges_save
     assert _dropped_privileges is not None and _dropped_privileges > 0
 AssertionError

Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Łukasz Zemczak (sil2100) wrote :

Is this reproducible? Does it only happen for Kubuntu, or all flavors?

Jean-Baptiste Lallement (jibel) wrote :

I tried on kubuntu, the "release notes" link does nothing because xdg-open uses kde-open which doesn't exist (kde-open5 does) but the installer doesn't crash.

Changed in ubiquity (Ubuntu):
importance: Medium → Low
Jean-Baptiste Lallement (jibel) wrote :

I filed bug 1890173 for the "release notes link doesn't work issue" but your crash is something different.

Leó Kolbeinsson (leok) wrote :

@jibel

I´ll retest and see if I can reproduce the crash and report back.

Leó Kolbeinsson (leok) wrote :

Retested and same result.

Chris Guiver (guiverc) wrote :

Just an FYI: My last test with Kubuntu 20.04.1 was with 31-July-2020 daily ISO and the only thing I recorded was the link didn't work; it was noted in comments on iso.qa.ubuntu.com & comment made on IRC too I believe (question asking if they wanted a bug report opened; I didn't get a reply)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers