on flavours ubiquity: bootloader failed on /dev/vda

Bug #1885414 reported by Mike Glover on 2020-06-28
110
This bug affects 12 people
Affects Status Importance Assigned to Milestone
kubuntu-meta (Ubuntu)
Status tracked in Groovy
Groovy
Undecided
Unassigned
ubiquity (Ubuntu)
Status tracked in Groovy
Groovy
Critical
Unassigned
ubuntu-budgie-meta (Ubuntu)
Status tracked in Groovy
Groovy
High
fossfreedom
ubuntu-mate-meta (Ubuntu)
Status tracked in Groovy
Groovy
Undecided
Unassigned
ubuntukylin-meta (Ubuntu)
Status tracked in Groovy
Groovy
Undecided
Unassigned
xubuntu-meta (Ubuntu)
Status tracked in Groovy
Groovy
Undecided
Unassigned

Bug Description

Testing the 2020-06-28 ubuntu-mate iso on QEMU (QuickEMU)
Selected Normal and 3rd party installation.
Installation looked to be going fine until it got to grub2 installation part
Came up with the following error:

https://i.imgur.com/IanRMYk.jpg

Had to do screenshot as apport is crashing and unable to submit bug via ubuntu-bug:

https://i.imgur.com/dqYcKqb.png

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1885414

tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

This is fixed with Ubiquity 20.10.6 currently in groovy proposed and will be available when it migrates to the release pocket.

Changed in ubiquity (Ubuntu):
status: New → Fix Released
status: Fix Released → Triaged
importance: Undecided → Critical
Brian Murray (brian-murray) wrote :

The version of ubiquity purported to fix this bug has migrated out of -proposed. Could you please test this again?

Changed in ubiquity (Ubuntu):
status: Triaged → Incomplete
tags: added: rls-gg-incoming
Jean-Baptiste Lallement (jibel) wrote :

This is actually not fixed with ubiquity 20.10.7 and image 20200701.

Changed in ubiquity (Ubuntu):
status: Incomplete → Triaged
Jean-Baptiste Lallement (jibel) wrote :

Syslog from a failed installation with 20200701.

summary: - ubiquity: bootloader failed on /dev/vda, ubuntu-mate groovy 2020-06-28
+ ubiquity: bootloader failed on /dev/vda

This patch from mwhudson fixes the issue:

diff --git a/d-i/source/grub-installer/grub-installer b/d-i/source/grub-installer/grub-installer
index 2329f0e801..ac9fd37ff3 100755
--- a/d-i/source/grub-installer/grub-installer
+++ b/d-i/source/grub-installer/grub-installer
@@ -641,7 +641,7 @@ db_progress INFO grub-installer/progress/step_install
 # to grub legacy, or vice-versa
 case "$grub_package" in
     grub-pc)
- log-output -t grub-installer $chroot $ROOT dpkg -P grub-efi grub-efi-amd64-bin grub-efi-amd64 grub-efi-amd64-signed grub-efi-ia32-bin grub-efi-ia32
+ log-output -t grub-installer $chroot $ROOT dpkg -P grub-efi grub-efi-amd64 grub-efi-ia32-bin grub-efi-ia32
  ;;
     grub-efi)
  log-output -t grub-installer $chroot $ROOT dpkg -P grub-efi-amd64-signed

Mike Glover (mikeglover) wrote :

Confirm that the issue still exists with 20200701 image.

Norbert (nrbrtx) on 2020-07-02
tags: added: groovy
Changed in ubiquity (Ubuntu):
status: Triaged → In Progress
tags: added: patch
removed: rls-gg-incoming
Changed in ubiquity (Ubuntu Groovy):
milestone: none → ubuntu-20.08
Mike Glover (mikeglover) wrote :

Confirming issue still exists for image 20200704 with ubiquity 20.10.7
Will wait until 20.10.8 lands to test further.

Rik Mills (rikmills) wrote :

ubiquity (20.10.8) groovy; urgency=medium

  [ Michael Hudson-Doyle ]
  * grub-installer: do not attempt to uninstall grub-efi-amd64-bin and grub-efi-amd64-signed when legacy booted

  [ Jean-Baptiste Lallement ]
  * Add right swap device id to fstab

So should be fixed in new ISO when they spin...?

Norbert (nrbrtx) wrote :

Tested on MATE 20200707 (sha256sum = 2aca7aee24dee2566f21e6d999fb219f4029de0d70b249537b6c2f265b30b1fd ) - it is still affected while installing on MBR.
EFI is OK as it was before.

This is fixed with Ubuntu Desktop 20200707.1. Other builds will be done automatically tomorrow.

Changed in ubiquity (Ubuntu Groovy):
status: In Progress → Fix Released
Mike Glover (mikeglover) wrote :

Can confirm Ubuntu Desktop 20200707.1 did not experience the issue and installation completed.
Will test other flavours tomorrow. Thanks all :-)

Mike Glover (mikeglover) wrote :

Have tested Ubuntu MATE 20200708 image which has Ubiquity 20.10.8
The problem still exists, not fixed.
Have attached syslog

Rik Mills (rikmills) wrote :

> Have tested Ubuntu MATE 20200708 image which has Ubiquity 20.10.8
> The problem still exists, not fixed.
> Have attached syslog

Same error on Kubuntu daily 20200708 with 20.10.8

Norbert (nrbrtx) wrote :

Tested on MATE 20200708 (sha256sum = 7d2fdad36b8fcf0409aa0a484755e5fc5ef3798fd256eeebbde905a71ad474b7 ) - it is still affected while installing on MBR.
EFI is OK as it was before.

Per-Inge (per-inge-hallin) wrote :

Tested installation in VirtualBox of Ubuntu desktop amd64 version 20200707.1 in both MBR and EFI mode. Both worked OK.

Tested to install from USB in MBR mode on a computer with Nvidia GPU. Doesn't work. get an error message about /DEV/SR0 No media found

Tested on another computer in EFI mode. Doesn't work. Error message "Unable to find a medium container a live file system"

Changed in ubiquity (Ubuntu Groovy):
status: Fix Released → Triaged
summary: - ubiquity: bootloader failed on /dev/vda
+ on flavours ubiquity: bootloader failed on /dev/vda

It probably fails on flavours and not ubuntu desktop because grub-efi-amd64 is not seeded on Ubuntu.

Rik Mills (rikmills) wrote :

Kubuntu does not seed grub-efi-amd64

Bill (franksmcb) (franksmcb) wrote :

Test in QEMU in Legacy mode with 20200708 Ubuntu MATE ISO and issue still occurs.

Dimitri John Ledkov (xnox) wrote :

We have landed a fix for one of the booting/install issues in 20200709 build stamp images and higher.

If you are experiencing boot issues of install media, please try 20200709 media and please report back if it is still fails or is imporved.

Kubuntu from qtracker is still on 08

I got the 09 version from here:
http://cdimage.ubuntu.com/kubuntu/daily-live/current/
It says last updated 2020-07-09 05:48

Bug is still there. Will watch for the next point update to hit.

On Thu, Jul 9, 2020 at 1:50 PM Dimitri John Ledkov <
<email address hidden>> wrote:

> We have landed a fix for one of the booting/install issues in 20200709
> build stamp images and higher.
>
> If you are experiencing boot issues of install media, please try
> 20200709 media and please report back if it is still fails or is
> imporved.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1886085).
> https://bugs.launchpad.net/bugs/1885414
>
> Title:
> on flavours ubiquity: bootloader failed on /dev/vda
>
> Status in ubiquity package in Ubuntu:
> Triaged
> Status in ubiquity source package in Groovy:
> Triaged
>
> Bug description:
> Testing the 2020-06-28 ubuntu-mate iso on QEMU (QuickEMU)
> Selected Normal and 3rd party installation.
> Installation looked to be going fine until it got to grub2 installation
> part
> Came up with the following error:
>
> https://i.imgur.com/IanRMYk.jpg
>
> Had to do screenshot as apport is crashing and unable to submit bug
> via ubuntu-bug:
>
> https://i.imgur.com/dqYcKqb.png
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1885414/+subscriptions
>

--

*Truck driver, Linux Tech, Webmaster, and Web Admin.Volunteer Kubuntu Linux
Development Tester*

Per-Inge (per-inge-hallin) wrote :

Made an USB boot disk with mkusb and tested the Groovy Ubuntu Desktop amd64 version 20200709.

Worked with MBR/BIOS mode on a desktop computer with an AMD Bulldozer CPU and Nvidia 1660 GPU. There were however some peculiar things
- Graphical artifacts during the installation. Perhaps "Safe graphics mode" is needed.
- Had to power off after the installation to boot the computer
- At boot you get the message: BootOrder not found. Initializing default. Creating boot entry "Boot002" with label "ubuntu" for file \EFI\ubuntu\shimx64.efi

Worked as expected on a newer computer with Ryzen CPU and Radeon GPU.

Mike Glover (mikeglover) wrote :

Ubuntu Mate 20200709 iso still has the issue when trying to install with BIOS.
When installing EFI it works fine no issue.

Mike Glover (mikeglover) wrote :

Ubuntu Mate 20200710 iso failed using BIOS.
Have attached syslog

Rik Mills (rikmills) wrote :

For Kubuntu ISOs:

At least in testing in a VM, adjusting the live and ship-live seeds to make sure both include 'shim-signed' and 'grub-pc' packages, seems to have worked around the issue in legacy bios installs. i.e. in 20200709.2 images onwards.

If people could test and confirm that BOTH legacy and efi install now seem fine for Kubuntu ISOs, that would be great. :)

Dale Trombley (buzzmandt) wrote :

I just tested Kubuntu 20200710 linked from qtracker and it works now.
Bug appears fixed.

On Fri, Jul 10, 2020 at 4:06 AM Rik Mills <email address hidden>
wrote:

> For Kubuntu ISOs:
>
> At least in testing in a VM, adjusting the live and ship-live seeds to
> make sure both include 'shim-signed' and 'grub-pc' packages, seems to
> have worked around the issue in legacy bios installs. i.e. in 20200709.2
> images onwards.
>
> If people could test and confirm that BOTH legacy and efi install now
> seem fine for Kubuntu ISOs, that would be great. :)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1886085).
> https://bugs.launchpad.net/bugs/1885414
>
> Title:
> on flavours ubiquity: bootloader failed on /dev/vda
>
> Status in ubiquity package in Ubuntu:
> Triaged
> Status in ubiquity source package in Groovy:
> Triaged
>
> Bug description:
> Testing the 2020-06-28 ubuntu-mate iso on QEMU (QuickEMU)
> Selected Normal and 3rd party installation.
> Installation looked to be going fine until it got to grub2 installation
> part
> Came up with the following error:
>
> https://i.imgur.com/IanRMYk.jpg
>
> Had to do screenshot as apport is crashing and unable to submit bug
> via ubuntu-bug:
>
> https://i.imgur.com/dqYcKqb.png
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1885414/+subscriptions
>

--

*Truck driver, Linux Tech, Webmaster, and Web Admin.Volunteer Kubuntu Linux
Development Tester*

Mike Glover (mikeglover) wrote :

Tested Ubuntu MATE 20200711 iso:
BIOS fails to install.
EFI works fine.

Paul Howarth (paul-how) wrote :

Tested Ubuntu MATE 20200716 iso:
BIOS fails to install, same message as original bug description, though apport successfully submitted.
EFI works fine.

Leó Kolbeinsson (leok) wrote :

Testing the 2020-07-16 ubuntu-mate iso on VirtualBox

Selected Normal installation. Normal until "installing the grub2 package#

Received the following error: bootloader install failed (as superuser)-

Sorry, an error occurred and it was not possible to install the boat loader at the speceified location. /dev/sda

Bill (franksmcb) (franksmcb) wrote :

Tested in QEMU in Legacy mode with 20200722 Ubuntu MATE ISO and issue still occurs.

Norbert (nrbrtx) wrote :

Still happens with MATE 20200801 - can't install GRUB on MBR/legacy system.

Norbert (nrbrtx) wrote :

Xubuntu 20200805 (from http://cdimage.ubuntu.com/xubuntu/daily-live/current/groovy-desktop-amd64.iso ), QuickEMU MBR - fails to install GRUB bootloader

Rik Mills (rikmills) on 2020-08-05
Changed in kubuntu-meta (Ubuntu Groovy):
status: New → Fix Released
Norbert (nrbrtx) wrote :

Ubuntu Budgie 20200805, QuickEMU MBR - fails to install GRUB bootloader

Norbert (nrbrtx) wrote :

Kubuntu, Lubuntu and Ubuntu were installed normally on MBR/legacy.

Norbert (nrbrtx) wrote :

Ubuntu Kylin daily (from http://cdimage.ubuntu.com/ubuntukylin/focal/daily-live/20200804/groovy-desktop-amd64.iso ) fails to install GRUB on MBR/legacy system.

Norbert (nrbrtx) wrote :

Ubuntu MATE 20200805.1 ISO fixes the issue.

Changed in ubuntu-mate-meta (Ubuntu Groovy):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-budgie-meta (Ubuntu):
status: New → Confirmed
Changed in ubuntukylin-meta (Ubuntu):
status: New → Confirmed
Changed in xubuntu-meta (Ubuntu):
status: New → Confirmed
fossfreedom (fossfreedom) wrote :

Hopefully todays daily build for UB will be ok - I've copied the ship-live and live changes from Mate to Budgie

Changed in ubuntu-budgie-meta (Ubuntu Groovy):
assignee: nobody → fossfreedom (fossfreedom)
importance: Undecided → High
status: Confirmed → Fix Committed
Jags Desai (jagsdesai) wrote :

Bootloader installation still fails with Aug 06, 2020 ISO of Ubuntu MATE Groovy 20.10 in a VirtualBox VM.

Host OS: Ubuntu MATE 20.04
VirtualBox Version: VirtualBox-6.1.97-139689-Linux_amd64

Right when I tried to partition manually there were warnings that I never saw up until Ubuntu MATE Focal 20.04

Warning #1:
"No EFI System Partition was found. This system will likely not be able to boot successfully, and the installation process may fail. Please go back and add an EFI System Partition, or continue at your own risk".

and upon clicking "Continue", installer displayed:

Warning #2:
"The partition table format in use on your disks normally requires you to create a separate partition for boot loader code. This partition should be marked as a "Reserved BIOS boot area" and should be at leat 1 MB in size. Note that thi is not the same as a partition mounted on /boot.

If you do not go back to the partitioning menu and correct this error, boot loader installation may fail later, although it may still be possible to install the boot loader to a partition".

I have submitted 2 similar bug reports on July 06, and Aug 01, bug report #1886580 and #1889989.

Today, I could not submit bug report from within the installation as Apport kept displaying a message, "Collecting problem information". I waited for 20+ minutes but it did not bring a window from where I can submit a bug report.

Here's Imgur album with 7 screenshots:

https://imgur.com/a/fgaxBoc

Norbert (nrbrtx) wrote :

@Jags Desai (jagsdesai)

Installing without ESP partition seem to be currently impossible, so please allow its creation and then GRUB will be installed on legacy and/or EFI system.

The ESP partition was introduced after 18.04 LTS. For now all systems have two partitions after installation - ESP and rootfs.

So please do tests correctly - as described in http://iso.qa.ubuntu.com/qatracker/milestones/413/builds/218647/testcases/1300/results for example.

Norbert (nrbrtx) wrote :

@fossfreedom (fossfreedom)

UB 20200806 installs normally on legacy system.

Jags Desai (jagsdesai) wrote :

@nrbrtx (Norbert)

Ok. Also, just to be extra clear, "Enable EFI" was NOT selected in the VirtualBox settings, and the host machine is also with old-style BIOS (no UEFI at all).

#1: Do I have to create two small partitions, (1) EFI system partition, and (2) Reserved BIOS boot area... or just one, EFI system partition?

#2: From the link you provided, point #11 says, "Full drive space is allocated for installation"

So does manual partitioning (meaning not allocating the full drive space) blocked / not allowed anymore with Ubuntu / Ubuntu MATE 20.10 onward?

Thanks alot.

Changed in ubuntu-budgie-meta (Ubuntu Groovy):
status: Fix Committed → Fix Released
Norbert (nrbrtx) wrote :

UbuntuKylin 20200811 installed normally on legacy.

Changed in ubuntukylin-meta (Ubuntu Groovy):
status: Confirmed → Fix Released
Gene Soo (genesoo77072) wrote :

I have been trying Xubuntu 20.10 Daily Build and as of today, this issue seems to prevent it from being installed.

Guilherme Campos (cheker) wrote :

Still happens on xubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments