missing installer icon on liveCD desktop

Bug #188221 reported by Steve Langasek on 2008-02-01
26
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned
Declined for Hardy by Brian Murray

Bug Description

Binary package hint: ubiquity

This appears to be a separate bug from the other reports about missing graphics in the alpha4 installer. When I boot the hardy alpha4 amd64 desktop CD, my 'install' icon on the desktop is a generic document icon.

There is also a 'rofs' icon on the desktop, probably related to the new gvfs and its desire to add icons for all removable volumes; so not an ubiquity or casper bug.

Related branches

Changed in ubiquity:
status: New → Confirmed
Savvas Radevic (medigeek) wrote :

Confirming. I've seen it as well, amd64 alpha-4 livecd.

Savvas Radevic (medigeek) wrote :
mwacky (mileswacker) wrote :

I can confirm the missing icon on the Desktop i386 alpha-4 livecd.

Changed in ubiquity:
importance: Undecided → Medium
Patrice Vetsel (vetsel-patrice) wrote :

Also on Alpha5

Savvas Radevic (medigeek) wrote :

alpha 5 will be released in 2 days
Or have I missed something?

Patrice Vetsel (vetsel-patrice) wrote :

@Sawas : i use pre-Alpha5 because i do some tests from http://iso.qa.ubuntu.com/

Manudwarf (manudwarf) wrote :

The problem is that the icon of ubiquity is not in the /usr/share/icon folder but in its own folder (/usr/share/ubiquity).
Two solutions :
- change the icon folder
- change .desktop file related to ubiquity-frontend-gtk package

Colin Watson (cjwatson) wrote :

It's actually in /usr/share/pixmaps. Has this become wrong? It used to work ...

Evan (ev) wrote :

No, it has not become wrong. Per fdo's icon theme specification:
"Icons and themes are looked for in a set of directories. By default, apps should look in $HOME/.icons (for backwards compatibility), in $XDG_DATA_DIRS/icons and in /usr/share/pixmaps (in that order)."

The problem was the .png suffix, which is no longer legal.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.7.12

---------------
ubiquity (1.7.12) hardy; urgency=low

  [ Colin Watson ]
  * Slight shell efficiency improvement in
    partman/check.d/03partition_too_small.
  * Use 'autoreconf -fi' so that Autotools files reliably get upgraded.
  * Upgrade to gettext 0.17.

  [ Evan Dandrea ]
  * Update partman_popup with respect to other recent changes
    (LP: #194688). Thanks Colin Watson.
  * Regain root when moving /etc/default/console-setup out of the way
    (LP: #188492). Thanks Colin Watson.
  * Minor changes to ubiquity-dm from suggestions by Colin Watson.
  * Remove suffix from icon path in .desktop file (LP: #188221).

  [ Jonathan Riddell ]
  * Fix QApplication args in ubiquity/frontend/kde_ui.py

 -- Jonathan Riddell <email address hidden> Mon, 25 Feb 2008 10:13:27 -0500

Changed in ubiquity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers