downloading and installing updates may result in stray packages installed

Bug #1874310 reported by Dimitri John Ledkov
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned
Focal
Medium
Unassigned
Groovy
Medium
Unassigned

Bug Description

downloading and installing updates may result in stray packages installed

I am on OEM certified machine with nvidia graphics driver card.

I chose to use nonfree & download/install updates.

in target i ended up with manual linux-modules-nvidia-440-generic-hwe-20.04 package
and automatically installed linux-image-5.4.0-26-generic linux-modules-5.4.0-26-generic linux-modules-nvidia-440-5.4.0-26-generic.

Which is ok, they are extra.

It sounds like we are installing downloaded updates, rather than attempting a new dist-upgrade in target with cached downloads.

tags: added: rls-gg-incoming
Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-20.04.1
Changed in ubiquity (Ubuntu Focal):
importance: Undecided → Medium
Changed in ubiquity (Ubuntu Groovy):
importance: Undecided → Medium
milestone: ubuntu-20.04.1 → none
Changed in ubiquity (Ubuntu Groovy):
status: New → Triaged
Changed in ubiquity (Ubuntu Focal):
status: New → Triaged
tags: added: id-5ebd64b60df3a98fbb63c846
tags: removed: rls-gg-incoming
tags: added: fr-339
Revision history for this message
Balint Reczey (rbalint) wrote :

This seems to be a design decision rather than a miss to minimize the upgrades during installation.
We _can_ change that by running an apt dist-upgrade before doing anything else and that would probably also fix LP: #1871268.

Revision history for this message
Balint Reczey (rbalint) wrote :

@xnox I've verified the issue on real HW, but not an OEM certified one. You mentioned that both having and nvidia card and being oem certified can be emulated in qemu. Could you please give some pointers about that?
I've found LP: #1882795 which suggests that this testing method is incomplete yet.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

actually i think the issue is deeper; and we _always_ installed two sets of nvidia packages.

I think we have fixed this for the .2 release of focal however.

Revision history for this message
Brian Murray (brian-murray) wrote :

The Groovy Gorilla has reached end of life, so this bug will not be fixed for that release

Changed in ubiquity (Ubuntu Groovy):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers