Country base system Locales is wrong

Bug #1872186 reported by kokoye2007  on 2020-04-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
localechooser (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
Unassigned

Bug Description

Country / City Base Locales system is wrong

When we choose Yangon
Our National Wide Official is Myanmar (Burma)
my_MM (bur_MM)

but locales is Mon
mnw_MM

someone explain about alphabet sort.

its wrong. is alphabet sort
us is must be ar_US, not en_US

We can export and can be use this data.
https://en.wikipedia.org/wiki/List_of_official_languages_by_country_and_territory

ref:
https://en.wikipedia.org/wiki/Myanmar

Dimitri John Ledkov (xnox) wrote :

Can you help to explain what you do, and what goes wrong?

Are you using installer, and select myanmar and then it defaults to the wrong code?

Gunnar Hjalmarsson (gunnarhj) wrote :

@Dimitri: This ubuntu-translators list message might help explain:

https://lists.ubuntu.com/archives/ubuntu-translators/2020-April/007644.html

So yes, it's the installer which picks the locale for regional formats a bit arbitrarily. Basically a duplicate of bug #1747637 and/or bug #1763025.

Dimitri John Ledkov (xnox) wrote :

Thank you Gunnar!

tags: added: ubiquity
Dimitri John Ledkov (xnox) wrote :

$ grep UTF-8 /usr/share/i18n/SUPPORTED | grep _MM
mnw_MM UTF-8
my_MM UTF-8
shn_MM UTF-8

the first one wins. I'm not sure we we can reorder entries in that file.

or patch the vendored patch to localechooser in ubiquity to do this.

Specifically:

deflang variable as selected in https://git.launchpad.net/ubiquity/tree/d-i/patches/localechooser-post-base-installer.patch#n46

and the duplication of that in https://git.launchpad.net/ubiquity/tree/scripts/localechooser-apply#n45

Yes Dimitri
its sort from locales
but

grep UTF-8 /usr/share/i18n/SUPPORTED | grep _US
chr_US UTF-8
en_US.UTF-8 UTF-8
eo_US.UTF-8 UTF-8
es_US.UTF-8 UTF-8
unm_US UTF-8
yi_US.UTF-8 UTF-8

but en_US is official

we must be support like

https://en.wikipedia.org/wiki/List_of_official_languages_by_country_and_territory

On Thu, Jun 11, 2020 at 8:50 AM Dimitri John Ledkov <
<email address hidden>> wrote:

> $ grep UTF-8 /usr/share/i18n/SUPPORTED | grep _MM
> mnw_MM UTF-8
> my_MM UTF-8
> shn_MM UTF-8
>
> the first one wins. I'm not sure we we can reorder entries in that file.
>
> or patch the vendored patch to localechooser in ubiquity to do this.
>
> Specifically:
>
> deflang variable as selected in
> https://git.launchpad.net/ubiquity/tree/d-i/patches/localechooser-post-
> base-installer.patch#n46
> <https://git.launchpad.net/ubiquity/tree/d-i/patches/localechooser-post-base-installer.patch#n46>
>
> and the duplication of that in
> https://git.launchpad.net/ubiquity/tree/scripts/localechooser-apply#n45
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1872186
>
> Title:
> Country base system Locales is wrong
>
> Status in localechooser package in Ubuntu:
> New
>
> Bug description:
> Country / City Base Locales system is wrong
>
>
> When we choose Yangon
> Our National Wide Official is Myanmar (Burma)
> my_MM (bur_MM)
>
> but locales is Mon
> mnw_MM
>
> someone explain about alphabet sort.
>
> its wrong. is alphabet sort
> us is must be ar_US, not en_US
>
> We can export and can be use this data.
>
> https://en.wikipedia.org/wiki/List_of_official_languages_by_country_and_territory
>
> ref:
> https://en.wikipedia.org/wiki/Myanmar
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/localechooser/+bug/1872186/+subscriptions
>

--

with regards *Ko Ko Ye`*

+95 97989 22022
+95 94500 22022
+95 9731 47907
<email address hidden>
<email address hidden>

skype: kokoye2007
jitsi: kokoye2007

http://ubuntu-mm.net
http://wiki.ubuntu.com/kokoye2007
http://wiki.ubuntu.com/MyanmarTeam http://loco.ubuntu.com/teams/ubuntu-mm

kokoye2007  (kokoye2007) wrote :

we must be add

Specifically:

deflang variable as selected in
https://git.launchpad.net/ubiquity/tree/d-i/patches/localechooser-post-
base-installer.patch#n46

and the duplication of that in
https://git.launchpad.net/ubiquity/tree/scripts/localechooser-apply#n45

      MM) deflang=my ;;

On Thu, Jun 11, 2020 at 9:33 AM Ko Ko Ye` <email address hidden> wrote:

> Yes Dimitri
> its sort from locales
> but
>
> grep UTF-8 /usr/share/i18n/SUPPORTED | grep _US
> chr_US UTF-8
> en_US.UTF-8 UTF-8
> eo_US.UTF-8 UTF-8
> es_US.UTF-8 UTF-8
> unm_US UTF-8
> yi_US.UTF-8 UTF-8
>
> but en_US is official
>
> we must be support like
>
>
> https://en.wikipedia.org/wiki/List_of_official_languages_by_country_and_territory
>
> On Thu, Jun 11, 2020 at 8:50 AM Dimitri John Ledkov <
> <email address hidden>> wrote:
>
>> $ grep UTF-8 /usr/share/i18n/SUPPORTED | grep _MM
>> mnw_MM UTF-8
>> my_MM UTF-8
>> shn_MM UTF-8
>>
>> the first one wins. I'm not sure we we can reorder entries in that file.
>>
>> or patch the vendored patch to localechooser in ubiquity to do this.
>>
>> Specifically:
>>
>> deflang variable as selected in
>> https://git.launchpad.net/ubiquity/tree/d-i/patches/localechooser-post-
>> base-installer.patch#n46
>> <https://git.launchpad.net/ubiquity/tree/d-i/patches/localechooser-post-base-installer.patch#n46>
>>
>> and the duplication of that in
>> https://git.launchpad.net/ubiquity/tree/scripts/localechooser-apply#n45
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1872186
>>
>> Title:
>> Country base system Locales is wrong
>>
>> Status in localechooser package in Ubuntu:
>> New
>>
>> Bug description:
>> Country / City Base Locales system is wrong
>>
>>
>> When we choose Yangon
>> Our National Wide Official is Myanmar (Burma)
>> my_MM (bur_MM)
>>
>> but locales is Mon
>> mnw_MM
>>
>> someone explain about alphabet sort.
>>
>> its wrong. is alphabet sort
>> us is must be ar_US, not en_US
>>
>> We can export and can be use this data.
>>
>> https://en.wikipedia.org/wiki/List_of_official_languages_by_country_and_territory
>>
>> ref:
>> https://en.wikipedia.org/wiki/Myanmar
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/localechooser/+bug/1872186/+subscriptions
>>
>
>
> --
>
> with regards *Ko Ko Ye`*
>
> +95 97989 22022
> +95 94500 22022
> +95 9731 47907
> <email address hidden>
> <email address hidden>
>
> skype: kokoye2007
> jitsi: kokoye2007
>
> http://ubuntu-mm.net
> http://wiki.ubuntu.com/kokoye2007
> http://wiki.ubuntu.com/MyanmarTeam http://loco.ubuntu.com/teams/ubuntu-mm
>

--

with regards *Ko Ko Ye`*

+95 97989 22022
+95 94500 22022
+95 9731 47907
<email address hidden>
<email address hidden>

skype: kokoye2007
jitsi: kokoye2007

http://ubuntu-mm.net
http://wiki.ubuntu.com/kokoye2007
http://wiki.ubuntu.com/MyanmarTeam http://loco.ubuntu.com/teams/ubuntu-mm

kokoye2007  (kokoye2007) wrote :

 MM) deflang=my ;;

Ref

deflang variable as selected in
https://git.launchpad.net/ubiquity/tree/d-i/patches/localechooser-post-
base-installer.patch#n46

and the duplication of that in
https://git.launchpad.net/ubiquity/tree/scripts/localechooser-apply#n45

affects: localechooser (Ubuntu) → ubiquity (Ubuntu)
Gunnar Hjalmarsson (gunnarhj) wrote :

That's interesting, @kokoye2007. It seems like this has already been carefully considered.

Maybe worth mentioning that there is a parallel in form of the file /usr/share/language-tools/main-countries (belonging to accountsservice) which is used to be able to pick the main locale out from the pure language code. So

$ /usr/share/language-tools/language2locale en
en_US.UTF-8
$ /usr/share/language-tools/language2locale fr
fr_FR.UTF-8

(That is run on 'locale -a' output, though, but same idea.)

Gunnar Hjalmarsson (gunnarhj) wrote :

And no, @Dimitri, reordering SUPPORTED (from glibc) is probably not a reasonable approach. There is a need for some kind of hard coded mapping.

Changed in ubiquity (Ubuntu):
status: New → Fix Committed
Changed in localechooser (Ubuntu):
status: New → Won't Fix
Changed in localechooser (Ubuntu Focal):
status: New → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 20.10.11

---------------
ubiquity (20.10.11) groovy; urgency=medium

  [ Jean-Baptiste Lallement ]
  * Remove popularity-contest.
  * Initialize text variables to fix crash in OEM mode (LP: #1898029)

  [ Sebastien Bacher ]
  * Updated translations (LP: #1897444)

  [ Dimitri John Ledkov ]
  * oem-config.target: Correct name of the NetworkManager.service unit
    (LP: #1665384)
  * localechooser.patch: set my (Burmese) as the default Myanmar language.
    (LP: #1872186)

 -- Dimitri John Ledkov <email address hidden> Wed, 14 Oct 2020 13:18:26 +0100

Changed in ubiquity (Ubuntu Groovy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers