file system creation in partition failed in auto-resize install 18.04.4

Bug #1861912 reported by Bill (franksmcb) on 2020-02-04

This bug report will be marked for expiration in 37 days if no further activity occurs. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned

Bug Description

32bit ISO testing.

Ubuntu MATE 18.04.4 20200203.1

Lenovo T60

When trying to install and use auto-resize on 32bit system the installer fails and locks system with the error: The ext4 file system creation in partition#5 of SCSI3 (0,0,0) (sdb) failed.

Łukasz Zemczak (sil2100) wrote :

Is it possible to get more ubiquity/partman logs? Also, a very useful test would be to run the exact same steps using the 18.04.3 images and see if it works there or not.

Bill (franksmcb) (franksmcb) wrote :

Sadly during the process it hangs completely and there are no logs available.

I can complete an entire disk installation with the .4 isos.

This system has been used for ISO testing with the .3 releases and works correctly.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1861912

tags: added: iso-testing
Bill (franksmcb) (franksmcb) wrote :

18.4.3 point release installs correctly using auto-resize.

Ran SMART tests on disk and it shows OK.

Michael Hudson-Doyle (mwhudson) wrote :

I managed to reproduce this, although I don't think I was being offered the autoresize option but rather it was trying to install "alongside" the "install" that was on the install media. (certainly, sdb was the install media for me, and I got the same message)

Michael Hudson-Doyle (mwhudson) wrote :

Here's /var/log from a failed install attempt with debug-ubiquity on the kernel command line.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Walter Lapchynski (wxl) on 2020-02-05
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
Jean-Baptiste Lallement (jibel) wrote :

@Michael, your syslog is truncated and doesn't show any error. Any chance to have the full log or if there is nothing else in the logs, that you can see what is stuck when this error happens?

Julian Andres Klode (juliank) wrote :

mwhudson's problem is that the USB medium (sdb) he was installing from had more free space than the actual disk (sda) in the system, and partman-auto wrongly then chose to use that free space to install to.

Now, the partitioning of installer media is somewhat weird, so it's sort of expected that you can't create a file system on there. So it's not clear whether this is the same issue as the bug report. Obviously still something that should be fixed.

Bill: Is your install medium larger than the disk in the system, or rather the free space larger than the free space on the installed system, too? Without more logs, we can't have conclusive answers. I think even just running parted -l after booting the installer would help a lot.

Julian Andres Klode (juliank) wrote :

Also, did you use the same install medium for 18.04.3 and 18.04.4? If you used a larger USB stick for 18.04.4, that could trigger it.

@bill, there is not enough information to process this bug report. Could you at least provide more details about the state of the machine before the new installation:
- The setup of you disks
- How were they partitioned with which filesystem
- Which OS installed on which partition

And any information you might think would be useful to help us understand your setup and troubleshoot this issue.

Thanks.

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
importance: Critical → High
Bill (franksmcb) (franksmcb) wrote :

Apologies for the lack of logs. When this error occurs the system pops up with "The ext4 file system creation in partition#5 of SCSI3 (0,0,0) (sdb) failed." and locks up hard. I cannot get to a TTY.

The T60 system has an Intel 180GB SSD.
The installation media used was a 16GB USB drive.

The system exists exclusively for testing. When this error first occurred and reported the system was running Ubuntu MATE 18.04.3 from the last point release testing final release and had been installed entire disk using ext4.

The Lubuntu team asked me to recreate the issue using 18.04.3 and again I was able to recreate the issue installing using with auto-resizing.

Installing to entire disk or manually partitioning works as expected.

In subsequent errors the popup shows a different partition number...ie "partition#x of SCSI3 (0,0,0) (sdb)

What is odd in that the system when booted with the install media it shows that the OS is installed on /dev/sda and it shows the USB install media as /dev/sdb

Bill (franksmcb) (franksmcb) wrote :

If I attempt to install using 18.04.3 ISO I am able to complete an an auto-resize install as expected.

Chris Guiver (guiverc) wrote :

I tried writing ubuntu-mate 18.04.4 i386 ISO (8x) to a thumb-drive but validation failed each time until I had to go to sleep last night (new thumb drive too)
Walter (wxl) asked me to add my 2c here

Fails on Lubuntu i386 (install alongside)
http://launchpad.net/bugs/1861777
http://launchpad.net/bugs/1861788

Fail on Xubuntu i386 (install auto-resize)
http://launchpad.net/bugs/1861965

In either case I couldn't get a install alongside/auto-resize to work per testcases. In my case I had multiple drives and was trying to use SDA for 18.04.4 (the only drive I ran badblocks on for this release use)

My description/issue felt different, which is why I didn't add anything to this report earlier, but issues on same type of install.

Dan Simmons (kc2bez) wrote :

On a drive where sufficient free space was left (30GB free/ 120GB total) I was able to complete the install alongside method. The free space on my USB install media was only 12GB. My thoughts here; the bug is a lack of a graceful warning/exit when there is insufficient (greater on the HD) space.

Bill (franksmcb) (franksmcb) wrote :

I was able to get a system that had a failure attempt to allow me to grab a syslog.

Bill (franksmcb) (franksmcb) wrote :

Please note sdc at the end of syslog is the USB drive I inserted to copy the syslog file to

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers