ubiquity "failed to remove conflicting files"

Bug #186147 reported by sam tygier on 2008-01-26
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Evan
Nominated for Intrepid by andol123
Nominated for Jaunty by andol123

Bug Description

Binary package hint: ubiquity

i attempted to install ubuntu using the amd64 hardy 20080126 live cd.

my system has 2 sata disks. i asked the partition to format one of the existing partitions (sda9) as ext3 and use it as '/'

at the installing phase, the install window is says
"Creating ext3 file system for / in partition #9 of SCSI1 (0,0,0)"

then a message pops up
"Failed to remove conflicting files"
"The installer needs to remove operating system files from the install target, but was unable to do so. The install cannot continue"
pressing ok takes me back to the partitioner

sam tygier (samtygier) wrote :
sam tygier (samtygier) wrote :
sam tygier (samtygier) wrote :

just to note this occurred in the same attempt to install as Bug #186146

Nanley Chery (nanoman) wrote :

* Changing Status to confirmed *
I can confirm this on the 25th and 26th i386 daily-live cd.

Changed in ubiquity:
status: New → Confirmed
mczero (timlindner-t-online) wrote :

I can confirm it too

Milhouse (milhouse-mujweb) wrote :

Hallo.

I'm have the same problem with http://archive.ubuntu.com/ubuntu/dists/hardy/main/installer-i386/current/images/netboot/mini.iso

My HW:
Notebook Prestigio, HDD: Samsung 60GB SATA HM060II

Sorry for my english. :)

Evan (ev) on 2008-01-28
Changed in ubiquity:
assignee: nobody → evand
sam tygier (samtygier) wrote :

alpha4 install seems to have gone fine for me. i will attach the log files

sam tygier (samtygier) wrote :
Andrew Frank (frank-geoinfo) wrote :

i had the same problem (with a copy of hardy from end of jan 08) and try now with alpha4.

however: this bug left the system with a blank boot partition and it could not boot other systems still present. this is ok for alpha software and i know how to recover.

the important issue here is, that this bug reveals that the installation process is not secure. it can leave the system in a state which it does not boot what was before (and still is) on the disk (eg. other Linux, windows). even if this bug is fixed, it would be worthwhile to rethink the order of the installation process: removing/blanking the /boot disk partition should come last, when a new boot partition is ready as an image to be written (it will not likely be possible to make this a database transaction 'commit' with a single action), thus reducing the possibility that the boot partition is blanked but not written with the new boot information, independent what the cause of interrupting the installation process.

MountainX (dave-mountain) wrote :

I just got this error with alpha 6 which I downloaded and burned to CD two days ago. Are there steps I can take to resolve it?

Also, as Andrew Frank said, my system will no longer boot into Windows. Unfortunately, I don't know how to fix it like Andrew did. (It isn't the end of the world because I plan to get rid of Windows anyway, but it would be nice to be able to boot into it right now...)

Evan (ev) wrote :

Is anyone able to reproduce this with the final 8.04 CD? The code in question underwent numerous revisions prior to release and I believe this bug was fixed.

If you are able to reproduce the bug, please attach a fresh /var/log/syslog and /var/log/partman from the install environment.

Thanks!

Changed in ubiquity:
status: Confirmed → Incomplete
importance: Undecided → High
Evan (ev) wrote :

I'm marking this as fixed released, as it's been nearly 4 months since my previous question asking if anyone is able to reproduce this, and I suspect the issue has been fixed in one of the later revisions. If someone finds later that they are experiencing this bug, please feel free to reopen this bug report.

Thanks!

Changed in ubiquity:
status: Incomplete → Fix Released
andol123 (andol123) wrote :

I can confirm this still exist with ubuntu-8.10-desktop-amd64.iso as on 2009-04-20. It has not been fixed.

How do I fix this? I now have a fucked up / partition, grub fails with Error 15, Ubuntu won't install no matter what.. I still have files on /home (seperate partion)

> "The installer needs to remove operating system files from the install target, but was unable to do so. The install cannot continue"

I selected the / partiotion to be formatted, why is it trying to remove files from that partition? It should format that partition not remove files before formatting it.

andol123 (andol123) wrote :

I can also confirmed that the same issue happens with: ubuntu-9.04-rc-desktop-amd64.iso

andol123 (andol123) wrote :

I managed to fix it by installing ArchLinux.. then installing Ubuntu over it.. the error did not show this time.
What I did and noticed when installing ArchLinux was that I could not mount /home .. had to fsck.jfs it.. then it mounted. The same thing happened from Ubuntu install CD live session before installing ArchLinux (though I didn't fsck.jfs from the Ubuntu install cd).

MGdesigner (shoichi-chou) wrote :

I can also confirmed that the same issue happens with ubuntustudio-8.04.1 amd64 iso and also ubuntustudio 10.04.

I also found that is caused by an old partition that I keeped without format. Yes, my old /home - /dev/sda4. I found the solution is install a base system without mounting /dev/sda4. It will pass and then I fsck.jfs -f /dev/sda4. Ok,done. Then reboot reinstall Ubuntu, this time "failed to remove conflicting files" is disappeared. :)

Sean Collins (sean4u-gmail) wrote :

I have a Dell Mini 9 currently installing 11.04 i386 desktop from a USB flash disk. It had 10.10 on it. I booted from the flash disk, chose the Install option and the new (is it?) "upgrade from 10.10 to 11.04" option, got a little message to say I hadn't configured any swap, was returned to the partitioner, selected my previous swap partition to be used as swap, and then proceeded as usual. It had been showing the narwhals and the message "Removing conflicting operating system files..." for two hours or more. I Ctrl+Alt+F1, killed the last three (two processes + their parent, can't remember exact process details) ubiquity processes, got a 'cannot continue' dialogue, and elected to go through the install again from a desktop. This time I only got the 'Erase' and 'Something else' options. I chose the 'Something else' option, selected my existing / and swap partitions to be used without formatting.

... Time passes ... I'm almost certain this second time (no reboot, it's a follow-on from the "Removing conflicting...", that I *un-checked* the 'download files' option early on in the install. I checked it the first time through. It's currently "Retrieving file 9 of 30", which seems unexpected given the unchecked download option. It's also counting down seconds to zero for each file, which seems an odd thing to do. I don't know how useful any observations are after I killed those processes, so I'll post this just to record "still happening".

Inx (jhr8888) wrote :

I'll also confirm this is "still happening" on both my 10.10 LiveCD and 'alternate' 11.04 CD.

No other distro has made this happen when keeping ("K") /home (instead of reformatting it), in order to preserve my settings & user-files. Inconvenient, but gave me an excuse to check out openSuSE 11.4, which has a beautiful installer.

I can confirm that this is still happening on 11.04 being installed from a USB Disk, when trying to install as an upgrade to my existing (11.04) installation. After trying to shut down the computer (eventually requiring a hard-off) the upgrade option had disappeared, so installing as a clean install, formatting the existing install instead, eventually worked.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers